aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-11-07 07:11:51 +0800
committeranholt <anholt@FreeBSD.org>2003-11-07 07:11:51 +0800
commit508c5dc97c2e034f1a07096559bff28f7df8933b (patch)
tree1e69eb0785bcde8d4c7c9ebca751307ea4e09aa7 /games
parent36aa5eb374a2792b6e233b60a78727c92ff9cb0a (diff)
downloadfreebsd-ports-gnome-508c5dc97c2e034f1a07096559bff28f7df8933b.tar.gz
freebsd-ports-gnome-508c5dc97c2e034f1a07096559bff28f7df8933b.tar.zst
freebsd-ports-gnome-508c5dc97c2e034f1a07096559bff28f7df8933b.zip
Use -lGLU -lGL instead of -lMesaGLU -lMesaGL
Diffstat (limited to 'games')
-rw-r--r--games/KnightCap/Makefile1
-rw-r--r--games/KnightCap/files/patch-aa7
2 files changed, 5 insertions, 3 deletions
diff --git a/games/KnightCap/Makefile b/games/KnightCap/Makefile
index 1aec49cbcdaa..ffe73a5770f9 100644
--- a/games/KnightCap/Makefile
+++ b/games/KnightCap/Makefile
@@ -7,6 +7,7 @@
PORTNAME= knightcap
PORTVERSION= 3.6
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ftp://samba.anu.edu.au/pub/KnightCap/ \
ftp://ftp.cadvision.com/pub/linuxberg/files/x11/entertain/
diff --git a/games/KnightCap/files/patch-aa b/games/KnightCap/files/patch-aa
index 1a7331194860..5c8749b6f61b 100644
--- a/games/KnightCap/files/patch-aa
+++ b/games/KnightCap/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.orig Mon May 18 08:09:21 1998
-+++ Makefile Wed Aug 9 04:55:31 2000
+--- Makefile.orig Sun May 17 16:09:21 1998
++++ Makefile Thu Nov 6 15:07:34 2003
@@ -2,11 +2,11 @@
# what C compiler? It better be Ansi-C. Use gcc if you have it.
@@ -22,11 +22,12 @@
-GLUT = /usr/local/Mesa-2.1/glut-3.2
-X11 = /usr/X11R6
-GLUT_LIBS = -L$(GLUT)/lib/glut -lglut
+-MESA_LIBS = -L$(MESA)/lib -lMesaGLU -lMesaGL -lm
+MESA = ${X11BASE}
+GLUT = ${X11BASE}
+X11 = ${X11BASE}
+GLUT_LIBS = -L$(GLUT)/lib -lglut
- MESA_LIBS = -L$(MESA)/lib -lMesaGLU -lMesaGL -lm
++MESA_LIBS = -L$(MESA)/lib -lGLU -lGL -lm
XLIBS = -L$(X11)/lib -lXmu -lXt -lXext -lX11 -lXi
-DISPLAYFLAGS = -I$(MESA)/include -I$(GLUT) -DRENDERED_DISPLAY=1
+DISPLAYFLAGS = -I$(X11)/include -I$(MESA)/include -I$(GLUT)/include -DRENDERED_DISPLAY=1