aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-05-12 02:16:18 +0800
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-05-12 02:16:18 +0800
commit56a2efb94aa71af67a9034dcef54539a84a4edc9 (patch)
tree71aed977367a76223bab6f7d44170f5eeec63a93 /games
parentb98ea14f94c37aa31888d9f3a08db3aa83c62763 (diff)
downloadfreebsd-ports-gnome-56a2efb94aa71af67a9034dcef54539a84a4edc9.tar.gz
freebsd-ports-gnome-56a2efb94aa71af67a9034dcef54539a84a4edc9.tar.zst
freebsd-ports-gnome-56a2efb94aa71af67a9034dcef54539a84a4edc9.zip
Jaymod is an add-on modification to RTCW: Enemy Territory.
The idea for Jaymod came from the main features of Shrubmod. Shrubmod has long been out of date and unsupported, and with the instability issues that come with Shrubmod, something had to be done to get a Shrub-like server-side mod that would provide most of Shrub's features, be stable, and be supported. This mod has, obviously, outgrown the original objective of being server-side only. Some of the ideas I wanted to implement could not be done with server code only, so the decision was made to start working on the client end as well. I wanted this to be as easy as possible for end users, and now only one pak needs to be downloaded (on the fly) to be able to play this mod. WWW: http://jaymod.clanfu.org/ PR: ports/93544 Approved by: garga (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/linux-enemyterritory-jaymod-21/Makefile55
-rw-r--r--games/linux-enemyterritory-jaymod-21/distinfo3
-rw-r--r--games/linux-enemyterritory-jaymod-21/pkg-descr14
-rw-r--r--games/linux-enemyterritory-jaymod-21/pkg-plist9
-rw-r--r--games/linux-enemyterritory-jaymod/Makefile55
-rw-r--r--games/linux-enemyterritory-jaymod/distinfo3
-rw-r--r--games/linux-enemyterritory-jaymod/pkg-descr14
-rw-r--r--games/linux-enemyterritory-jaymod/pkg-plist9
9 files changed, 163 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 59bfb3992f25..a5051eeacfc6 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -362,6 +362,7 @@
SUBDIR += linux-enemyterritory-etpro
SUBDIR += linux-enemyterritory-etpub
SUBDIR += linux-enemyterritory-fortress
+ SUBDIR += linux-enemyterritory-jaymod
SUBDIR += linux-enemyterritory-tce
SUBDIR += linux-goodway
SUBDIR += linux-nwnclient
diff --git a/games/linux-enemyterritory-jaymod-21/Makefile b/games/linux-enemyterritory-jaymod-21/Makefile
new file mode 100644
index 000000000000..6ef946d24627
--- /dev/null
+++ b/games/linux-enemyterritory-jaymod-21/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: jaymod
+# Date created: 7 May 2006
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= jaymod
+PORTVERSION= 1.4
+CATEGORIES= games linux
+MASTER_SITES= http://jaymod.clanfu.org/lib/downloads/ \
+ http://budjb.com/lib/downloads/ \
+ http://www.zenenterprises.org/bud/jaymod/ \
+ http://www.spherens.com/zen/et/distro/
+PKGNAMEPREFIX= linux-enemyterritory-
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Jaymod - An Enemy Territory Modification
+
+RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+USE_LINUX= yes
+NO_WRKSUBDIR= yes
+
+DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/enemyterritory-${PORTNAME}
+
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+do-build:
+.for f in et etded
+ @(${ECHO} "#!/bin/sh"; \
+ ${ECHO} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME} "$$@"') > \
+ ${WRKSRC}/${f}-${PORTNAME}
+.endfor
+
+do-install:
+.for f in et etded
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
+.endfor
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/qagame.mp.i386.so ${DATADIR}
+.for f in jaymod-${PORTVERSION}.pk3 jaymod.cfg-sample
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in jaymod-${PORTVERSION}.pdf readme.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/linux-enemyterritory-jaymod-21/distinfo b/games/linux-enemyterritory-jaymod-21/distinfo
new file mode 100644
index 000000000000..a8abf3bcf14a
--- /dev/null
+++ b/games/linux-enemyterritory-jaymod-21/distinfo
@@ -0,0 +1,3 @@
+MD5 (jaymod-1.4.tar.gz) = 86e69f4985c5c10be9ee61b15abb9292
+SHA256 (jaymod-1.4.tar.gz) = 41b1f9fa51724c67867c2c2805441277fc4f35fe10253157c718a0619570ba77
+SIZE (jaymod-1.4.tar.gz) = 4189340
diff --git a/games/linux-enemyterritory-jaymod-21/pkg-descr b/games/linux-enemyterritory-jaymod-21/pkg-descr
new file mode 100644
index 000000000000..44cf28808f72
--- /dev/null
+++ b/games/linux-enemyterritory-jaymod-21/pkg-descr
@@ -0,0 +1,14 @@
+Jaymod is an add-on modification to RTCW: Enemy Territory.
+
+The idea for Jaymod came from the main features of Shrubmod. Shrubmod has
+long been out of date and unsupported, and with the instability issues that
+come with Shrubmod, something had to be done to get a Shrub-like server-side
+mod that would provide most of Shrub's features, be stable, and be supported.
+
+This mod has, obviously, outgrown the original objective of being server-side
+only. Some of the ideas I wanted to implement could not be done with server
+code only, so the decision was made to start working on the client end as
+well. I wanted this to be as easy as possible for end users, and now only one
+pak needs to be downloaded (on the fly) to be able to play this mod.
+
+WWW: http://jaymod.clanfu.org/
diff --git a/games/linux-enemyterritory-jaymod-21/pkg-plist b/games/linux-enemyterritory-jaymod-21/pkg-plist
new file mode 100644
index 000000000000..6d34d90d85dd
--- /dev/null
+++ b/games/linux-enemyterritory-jaymod-21/pkg-plist
@@ -0,0 +1,9 @@
+bin/et-jaymod
+bin/etded-jaymod
+%%PORTDOCS%%%%DOCSDIR%%/jaymod-%%VERSION%%.pdf
+%%DATADIR%%/jaymod-%%VERSION%%.pk3
+%%DATADIR%%/jaymod.cfg-sample
+%%DATADIR%%/qagame.mp.i386.so
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/games/linux-enemyterritory-jaymod/Makefile b/games/linux-enemyterritory-jaymod/Makefile
new file mode 100644
index 000000000000..6ef946d24627
--- /dev/null
+++ b/games/linux-enemyterritory-jaymod/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: jaymod
+# Date created: 7 May 2006
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= jaymod
+PORTVERSION= 1.4
+CATEGORIES= games linux
+MASTER_SITES= http://jaymod.clanfu.org/lib/downloads/ \
+ http://budjb.com/lib/downloads/ \
+ http://www.zenenterprises.org/bud/jaymod/ \
+ http://www.spherens.com/zen/et/distro/
+PKGNAMEPREFIX= linux-enemyterritory-
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Jaymod - An Enemy Territory Modification
+
+RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+USE_LINUX= yes
+NO_WRKSUBDIR= yes
+
+DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/enemyterritory-${PORTNAME}
+
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+do-build:
+.for f in et etded
+ @(${ECHO} "#!/bin/sh"; \
+ ${ECHO} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME} "$$@"') > \
+ ${WRKSRC}/${f}-${PORTNAME}
+.endfor
+
+do-install:
+.for f in et etded
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
+.endfor
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/qagame.mp.i386.so ${DATADIR}
+.for f in jaymod-${PORTVERSION}.pk3 jaymod.cfg-sample
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in jaymod-${PORTVERSION}.pdf readme.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/linux-enemyterritory-jaymod/distinfo b/games/linux-enemyterritory-jaymod/distinfo
new file mode 100644
index 000000000000..a8abf3bcf14a
--- /dev/null
+++ b/games/linux-enemyterritory-jaymod/distinfo
@@ -0,0 +1,3 @@
+MD5 (jaymod-1.4.tar.gz) = 86e69f4985c5c10be9ee61b15abb9292
+SHA256 (jaymod-1.4.tar.gz) = 41b1f9fa51724c67867c2c2805441277fc4f35fe10253157c718a0619570ba77
+SIZE (jaymod-1.4.tar.gz) = 4189340
diff --git a/games/linux-enemyterritory-jaymod/pkg-descr b/games/linux-enemyterritory-jaymod/pkg-descr
new file mode 100644
index 000000000000..44cf28808f72
--- /dev/null
+++ b/games/linux-enemyterritory-jaymod/pkg-descr
@@ -0,0 +1,14 @@
+Jaymod is an add-on modification to RTCW: Enemy Territory.
+
+The idea for Jaymod came from the main features of Shrubmod. Shrubmod has
+long been out of date and unsupported, and with the instability issues that
+come with Shrubmod, something had to be done to get a Shrub-like server-side
+mod that would provide most of Shrub's features, be stable, and be supported.
+
+This mod has, obviously, outgrown the original objective of being server-side
+only. Some of the ideas I wanted to implement could not be done with server
+code only, so the decision was made to start working on the client end as
+well. I wanted this to be as easy as possible for end users, and now only one
+pak needs to be downloaded (on the fly) to be able to play this mod.
+
+WWW: http://jaymod.clanfu.org/
diff --git a/games/linux-enemyterritory-jaymod/pkg-plist b/games/linux-enemyterritory-jaymod/pkg-plist
new file mode 100644
index 000000000000..6d34d90d85dd
--- /dev/null
+++ b/games/linux-enemyterritory-jaymod/pkg-plist
@@ -0,0 +1,9 @@
+bin/et-jaymod
+bin/etded-jaymod
+%%PORTDOCS%%%%DOCSDIR%%/jaymod-%%VERSION%%.pdf
+%%DATADIR%%/jaymod-%%VERSION%%.pk3
+%%DATADIR%%/jaymod.cfg-sample
+%%DATADIR%%/qagame.mp.i386.so
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%