aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-01-13 10:33:42 +0800
committeralepulver <alepulver@FreeBSD.org>2007-01-13 10:33:42 +0800
commit58846825a603d2e7134421fb645ba9beaddef984 (patch)
tree2c8e3230a02b4fb596fc55ddd2dbea60af9e0ae6 /games
parent986a7f803ed3e11b64f155e149e7e17f2d9a3eac (diff)
downloadfreebsd-ports-gnome-58846825a603d2e7134421fb645ba9beaddef984.tar.gz
freebsd-ports-gnome-58846825a603d2e7134421fb645ba9beaddef984.tar.zst
freebsd-ports-gnome-58846825a603d2e7134421fb645ba9beaddef984.zip
- Add -fPIC compiler flag to the shared library sources (recently a static
library was converted to shared) to fix building on amd64. Reported by: pointyhat
Diffstat (limited to 'games')
-rw-r--r--games/quakeforge/files/patch-libs__video__renderer__sw__Makefile.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/games/quakeforge/files/patch-libs__video__renderer__sw__Makefile.in b/games/quakeforge/files/patch-libs__video__renderer__sw__Makefile.in
new file mode 100644
index 000000000000..6fd5eb615889
--- /dev/null
+++ b/games/quakeforge/files/patch-libs__video__renderer__sw__Makefile.in
@@ -0,0 +1,23 @@
+--- ./libs/video/renderer/sw/Makefile.in.orig Sun May 2 17:52:12 2004
++++ ./libs/video/renderer/sw/Makefile.in Fri Jan 12 23:26:27 2007
+@@ -403,8 +403,8 @@
+ target_vendor = @target_vendor@
+ vid_libs = @vid_libs@
+ AUTOMAKE_OPTIONS = foreign
+-AM_CFLAGS = @PREFER_NON_PIC@
+-AM_CCASFLAGS = @PREFER_NON_PIC@
++AM_CFLAGS = @PREFER_PIC@
++AM_CCASFLAGS = @PREFER_PIC@
+ INCLUDES = -I$(top_srcdir)/include
+ @ASM_ARCH_FALSE@asm =
+ @ASM_ARCH_TRUE@asm = libasm.la
+@@ -422,9 +422,7 @@
+ sw_redge.c sw_rmain.c sw_rmisc.c sw_rpart.c sw_rsky.c sw_rsprite.c \
+ sw_rsurf.c sw_skin.c
+
+-libasm_la_LDFLAGS = @STATIC@
+ libasm_la_SOURCES = $(asm_src)
+-libsw_la_LDFLAGS = @STATIC@
+ libsw_la_SOURCES = $(sw_src)
+ @ASM_ARCH_TRUE@libsw_la_LIBADD = $(asm)
+ @ASM_ARCH_TRUE@libsw_la_DEPENDENCIES = $(asm)