aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-01-30 06:58:11 +0800
committerJason Helfman <jgh@FreeBSD.org>2013-01-30 06:58:11 +0800
commit58864c0fe88ed2235f90e59d022f58e7b02f3658 (patch)
treea406293f00418aa0880fc742c367a67df77f42e8 /games
parent5fa373cdbfd26f06705de45aefbde7ad9c8d3838 (diff)
downloadfreebsd-ports-gnome-58864c0fe88ed2235f90e59d022f58e7b02f3658.tar.gz
freebsd-ports-gnome-58864c0fe88ed2235f90e59d022f58e7b02f3658.tar.zst
freebsd-ports-gnome-58864c0fe88ed2235f90e59d022f58e7b02f3658.zip
- add new port: games/chocolate-doom
Chocolate Doom is a port of ID Software's Doom, Doom II, and Final Doom to modern operating systems that aims to be as compatible with the original DOS executable as possible. This includes emulating all the different versions, playing demos perfectly accurately, playing "vanilla-only" PWADS, and netcode that works on newer operating systems while still behaving the same as "vanilla" Doom. WWW: http://chocolate-doom.org PR: 161701 Submitted by: jakub_lach@mailplus.pl
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/chocolate-doom/Makefile35
-rw-r--r--games/chocolate-doom/distinfo2
-rw-r--r--games/chocolate-doom/files/patch-d__iwad.c12
-rw-r--r--games/chocolate-doom/pkg-descr8
-rw-r--r--games/chocolate-doom/pkg-message6
-rw-r--r--games/chocolate-doom/pkg-plist11
7 files changed, 75 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 1f9f5f83df5c..4458591ef151 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -126,6 +126,7 @@
SUBDIR += cgoban
SUBDIR += chanta
SUBDIR += chapping
+ SUBDIR += chocolate-doom
SUBDIR += cheech
SUBDIR += childsplay
SUBDIR += childsplay_plugins
diff --git a/games/chocolate-doom/Makefile b/games/chocolate-doom/Makefile
new file mode 100644
index 000000000000..1754cb73c6c6
--- /dev/null
+++ b/games/chocolate-doom/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= chocolate-doom
+PORTVERSION= 1.7.0
+CATEGORIES= games
+MASTER_SITES= SF
+
+MAINTAINER= jakub_lach@mailplus.pl
+COMMENT= Doom port that aims to be compatible with the original exe
+
+LICENSE= GPLv2
+
+USE_GMAKE= yes
+USE_SDL= mixer net sdl
+USE_PYTHON= 2.5+
+MAKE_JOBS_SAFE= yes
+GNU_CONFIGURE= yes
+
+MAN5= chocolate-doom.cfg.5 default.cfg.5
+MAN6= chocolate-doom.6 chocolate-server.6 chocolate-setup.6
+PORTDOCS= CMDLINE ChangeLog HACKING INSTALL NEWS NOT-BUGS README README.OPL
+
+.include "${.CURDIR}/../doom-data/Makefile.include"
+
+.include <bsd.port.options.mk>
+
+post-patch-script:
+ ${REINPLACE_CMD} -e 's|gamesdir = $$(prefix)/games|gamesdir = $$(prefix)/bin|' \
+ ${WRKSRC}/src/Makefile.in ${WRKSRC}/setup/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/HACKING ${DOCSDIR}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/games/chocolate-doom/distinfo b/games/chocolate-doom/distinfo
new file mode 100644
index 000000000000..aeb2b2d07dd1
--- /dev/null
+++ b/games/chocolate-doom/distinfo
@@ -0,0 +1,2 @@
+SHA256 (chocolate-doom-1.7.0.tar.gz) = c1cffb602e3cc3a82941b4675b9dc816a6e419076faf8f54db46df397f86bfc0
+SIZE (chocolate-doom-1.7.0.tar.gz) = 1091798
diff --git a/games/chocolate-doom/files/patch-d__iwad.c b/games/chocolate-doom/files/patch-d__iwad.c
new file mode 100644
index 000000000000..d822a034654e
--- /dev/null
+++ b/games/chocolate-doom/files/patch-d__iwad.c
@@ -0,0 +1,12 @@
+--- src/d_iwad.c 2011-05-17 16:01:48.000000000 -0700
++++ src/d_iwad.c 2011-10-15 11:30:26.998495197 -0700
+@@ -559,8 +559,7 @@
+
+ // Standard places where IWAD files are installed under Unix.
+
+- AddIWADDir("/usr/share/games/doom");
+- AddIWADDir("/usr/local/share/games/doom");
++ AddIWADDir("/usr/local/share/doom");
+
+ #endif
+
diff --git a/games/chocolate-doom/pkg-descr b/games/chocolate-doom/pkg-descr
new file mode 100644
index 000000000000..9af3ee9290a9
--- /dev/null
+++ b/games/chocolate-doom/pkg-descr
@@ -0,0 +1,8 @@
+Chocolate Doom is a port of ID Software's Doom, Doom II, and Final Doom to
+modern operating systems that aims to be as compatible with the original DOS
+executable as possible. This includes emulating all the different versions,
+playing demos perfectly accurately, playing "vanilla-only" PWADS, and netcode
+that works on newer operating systems while still behaving the same as
+"vanilla" Doom.
+
+WWW: http://chocolate-doom.org
diff --git a/games/chocolate-doom/pkg-message b/games/chocolate-doom/pkg-message
new file mode 100644
index 000000000000..847af4226051
--- /dev/null
+++ b/games/chocolate-doom/pkg-message
@@ -0,0 +1,6 @@
+**************************************************************
+
+To enable OPL MIDI emulation you need to run chocolate-setup,
+default Native MIDI is very similar to Roland SC-55.
+
+**************************************************************
diff --git a/games/chocolate-doom/pkg-plist b/games/chocolate-doom/pkg-plist
new file mode 100644
index 000000000000..05b46953e3fe
--- /dev/null
+++ b/games/chocolate-doom/pkg-plist
@@ -0,0 +1,11 @@
+share/icons/chocolate-doom.png
+share/icons/chocolate-setup.png
+share/applications/chocolate-doom.desktop
+share/applications/screensavers/chocolate-doom-screensaver.desktop
+share/applications/chocolate-setup.desktop
+bin/chocolate-doom
+bin/chocolate-server
+bin/chocolate-setup
+@dirrmtry share/icons
+@dirrmtry share/applications/screensavers
+@dirrmtry share/applications