aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-09-05 03:26:24 +0800
committerantoine <antoine@FreeBSD.org>2014-09-05 03:26:24 +0800
commit59d49e15cacdc386288d1958cdc1c291dcd919bc (patch)
tree7fe589d0d1b0e6d00b7aa9cd05fc46ca15de7655 /games
parent990841b6170cce720b6df85c358d10065e9a7fa4 (diff)
downloadfreebsd-ports-gnome-59d49e15cacdc386288d1958cdc1c291dcd919bc.tar.gz
freebsd-ports-gnome-59d49e15cacdc386288d1958cdc1c291dcd919bc.tar.zst
freebsd-ports-gnome-59d49e15cacdc386288d1958cdc1c291dcd919bc.zip
Change INSTALL_DATA to install with mode 644
Remove patches and hacks that were used to work around the previous situation This allows to stage more ports as a regular user Differential Revision: https://reviews.freebsd.org/D703 Reviewed by and discussed with: bapt With hat: portmgr
Diffstat (limited to 'games')
-rw-r--r--games/pinball/Makefile4
-rw-r--r--games/tetrinet-x/Makefile8
2 files changed, 6 insertions, 6 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index fff17aaa10a6..cec224e989d7 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -36,10 +36,10 @@ LDFLAGS+= -L${LOCALBASE}/lib
DOCS= README
-# For gmake>=3.82 + ranlib runs twice
+# For gmake>=3.82
pre-configure:
${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
- ${REINPLACE_CMD} -e 's,^dnl,# dnl,;/echo.*RANLIB/,+1d'
+ ${REINPLACE_CMD} -e 's,^dnl,# dnl,'
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/games/tetrinet-x/Makefile b/games/tetrinet-x/Makefile
index 38b833890091..36b01e230626 100644
--- a/games/tetrinet-x/Makefile
+++ b/games/tetrinet-x/Makefile
@@ -27,10 +27,10 @@ do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/bin/tetrix.freebsd ${STAGEDIR}${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/bin/server-query ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} -m 644 ${WRKSRC}/bin/game.conf ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} -m 644 ${WRKSRC}/bin/game.log ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} -m 644 ${WRKSRC}/bin/game.secure ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} -m 644 ${WRKSRC}/bin/game.winlist ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/game.conf ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/game.log ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/game.secure ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/game.winlist ${STAGEDIR}${DATADIR}
${INSTALL_SCRIPT} -m 751 ${WRKDIR}/tetrinetx ${STAGEDIR}${PREFIX}/etc/rc.d
.include <bsd.port.mk>