aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-29 01:20:42 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-29 01:20:42 +0800
commit5c572259877cd7ca5a4290778fe5ebabf9dfb2a0 (patch)
treeacb73643f4fe5f57790ed056215bc1db842b57ce /games
parent8edd9d818ed2c5af206b6d8566c6a4502218b89b (diff)
downloadfreebsd-ports-gnome-5c572259877cd7ca5a4290778fe5ebabf9dfb2a0.tar.gz
freebsd-ports-gnome-5c572259877cd7ca5a4290778fe5ebabf9dfb2a0.tar.zst
freebsd-ports-gnome-5c572259877cd7ca5a4290778fe5ebabf9dfb2a0.zip
Implemented complete support for test target.
You can now `make test' on any port to run test sequence, no-op by default. If a port defines TEST_TARGET, it'll run sub-make with specified target, usually `check' or `test', useful if upstream supports that. The port may instead define custom do-test target, as well as usual satellite targets: {pre,do,post}-test, {pre,do,post}-test-OPT, {pre,do,post}-test-OPT-off `make test' builds and stages port first, so test may use both WRKDIR and STAGEDIR, and both BUILD and RUN depends are available for test target. Additionally, TEST_DEPENDS is now properly supported and may be used to define additional depends specifically for testing. Framework may define default tests for specific cases. For instance, perl5.mk and cran.mk already provide default test target on their own. This commit also converts my ports which have tests to this new framework. Approved by: portmgr (bapt) Differential Revision: D3680
Diffstat (limited to 'games')
-rw-r--r--games/spring/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/games/spring/Makefile b/games/spring/Makefile
index 0b3807956a2e..be891c1d9583 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -52,6 +52,9 @@ LEI_PREFIX= ${LOCALBASE}
# Do not exctract bundled copies of header files for 3rd-party packages:
EXTRACT_AFTER_ARGS=--no-same-owner --no-same-permissions --exclude ${WRKSRC:T}/include
+# The check-target fails right now: https://springrts.com/mantis/view.php?id=4736
+TEST_TARGET= check
+
PORTDOCS= *
PORTDATA= *
@@ -75,10 +78,6 @@ CXXFLAGS+= -Wno-deprecated # Too much noise
PR_DOWNLOADER_LIB_DEPENDS=libcurl.so:${PORTSDIR}/ftp/curl
-# The check-target fails right now: https://springrts.com/mantis/view.php?id=4736
-check test xregression-test: build
- ${MAKE} -C ${WRKSRC} check
-
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000