aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-11-05 19:18:07 +0800
committermiwi <miwi@FreeBSD.org>2007-11-05 19:18:07 +0800
commit5d88ed0157417357d15ad413dc80ffddbd3efb5d (patch)
tree869a7abe3f5fbd0474980ef927cd44c5be9e7851 /games
parentc48a019d962f3a8007f147097ac747be937ef26e (diff)
downloadfreebsd-ports-gnome-5d88ed0157417357d15ad413dc80ffddbd3efb5d.tar.gz
freebsd-ports-gnome-5d88ed0157417357d15ad413dc80ffddbd3efb5d.tar.zst
freebsd-ports-gnome-5d88ed0157417357d15ad413dc80ffddbd3efb5d.zip
- Fix build with gcc 4.2
PR: 117732 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> Approved by: portmgr (pav), maintainer
Diffstat (limited to 'games')
-rw-r--r--games/mangband/Makefile8
-rw-r--r--games/mangband/files/patch-server-netserver.c11
2 files changed, 12 insertions, 7 deletions
diff --git a/games/mangband/Makefile b/games/mangband/Makefile
index 7f8edbd50de7..ffa64f38c0f7 100644
--- a/games/mangband/Makefile
+++ b/games/mangband/Makefile
@@ -36,10 +36,4 @@ do-install:
${CHOWN} -R root:games ${MALIB}/*
${CHOWN} ${SHAREOWN}:${SHAREGRP} ${MALIB}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/mangband/files/patch-server-netserver.c b/games/mangband/files/patch-server-netserver.c
new file mode 100644
index 000000000000..2911ce88153d
--- /dev/null
+++ b/games/mangband/files/patch-server-netserver.c
@@ -0,0 +1,11 @@
+--- server/netserver.c.orig 2001-01-02 04:02:10.000000000 +0000
++++ server/netserver.c 2007-11-01 04:27:06.000000000 +0000
+@@ -98,7 +98,7 @@
+ (*drain_receive[256])(int ind);
+ int login_in_progress;
+ static int num_logins, num_logouts;
+-static long Id;
++long Id;
+ int NumPlayers;
+
+ int MetaSocket = -1;