aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-09-04 23:45:01 +0800
committerjylefort <jylefort@FreeBSD.org>2005-09-04 23:45:01 +0800
commit5eb85bfe97c2537b1cafef7f16ba493f00c96fe2 (patch)
treeca527e65bccfc759ffa112c9455abb2ac6b1e3cd /games
parentf7b70cc756e583de138a9faa8834d6bedf4f0354 (diff)
downloadfreebsd-ports-gnome-5eb85bfe97c2537b1cafef7f16ba493f00c96fe2.tar.gz
freebsd-ports-gnome-5eb85bfe97c2537b1cafef7f16ba493f00c96fe2.tar.zst
freebsd-ports-gnome-5eb85bfe97c2537b1cafef7f16ba493f00c96fe2.zip
Add a missing runtime dependency on libGL.
Reported by: kris Approved by: maintainer
Diffstat (limited to 'games')
-rw-r--r--games/linux-ut2003-demo/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/games/linux-ut2003-demo/Makefile b/games/linux-ut2003-demo/Makefile
index a7c6ca36cbc7..bb1bd5777626 100644
--- a/games/linux-ut2003-demo/Makefile
+++ b/games/linux-ut2003-demo/Makefile
@@ -41,6 +41,18 @@ PORTDOCS= *
LIBDIRS= Animations Benchmark ForceFeedback KarmaData Maps Music \
Sounds StaticMeshes System Textures Web
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3
+.if defined(WITH_NVIDIA_GL)
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+.else
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+.endif
+.else
+RUN_DEPENDS+= ${LINUXBASE}/lib/libGL.so.1:${PORTSDIR}/graphics/linux_glx
+.endif
+
do-extract:
@${MKDIR} ${WRKSRC}
@cd ${WRKSRC} && ${TAIL} -c +6360 ${_DISTDIR}/${DISTFILES} | ${TAR} zxf -
@@ -82,4 +94,4 @@ do-install:
. endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>