aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-21 13:39:29 +0800
committeraz <az@FreeBSD.org>2013-09-21 13:39:29 +0800
commit5f97c6c27ab4a5f860ded8f44fd933a682a353f1 (patch)
treef4e03747a25c95c9522b3f0a7afefea08f5dcfdc /games
parent68850a551ecde7a5da22df40ffa79ba5772cc576 (diff)
downloadfreebsd-ports-gnome-5f97c6c27ab4a5f860ded8f44fd933a682a353f1.tar.gz
freebsd-ports-gnome-5f97c6c27ab4a5f860ded8f44fd933a682a353f1.tar.zst
freebsd-ports-gnome-5f97c6c27ab4a5f860ded8f44fd933a682a353f1.zip
- restore build, pkgconfig explicitly needed now in global context
Approved by: danfe@ (maintainer, via email)
Diffstat (limited to 'games')
-rw-r--r--games/openttd/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 0c8e953d2f2b..0f442da165c6 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
lzo2:${PORTSDIR}/archivers/lzo2
-USES= gmake
+USES= gmake pkgconfig
USE_XZ= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= STRIP="${STRIP_CMD} ${STRIP}"
@@ -47,7 +47,6 @@ CONFIGURE_ARGS+= --with-midi-arg="${WITH_MIDI_PLAYER_ARGS}"
.endif
.if defined(WITH_DEDICATED_SERVER_ONLY)
-USES+= pkgconfig # Needed for liblzma support
CONFIGURE_ARGS+= --enable-dedicated
# Aid it to find lzo2 headers; client build gets it via sdl-config
CFLAGS+= -I${LOCALBASE}/include