aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
committermat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
commit60e51bda11dcc0742419f2a459990d0d81cb07d8 (patch)
treea5029ff30555b3a7ee0621f4dd5aacb832fde1d8 /games
parent3432585b4743642027fc2b3af5eac2780fc2c4cd (diff)
downloadfreebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.gz
freebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.zst
freebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.zip
Use USES=pathfix where applicable.
PR: 213195 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D8093
Diffstat (limited to 'games')
-rw-r--r--games/liblcf/Makefile1
-rw-r--r--games/poker-engine/Makefile7
-rw-r--r--games/py-poker-eval/Makefile2
-rw-r--r--games/py-poker-eval/files/patch-Makefile.am9
-rw-r--r--games/qqwing/Makefile1
5 files changed, 2 insertions, 18 deletions
diff --git a/games/liblcf/Makefile b/games/liblcf/Makefile
index 72fa56d7914a..19861dd6243d 100644
--- a/games/liblcf/Makefile
+++ b/games/liblcf/Makefile
@@ -18,7 +18,6 @@ USE_GITHUB= yes
GH_ACCOUNT= EasyRPG
USES= autoreconf compiler:c++11-lib libtool pathfix pkgconfig
-PATHFIX_MAKEFILEIN= Makefile.am
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/games/poker-engine/Makefile b/games/poker-engine/Makefile
index 31b84147ad9d..d39083cc89f8 100644
--- a/games/poker-engine/Makefile
+++ b/games/poker-engine/Makefile
@@ -22,14 +22,9 @@ RUN_DEPENDS= ${LOCALBASE}/bin/rsync:net/rsync \
${PYTHON_SITELIBDIR}/libxml2.py:textproc/py-libxml2 \
${PYTHON_SITELIBDIR}/libxslt.py:textproc/py-libxslt
-USES= gettext gmake pkgconfig python:2
+USES= gettext gmake pathfix pkgconfig python:2
GNU_CONFIGURE= yes
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|{datadir}/pkgconfig|(prefix)/libdata/pkgconfig|g' \
- ${WRKSRC}/Makefile.in
-
test:
@cd ${WRKSRC} && ${MAKE_CMD} check
diff --git a/games/py-poker-eval/Makefile b/games/py-poker-eval/Makefile
index 137db624a9bd..8c54a82d69d9 100644
--- a/games/py-poker-eval/Makefile
+++ b/games/py-poker-eval/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpoker-eval.so:games/poker-eval
-USES= autoreconf libtool pkgconfig python:2
+USES= autoreconf libtool pathfix pkgconfig python:2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= PYTHON=""
diff --git a/games/py-poker-eval/files/patch-Makefile.am b/games/py-poker-eval/files/patch-Makefile.am
index fa26c192a91a..914e0ad9840b 100644
--- a/games/py-poker-eval/files/patch-Makefile.am
+++ b/games/py-poker-eval/files/patch-Makefile.am
@@ -15,12 +15,3 @@
if PYTHON_2_6
py2_6exec_LTLIBRARIES = _pokereval_2_6.la
_pokereval_2_6_la_SOURCES = pypokereval.c
-@@ -64,7 +72,7 @@
- _pokereval_2_3_la_CFLAGS = ${PYTHON2_3_CFLAGS} ${POKER_EVAL_CFLAGS} -DPYTHON_VERSION=\"2_3\" -D'VERSION_NAME(w)=w\#\#2_3'
- endif
-
--pkgconfigdir = ${libdir}/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = pypoker-eval.pc
-
- EXTRA_DIST = config/python.m4 config/ccpython.m4 \
diff --git a/games/qqwing/Makefile b/games/qqwing/Makefile
index f716ad4f3cfe..09b8e9dad7d0 100644
--- a/games/qqwing/Makefile
+++ b/games/qqwing/Makefile
@@ -17,7 +17,6 @@ USES= autoreconf gmake libtool pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_OUTSOURCE= yes
-PATHFIX_MAKEFILEIN= Makefile.am
AUTORECONF_WRKSRC= ${WRKSRC}/build
CONFIGURE_CMD= ${AUTORECONF_WRKSRC}/configure
INSTALL_TARGET= install-strip