aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2004-05-02 12:41:36 +0800
committerpetef <petef@FreeBSD.org>2004-05-02 12:41:36 +0800
commit620f1d55354102108ebd3ea5db12076693b3fa42 (patch)
tree731cd88c904c35d06efce98a42039ef5bc6b35a2 /games
parentce950de6019c6b76cd15b7aa0157777c79257574 (diff)
downloadfreebsd-ports-gnome-620f1d55354102108ebd3ea5db12076693b3fa42.tar.gz
freebsd-ports-gnome-620f1d55354102108ebd3ea5db12076693b3fa42.tar.zst
freebsd-ports-gnome-620f1d55354102108ebd3ea5db12076693b3fa42.zip
- update to 4.6.4
- move to sourceforge - add OPTIONS support for SDL PR: 66002 Submitted by: maintainer
Diffstat (limited to 'games')
-rw-r--r--games/xpilot-ng-client/Makefile34
-rw-r--r--games/xpilot-ng-client/distinfo4
-rw-r--r--games/xpilot-ng-client/files/patch-aa11
-rw-r--r--games/xpilot-ng-client/files/patch-ba11
-rw-r--r--games/xpilot-ng-client/files/patch-ca11
-rw-r--r--games/xpilot-ng-client/files/patch-da11
-rw-r--r--games/xpilot-ng-client/files/patch-ea11
-rw-r--r--games/xpilot-ng-client/pkg-plist36
-rw-r--r--games/xpilot-ng-server/Makefile34
-rw-r--r--games/xpilot-ng-server/distinfo4
-rw-r--r--games/xpilot-ng-server/files/patch-aa11
-rw-r--r--games/xpilot-ng-server/files/patch-ba11
-rw-r--r--games/xpilot-ng-server/files/patch-ca11
-rw-r--r--games/xpilot-ng-server/files/patch-da11
-rw-r--r--games/xpilot-ng-server/files/patch-ea11
-rw-r--r--games/xpilot-ng-server/pkg-plist36
-rw-r--r--games/xpilot-ng/Makefile34
-rw-r--r--games/xpilot-ng/distinfo4
-rw-r--r--games/xpilot-ng/files/patch-aa11
-rw-r--r--games/xpilot-ng/files/patch-ba11
-rw-r--r--games/xpilot-ng/files/patch-ca11
-rw-r--r--games/xpilot-ng/files/patch-da11
-rw-r--r--games/xpilot-ng/files/patch-ea11
-rw-r--r--games/xpilot-ng/pkg-plist36
24 files changed, 165 insertions, 222 deletions
diff --git a/games/xpilot-ng-client/Makefile b/games/xpilot-ng-client/Makefile
index b2cdc3df0fc7..653ba7f66ce6 100644
--- a/games/xpilot-ng-client/Makefile
+++ b/games/xpilot-ng-client/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= xpilot-ng
-PORTVERSION= 4.5.4X2
-PORTREVISION= 2
+PORTVERSION= 4.6.4
CATEGORIES= games
-MASTER_SITES= http://www.hut.fi/~ksoderbl/xpilot/
-DISTNAME= xpilot-${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xpilot
MAINTAINER= jylefort@brutele.be
COMMENT= An enhanced version of XPilot
@@ -19,11 +18,32 @@ LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-MAN6= xp-mapedit-ng.6 xp-replay-ng.6 xpilot-ng.6 xpilots-ng.6
+MAN6= xpilot-ng-replay.6 \
+ xpilot-ng-sdl.6 \
+ xpilot-ng-server.6 \
+ xpilot-ng-x11.6
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS= --program-suffix=-ng
+CONFIGURE_ARGS= --program-prefix=""
-.include <bsd.port.mk>
+OPTIONS= SDL "SDL/OpenGL client" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SDL)
+USE_SDL= image sdl ttf
+CONFIGURE_ARGS+= --enable-sdl-client
+PLIST_SUB+= WITH_SDL=""
+USE_GCC= 3.2
+.else
+PLIST_SUB+= WITH_SDL="@comment "
+.endif
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's,#include "SDL/,#include "SDL11/,g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/games/xpilot-ng-client/distinfo b/games/xpilot-ng-client/distinfo
index 364400b6497b..4288f3b0ffb5 100644
--- a/games/xpilot-ng-client/distinfo
+++ b/games/xpilot-ng-client/distinfo
@@ -1,2 +1,2 @@
-MD5 (xpilot-4.5.4X2.tar.gz) = cbe107324a129c360bcf026ee3f31ff5
-SIZE (xpilot-4.5.4X2.tar.gz) = 1054360
+MD5 (xpilot-ng-4.6.4.tar.gz) = 23e4495c755251f72d5dd525e8dfa420
+SIZE (xpilot-ng-4.6.4.tar.gz) = 1662416
diff --git a/games/xpilot-ng-client/files/patch-aa b/games/xpilot-ng-client/files/patch-aa
deleted file mode 100644
index d0357939cf49..000000000000
--- a/games/xpilot-ng-client/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.in.orig Thu Sep 11 03:29:50 2003
-+++ lib/Makefile.in Thu Sep 11 03:30:00 2003
-@@ -18,7 +18,7 @@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(datadir)/xpilot-ng
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ..
-
diff --git a/games/xpilot-ng-client/files/patch-ba b/games/xpilot-ng-client/files/patch-ba
deleted file mode 100644
index 4754cf1fabd8..000000000000
--- a/games/xpilot-ng-client/files/patch-ba
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/maps/Makefile.in.orig Thu Sep 11 03:32:17 2003
-+++ lib/maps/Makefile.in Thu Sep 11 03:32:26 2003
-@@ -18,7 +18,7 @@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(datadir)/xpilot-ng
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ../..
-
diff --git a/games/xpilot-ng-client/files/patch-ca b/games/xpilot-ng-client/files/patch-ca
deleted file mode 100644
index d088f7a16f1c..000000000000
--- a/games/xpilot-ng-client/files/patch-ca
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/textures/Makefile.in.orig Thu Sep 11 03:32:37 2003
-+++ lib/textures/Makefile.in Thu Sep 11 03:32:54 2003
-@@ -18,7 +18,7 @@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(datadir)/xpilot-ng
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ../..
-
diff --git a/games/xpilot-ng-client/files/patch-da b/games/xpilot-ng-client/files/patch-da
deleted file mode 100644
index 1c7d18891184..000000000000
--- a/games/xpilot-ng-client/files/patch-da
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/common/Makefile.in.orig Thu Sep 11 03:28:54 2003
-+++ src/common/Makefile.in Thu Sep 11 03:29:43 2003
-@@ -18,7 +18,7 @@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(datadir)/xpilot-ng
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ../..
-
diff --git a/games/xpilot-ng-client/files/patch-ea b/games/xpilot-ng-client/files/patch-ea
deleted file mode 100644
index b16ed221fcbb..000000000000
--- a/games/xpilot-ng-client/files/patch-ea
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Mon Feb 2 00:00:41 2004
-+++ Makefile.in Mon Feb 2 00:00:49 2004
-@@ -17,7 +17,7 @@
- srcdir = @srcdir@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
--pkgdatadir = $(datadir)/@PACKAGE@
-+pkgdatadir = $(datadir)/xpilot-ng
- pkglibdir = $(libdir)/@PACKAGE@
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = .
diff --git a/games/xpilot-ng-client/pkg-plist b/games/xpilot-ng-client/pkg-plist
index 982010fb6c99..f9b1960e307e 100644
--- a/games/xpilot-ng-client/pkg-plist
+++ b/games/xpilot-ng-client/pkg-plist
@@ -1,12 +1,25 @@
-bin/xpilot-ng
-bin/xpilots-ng
-bin/xp-replay-ng
+bin/xpilot-ng-replay
+%%WITH_SDL%%bin/xpilot-ng-sdl
+bin/xpilot-ng-server
+bin/xpilot-ng-x11
+share/xpilot-ng/defaults.txt
+share/xpilot-ng/fonts/ConsoleFont.bmp
+share/xpilot-ng/fonts/FreeSansBoldOblique.ttf
+share/xpilot-ng/fonts/VeraMoBd.ttf
share/xpilot-ng/mapconvert.py
-share/xpilot-ng/maps/teamcup.xp
share/xpilot-ng/maps/polybloods.xp2
+share/xpilot-ng/maps/sadistic_bastard_v2.xp2
+share/xpilot-ng/maps/teamcup.xp
+share/xpilot-ng/password.txt
+share/xpilot-ng/robots.txt
+share/xpilot-ng/sounds.txt
+share/xpilot-ng/textures/acwise_grav.ppm
share/xpilot-ng/textures/allitems.ppm
+share/xpilot-ng/textures/asteroid.ppm
share/xpilot-ng/textures/asteroidconcentrator.ppm
share/xpilot-ng/textures/ball.ppm
+share/xpilot-ng/textures/ball_gray.ppm
+share/xpilot-ng/textures/ball_gray16.ppm
share/xpilot-ng/textures/base_down.ppm
share/xpilot-ng/textures/base_left.ppm
share/xpilot-ng/textures/base_right.ppm
@@ -22,16 +35,20 @@ share/xpilot-ng/textures/cannon_up.ppm
share/xpilot-ng/textures/checkpoint.ppm
share/xpilot-ng/textures/clouds.ppm
share/xpilot-ng/textures/concentrator.ppm
+share/xpilot-ng/textures/cwise_grav.ppm
share/xpilot-ng/textures/fuel2.ppm
share/xpilot-ng/textures/fuelcell.ppm
share/xpilot-ng/textures/holder1.ppm
share/xpilot-ng/textures/holder2.ppm
share/xpilot-ng/textures/logo.ppm
+share/xpilot-ng/textures/metabtndown.png
+share/xpilot-ng/textures/metabtnup.png
share/xpilot-ng/textures/metalite.ppm
share/xpilot-ng/textures/meter.ppm
share/xpilot-ng/textures/mine_other.ppm
share/xpilot-ng/textures/mine_team.ppm
share/xpilot-ng/textures/minus.ppm
+share/xpilot-ng/textures/missile.ppm
share/xpilot-ng/textures/moon.ppm
share/xpilot-ng/textures/paused.ppm
share/xpilot-ng/textures/plus.ppm
@@ -40,15 +57,17 @@ share/xpilot-ng/textures/radar2.ppm
share/xpilot-ng/textures/radar3.ppm
share/xpilot-ng/textures/refuel.ppm
share/xpilot-ng/textures/rock4.ppm
+share/xpilot-ng/textures/sdlmetabg.png
+share/xpilot-ng/textures/shield.ppm
share/xpilot-ng/textures/ship.ppm
share/xpilot-ng/textures/ship_blue.ppm
share/xpilot-ng/textures/ship_red.ppm
share/xpilot-ng/textures/ship_red2.ppm
share/xpilot-ng/textures/ship_red3.ppm
share/xpilot-ng/textures/sparks.ppm
-share/xpilot-ng/textures/wall_dl.ppm
share/xpilot-ng/textures/volcanic.ppm
share/xpilot-ng/textures/wall_bottom.ppm
+share/xpilot-ng/textures/wall_dl.ppm
share/xpilot-ng/textures/wall_dr.ppm
share/xpilot-ng/textures/wall_fi.ppm
share/xpilot-ng/textures/wall_left.ppm
@@ -59,10 +78,7 @@ share/xpilot-ng/textures/wall_ull.ppm
share/xpilot-ng/textures/wall_ur.ppm
share/xpilot-ng/textures/wall_url.ppm
share/xpilot-ng/textures/wormhole.ppm
-share/xpilot-ng/defaults
-share/xpilot-ng/password
-share/xpilot-ng/robots
-share/xpilot-ng/sounds
-@dirrm share/xpilot-ng/maps
@dirrm share/xpilot-ng/textures
+@dirrm share/xpilot-ng/maps
+@dirrm share/xpilot-ng/fonts
@dirrm share/xpilot-ng
diff --git a/games/xpilot-ng-server/Makefile b/games/xpilot-ng-server/Makefile
index b2cdc3df0fc7..653ba7f66ce6 100644
--- a/games/xpilot-ng-server/Makefile
+++ b/games/xpilot-ng-server/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= xpilot-ng
-PORTVERSION= 4.5.4X2
-PORTREVISION= 2
+PORTVERSION= 4.6.4
CATEGORIES= games
-MASTER_SITES= http://www.hut.fi/~ksoderbl/xpilot/
-DISTNAME= xpilot-${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xpilot
MAINTAINER= jylefort@brutele.be
COMMENT= An enhanced version of XPilot
@@ -19,11 +18,32 @@ LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-MAN6= xp-mapedit-ng.6 xp-replay-ng.6 xpilot-ng.6 xpilots-ng.6
+MAN6= xpilot-ng-replay.6 \
+ xpilot-ng-sdl.6 \
+ xpilot-ng-server.6 \
+ xpilot-ng-x11.6
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS= --program-suffix=-ng
+CONFIGURE_ARGS= --program-prefix=""
-.include <bsd.port.mk>
+OPTIONS= SDL "SDL/OpenGL client" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SDL)
+USE_SDL= image sdl ttf
+CONFIGURE_ARGS+= --enable-sdl-client
+PLIST_SUB+= WITH_SDL=""
+USE_GCC= 3.2
+.else
+PLIST_SUB+= WITH_SDL="@comment "
+.endif
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's,#include "SDL/,#include "SDL11/,g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/games/xpilot-ng-server/distinfo b/games/xpilot-ng-server/distinfo
index 364400b6497b..4288f3b0ffb5 100644
--- a/games/xpilot-ng-server/distinfo
+++ b/games/xpilot-ng-server/distinfo
@@ -1,2 +1,2 @@
-MD5 (xpilot-4.5.4X2.tar.gz) = cbe107324a129c360bcf026ee3f31ff5
-SIZE (xpilot-4.5.4X2.tar.gz) = 1054360
+MD5 (xpilot-ng-4.6.4.tar.gz) = 23e4495c755251f72d5dd525e8dfa420
+SIZE (xpilot-ng-4.6.4.tar.gz) = 1662416
diff --git a/games/xpilot-ng-server/files/patch-aa b/games/xpilot-ng-server/files/patch-aa
deleted file mode 100644
index d0357939cf49..000000000000
--- a/games/xpilot-ng-server/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.in.orig Thu Sep 11 03:29:50 2003
-+++ lib/Makefile.in Thu Sep 11 03:30:00 2003
-@@ -18,7 +18,7 @@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(datadir)/xpilot-ng
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ..
-
diff --git a/games/xpilot-ng-server/files/patch-ba b/games/xpilot-ng-server/files/patch-ba
deleted file mode 100644
index 4754cf1fabd8..000000000000
--- a/games/xpilot-ng-server/files/patch-ba
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/maps/Makefile.in.orig Thu Sep 11 03:32:17 2003
-+++ lib/maps/Makefile.in Thu Sep 11 03:32:26 2003
-@@ -18,7 +18,7 @@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(datadir)/xpilot-ng
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ../..
-
diff --git a/games/xpilot-ng-server/files/patch-ca b/games/xpilot-ng-server/files/patch-ca
deleted file mode 100644
index d088f7a16f1c..000000000000
--- a/games/xpilot-ng-server/files/patch-ca
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/textures/Makefile.in.orig Thu Sep 11 03:32:37 2003
-+++ lib/textures/Makefile.in Thu Sep 11 03:32:54 2003
-@@ -18,7 +18,7 @@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(datadir)/xpilot-ng
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ../..
-
diff --git a/games/xpilot-ng-server/files/patch-da b/games/xpilot-ng-server/files/patch-da
deleted file mode 100644
index 1c7d18891184..000000000000
--- a/games/xpilot-ng-server/files/patch-da
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/common/Makefile.in.orig Thu Sep 11 03:28:54 2003
-+++ src/common/Makefile.in Thu Sep 11 03:29:43 2003
-@@ -18,7 +18,7 @@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(datadir)/xpilot-ng
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ../..
-
diff --git a/games/xpilot-ng-server/files/patch-ea b/games/xpilot-ng-server/files/patch-ea
deleted file mode 100644
index b16ed221fcbb..000000000000
--- a/games/xpilot-ng-server/files/patch-ea
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Mon Feb 2 00:00:41 2004
-+++ Makefile.in Mon Feb 2 00:00:49 2004
-@@ -17,7 +17,7 @@
- srcdir = @srcdir@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
--pkgdatadir = $(datadir)/@PACKAGE@
-+pkgdatadir = $(datadir)/xpilot-ng
- pkglibdir = $(libdir)/@PACKAGE@
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = .
diff --git a/games/xpilot-ng-server/pkg-plist b/games/xpilot-ng-server/pkg-plist
index 982010fb6c99..f9b1960e307e 100644
--- a/games/xpilot-ng-server/pkg-plist
+++ b/games/xpilot-ng-server/pkg-plist
@@ -1,12 +1,25 @@
-bin/xpilot-ng
-bin/xpilots-ng
-bin/xp-replay-ng
+bin/xpilot-ng-replay
+%%WITH_SDL%%bin/xpilot-ng-sdl
+bin/xpilot-ng-server
+bin/xpilot-ng-x11
+share/xpilot-ng/defaults.txt
+share/xpilot-ng/fonts/ConsoleFont.bmp
+share/xpilot-ng/fonts/FreeSansBoldOblique.ttf
+share/xpilot-ng/fonts/VeraMoBd.ttf
share/xpilot-ng/mapconvert.py
-share/xpilot-ng/maps/teamcup.xp
share/xpilot-ng/maps/polybloods.xp2
+share/xpilot-ng/maps/sadistic_bastard_v2.xp2
+share/xpilot-ng/maps/teamcup.xp
+share/xpilot-ng/password.txt
+share/xpilot-ng/robots.txt
+share/xpilot-ng/sounds.txt
+share/xpilot-ng/textures/acwise_grav.ppm
share/xpilot-ng/textures/allitems.ppm
+share/xpilot-ng/textures/asteroid.ppm
share/xpilot-ng/textures/asteroidconcentrator.ppm
share/xpilot-ng/textures/ball.ppm
+share/xpilot-ng/textures/ball_gray.ppm
+share/xpilot-ng/textures/ball_gray16.ppm
share/xpilot-ng/textures/base_down.ppm
share/xpilot-ng/textures/base_left.ppm
share/xpilot-ng/textures/base_right.ppm
@@ -22,16 +35,20 @@ share/xpilot-ng/textures/cannon_up.ppm
share/xpilot-ng/textures/checkpoint.ppm
share/xpilot-ng/textures/clouds.ppm
share/xpilot-ng/textures/concentrator.ppm
+share/xpilot-ng/textures/cwise_grav.ppm
share/xpilot-ng/textures/fuel2.ppm
share/xpilot-ng/textures/fuelcell.ppm
share/xpilot-ng/textures/holder1.ppm
share/xpilot-ng/textures/holder2.ppm
share/xpilot-ng/textures/logo.ppm
+share/xpilot-ng/textures/metabtndown.png
+share/xpilot-ng/textures/metabtnup.png
share/xpilot-ng/textures/metalite.ppm
share/xpilot-ng/textures/meter.ppm
share/xpilot-ng/textures/mine_other.ppm
share/xpilot-ng/textures/mine_team.ppm
share/xpilot-ng/textures/minus.ppm
+share/xpilot-ng/textures/missile.ppm
share/xpilot-ng/textures/moon.ppm
share/xpilot-ng/textures/paused.ppm
share/xpilot-ng/textures/plus.ppm
@@ -40,15 +57,17 @@ share/xpilot-ng/textures/radar2.ppm
share/xpilot-ng/textures/radar3.ppm
share/xpilot-ng/textures/refuel.ppm
share/xpilot-ng/textures/rock4.ppm
+share/xpilot-ng/textures/sdlmetabg.png
+share/xpilot-ng/textures/shield.ppm
share/xpilot-ng/textures/ship.ppm
share/xpilot-ng/textures/ship_blue.ppm
share/xpilot-ng/textures/ship_red.ppm
share/xpilot-ng/textures/ship_red2.ppm
share/xpilot-ng/textures/ship_red3.ppm
share/xpilot-ng/textures/sparks.ppm
-share/xpilot-ng/textures/wall_dl.ppm
share/xpilot-ng/textures/volcanic.ppm
share/xpilot-ng/textures/wall_bottom.ppm
+share/xpilot-ng/textures/wall_dl.ppm
share/xpilot-ng/textures/wall_dr.ppm
share/xpilot-ng/textures/wall_fi.ppm
share/xpilot-ng/textures/wall_left.ppm
@@ -59,10 +78,7 @@ share/xpilot-ng/textures/wall_ull.ppm
share/xpilot-ng/textures/wall_ur.ppm
share/xpilot-ng/textures/wall_url.ppm
share/xpilot-ng/textures/wormhole.ppm
-share/xpilot-ng/defaults
-share/xpilot-ng/password
-share/xpilot-ng/robots
-share/xpilot-ng/sounds
-@dirrm share/xpilot-ng/maps
@dirrm share/xpilot-ng/textures
+@dirrm share/xpilot-ng/maps
+@dirrm share/xpilot-ng/fonts
@dirrm share/xpilot-ng
diff --git a/games/xpilot-ng/Makefile b/games/xpilot-ng/Makefile
index b2cdc3df0fc7..653ba7f66ce6 100644
--- a/games/xpilot-ng/Makefile
+++ b/games/xpilot-ng/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= xpilot-ng
-PORTVERSION= 4.5.4X2
-PORTREVISION= 2
+PORTVERSION= 4.6.4
CATEGORIES= games
-MASTER_SITES= http://www.hut.fi/~ksoderbl/xpilot/
-DISTNAME= xpilot-${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xpilot
MAINTAINER= jylefort@brutele.be
COMMENT= An enhanced version of XPilot
@@ -19,11 +18,32 @@ LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-MAN6= xp-mapedit-ng.6 xp-replay-ng.6 xpilot-ng.6 xpilots-ng.6
+MAN6= xpilot-ng-replay.6 \
+ xpilot-ng-sdl.6 \
+ xpilot-ng-server.6 \
+ xpilot-ng-x11.6
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS= --program-suffix=-ng
+CONFIGURE_ARGS= --program-prefix=""
-.include <bsd.port.mk>
+OPTIONS= SDL "SDL/OpenGL client" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SDL)
+USE_SDL= image sdl ttf
+CONFIGURE_ARGS+= --enable-sdl-client
+PLIST_SUB+= WITH_SDL=""
+USE_GCC= 3.2
+.else
+PLIST_SUB+= WITH_SDL="@comment "
+.endif
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's,#include "SDL/,#include "SDL11/,g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/games/xpilot-ng/distinfo b/games/xpilot-ng/distinfo
index 364400b6497b..4288f3b0ffb5 100644
--- a/games/xpilot-ng/distinfo
+++ b/games/xpilot-ng/distinfo
@@ -1,2 +1,2 @@
-MD5 (xpilot-4.5.4X2.tar.gz) = cbe107324a129c360bcf026ee3f31ff5
-SIZE (xpilot-4.5.4X2.tar.gz) = 1054360
+MD5 (xpilot-ng-4.6.4.tar.gz) = 23e4495c755251f72d5dd525e8dfa420
+SIZE (xpilot-ng-4.6.4.tar.gz) = 1662416
diff --git a/games/xpilot-ng/files/patch-aa b/games/xpilot-ng/files/patch-aa
deleted file mode 100644
index d0357939cf49..000000000000
--- a/games/xpilot-ng/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.in.orig Thu Sep 11 03:29:50 2003
-+++ lib/Makefile.in Thu Sep 11 03:30:00 2003
-@@ -18,7 +18,7 @@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(datadir)/xpilot-ng
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ..
-
diff --git a/games/xpilot-ng/files/patch-ba b/games/xpilot-ng/files/patch-ba
deleted file mode 100644
index 4754cf1fabd8..000000000000
--- a/games/xpilot-ng/files/patch-ba
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/maps/Makefile.in.orig Thu Sep 11 03:32:17 2003
-+++ lib/maps/Makefile.in Thu Sep 11 03:32:26 2003
-@@ -18,7 +18,7 @@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(datadir)/xpilot-ng
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ../..
-
diff --git a/games/xpilot-ng/files/patch-ca b/games/xpilot-ng/files/patch-ca
deleted file mode 100644
index d088f7a16f1c..000000000000
--- a/games/xpilot-ng/files/patch-ca
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/textures/Makefile.in.orig Thu Sep 11 03:32:37 2003
-+++ lib/textures/Makefile.in Thu Sep 11 03:32:54 2003
-@@ -18,7 +18,7 @@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(datadir)/xpilot-ng
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ../..
-
diff --git a/games/xpilot-ng/files/patch-da b/games/xpilot-ng/files/patch-da
deleted file mode 100644
index 1c7d18891184..000000000000
--- a/games/xpilot-ng/files/patch-da
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/common/Makefile.in.orig Thu Sep 11 03:28:54 2003
-+++ src/common/Makefile.in Thu Sep 11 03:29:43 2003
-@@ -18,7 +18,7 @@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(datadir)/xpilot-ng
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ../..
-
diff --git a/games/xpilot-ng/files/patch-ea b/games/xpilot-ng/files/patch-ea
deleted file mode 100644
index b16ed221fcbb..000000000000
--- a/games/xpilot-ng/files/patch-ea
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Mon Feb 2 00:00:41 2004
-+++ Makefile.in Mon Feb 2 00:00:49 2004
-@@ -17,7 +17,7 @@
- srcdir = @srcdir@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
--pkgdatadir = $(datadir)/@PACKAGE@
-+pkgdatadir = $(datadir)/xpilot-ng
- pkglibdir = $(libdir)/@PACKAGE@
- pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = .
diff --git a/games/xpilot-ng/pkg-plist b/games/xpilot-ng/pkg-plist
index 982010fb6c99..f9b1960e307e 100644
--- a/games/xpilot-ng/pkg-plist
+++ b/games/xpilot-ng/pkg-plist
@@ -1,12 +1,25 @@
-bin/xpilot-ng
-bin/xpilots-ng
-bin/xp-replay-ng
+bin/xpilot-ng-replay
+%%WITH_SDL%%bin/xpilot-ng-sdl
+bin/xpilot-ng-server
+bin/xpilot-ng-x11
+share/xpilot-ng/defaults.txt
+share/xpilot-ng/fonts/ConsoleFont.bmp
+share/xpilot-ng/fonts/FreeSansBoldOblique.ttf
+share/xpilot-ng/fonts/VeraMoBd.ttf
share/xpilot-ng/mapconvert.py
-share/xpilot-ng/maps/teamcup.xp
share/xpilot-ng/maps/polybloods.xp2
+share/xpilot-ng/maps/sadistic_bastard_v2.xp2
+share/xpilot-ng/maps/teamcup.xp
+share/xpilot-ng/password.txt
+share/xpilot-ng/robots.txt
+share/xpilot-ng/sounds.txt
+share/xpilot-ng/textures/acwise_grav.ppm
share/xpilot-ng/textures/allitems.ppm
+share/xpilot-ng/textures/asteroid.ppm
share/xpilot-ng/textures/asteroidconcentrator.ppm
share/xpilot-ng/textures/ball.ppm
+share/xpilot-ng/textures/ball_gray.ppm
+share/xpilot-ng/textures/ball_gray16.ppm
share/xpilot-ng/textures/base_down.ppm
share/xpilot-ng/textures/base_left.ppm
share/xpilot-ng/textures/base_right.ppm
@@ -22,16 +35,20 @@ share/xpilot-ng/textures/cannon_up.ppm
share/xpilot-ng/textures/checkpoint.ppm
share/xpilot-ng/textures/clouds.ppm
share/xpilot-ng/textures/concentrator.ppm
+share/xpilot-ng/textures/cwise_grav.ppm
share/xpilot-ng/textures/fuel2.ppm
share/xpilot-ng/textures/fuelcell.ppm
share/xpilot-ng/textures/holder1.ppm
share/xpilot-ng/textures/holder2.ppm
share/xpilot-ng/textures/logo.ppm
+share/xpilot-ng/textures/metabtndown.png
+share/xpilot-ng/textures/metabtnup.png
share/xpilot-ng/textures/metalite.ppm
share/xpilot-ng/textures/meter.ppm
share/xpilot-ng/textures/mine_other.ppm
share/xpilot-ng/textures/mine_team.ppm
share/xpilot-ng/textures/minus.ppm
+share/xpilot-ng/textures/missile.ppm
share/xpilot-ng/textures/moon.ppm
share/xpilot-ng/textures/paused.ppm
share/xpilot-ng/textures/plus.ppm
@@ -40,15 +57,17 @@ share/xpilot-ng/textures/radar2.ppm
share/xpilot-ng/textures/radar3.ppm
share/xpilot-ng/textures/refuel.ppm
share/xpilot-ng/textures/rock4.ppm
+share/xpilot-ng/textures/sdlmetabg.png
+share/xpilot-ng/textures/shield.ppm
share/xpilot-ng/textures/ship.ppm
share/xpilot-ng/textures/ship_blue.ppm
share/xpilot-ng/textures/ship_red.ppm
share/xpilot-ng/textures/ship_red2.ppm
share/xpilot-ng/textures/ship_red3.ppm
share/xpilot-ng/textures/sparks.ppm
-share/xpilot-ng/textures/wall_dl.ppm
share/xpilot-ng/textures/volcanic.ppm
share/xpilot-ng/textures/wall_bottom.ppm
+share/xpilot-ng/textures/wall_dl.ppm
share/xpilot-ng/textures/wall_dr.ppm
share/xpilot-ng/textures/wall_fi.ppm
share/xpilot-ng/textures/wall_left.ppm
@@ -59,10 +78,7 @@ share/xpilot-ng/textures/wall_ull.ppm
share/xpilot-ng/textures/wall_ur.ppm
share/xpilot-ng/textures/wall_url.ppm
share/xpilot-ng/textures/wormhole.ppm
-share/xpilot-ng/defaults
-share/xpilot-ng/password
-share/xpilot-ng/robots
-share/xpilot-ng/sounds
-@dirrm share/xpilot-ng/maps
@dirrm share/xpilot-ng/textures
+@dirrm share/xpilot-ng/maps
+@dirrm share/xpilot-ng/fonts
@dirrm share/xpilot-ng