aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-12-30 12:18:26 +0800
committeredwin <edwin@FreeBSD.org>2005-12-30 12:18:26 +0800
commit65b29f8d7ac274b0aab47e40f37afe64afcea958 (patch)
treee0fd604fc12c98683efd193d2b6fc02c5e8a62b5 /games
parent861e5559f3dce9e6a0c1c9d79033d394d49e537f (diff)
downloadfreebsd-ports-gnome-65b29f8d7ac274b0aab47e40f37afe64afcea958.tar.gz
freebsd-ports-gnome-65b29f8d7ac274b0aab47e40f37afe64afcea958.tar.zst
freebsd-ports-gnome-65b29f8d7ac274b0aab47e40f37afe64afcea958.zip
[New port] games/q3base
Q3Base is a fork of Quake III Arena. Its advantage is that it has a lot of bugfixes, including support for FreeBSD out of the box. It also uses GNU Autoconf/Automake and works with BSD Make, thus removing the dependency on Perl and GNU Make. It's also more compact than Quake III Arena - 1.4 MB .tar.bz2 vs 5.5 MB .zip. PR: ports/89213 Submitted by: Ed Schouten <ed@fxq.nl>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/q3base/Makefile44
-rw-r--r--games/q3base/distinfo3
-rw-r--r--games/q3base/files/pkg-message.in25
-rw-r--r--games/q3base/pkg-descr13
-rw-r--r--games/q3base/pkg-plist14
-rw-r--r--games/quake3-q3base/Makefile44
-rw-r--r--games/quake3-q3base/distinfo3
-rw-r--r--games/quake3-q3base/files/pkg-message.in25
-rw-r--r--games/quake3-q3base/pkg-descr13
-rw-r--r--games/quake3-q3base/pkg-plist14
11 files changed, 199 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 99f5b57c2a15..f0623cc166ca 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -473,6 +473,7 @@
SUBDIR += quake3-excessive
SUBDIR += quake3-freezetag
SUBDIR += quake3-osp
+ SUBDIR += quake3-q3base
SUBDIR += quake3-ra3
SUBDIR += quake3-ut
SUBDIR += quake3-wfa
diff --git a/games/q3base/Makefile b/games/q3base/Makefile
new file mode 100644
index 000000000000..b4a66f1f395a
--- /dev/null
+++ b/games/q3base/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: q3base
+# Date created: 17 Nov 2005
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= q3base
+PORTVERSION= 0.1
+CATEGORIES= games
+MASTER_SITES= http://quake3.quakesrc.org/files/quake3/q3base/
+PKGNAMEPREFIX= quake3-
+
+MAINTAINER= ed@fxq.nl
+COMMENT= Quake III Arena fork using SDL
+
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+
+USE_BZIP2= yes
+USE_SDL= sdl net
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
+CONFIGURE_TARGET=
+CONFLICTS= q3server-1.32* quake3-[0-9]*
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKSRC}/pkg-message
+
+.if defined(WITHOUT_X11)
+CONFIGURE_ARGS= --disable-client
+.else
+USE_GL= yes
+USE_SDL+= image
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/quake3/baseq3
+ @${MKDIR} ${PREFIX}/share/quake3/missionpack
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/games/q3base/distinfo b/games/q3base/distinfo
new file mode 100644
index 000000000000..5a505a8a2f90
--- /dev/null
+++ b/games/q3base/distinfo
@@ -0,0 +1,3 @@
+MD5 (q3base-0.1.tar.bz2) = d68f1fd6d10ecf428e85f98d43d2abd8
+SHA256 (q3base-0.1.tar.bz2) = f4b78e9cf95df438c56976850dd5ba66716ac2ed0bb6ddf5e6e9f5d797244baf
+SIZE (q3base-0.1.tar.bz2) = 1510780
diff --git a/games/q3base/files/pkg-message.in b/games/q3base/files/pkg-message.in
new file mode 100644
index 000000000000..199dc1eeafbc
--- /dev/null
+++ b/games/q3base/files/pkg-message.in
@@ -0,0 +1,25 @@
+========================================================================
+
+In order to play Quake III Arena or Quake III Team Arena, you need to
+copy the non-free data-files from the CD to:
+
+ %%PREFIX%%/share/quake3
+
+For Quake III Arena, you need to have pak0.pk3 to pak8.pk3 stored in the
+'baseq3' directory. Quake III Team Arena also needs pak0.pk3 stored in
+the 'missionpack' directory.
+
+Below is a list of pk3 files, including their MD5 checksums:
+
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak0.pk3) = 1197ca3df1e65f3c380f8abc10ca43bf
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak1.pk3) = 48911719d91be25adb957f2d325db4a0
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak2.pk3) = d550ce896130c47166ca44b53f8a670a
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak3.pk3) = 968dfd0f30dad67056115c8e92344ddc
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak4.pk3) = 24bb1f4fcabd95f6e320c0e2f62f19ca
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak5.pk3) = 734dcd06d2cbc7a16432ff6697f1c5ba
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak6.pk3) = 873888a73055c023f6c38b8ca3f2ce05
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak7.pk3) = 8fd38c53ed814b64f6ab03b5290965e4
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak8.pk3) = d8b96d429ca4a9c289071cb7e77e14d2
+MD5 (%%PREFIX%%/share/quake3/missionpack/pak0.pk3) = e8ba9e3bf06210930bc0e7fdbcdd01c2
+
+========================================================================
diff --git a/games/q3base/pkg-descr b/games/q3base/pkg-descr
new file mode 100644
index 000000000000..3461227ea440
--- /dev/null
+++ b/games/q3base/pkg-descr
@@ -0,0 +1,13 @@
+Q3Base is a fork of Quake III Arena. It has the following advantages
+over Quake III Arena itself:
+
+- It uses SDL for establishing network connections. The client also uses
+ it for loading textures (thus adding PNG support) and OpenGL
+ rendering.
+- It supports FreeBSD out of the box
+- It hardcodes the shared object and datafile directories, thus removing
+ the need of startup scripts
+
+Q3Base is developed by the folks at Quakesrc.org.
+
+WWW: http://www.quakesrc.org/
diff --git a/games/q3base/pkg-plist b/games/q3base/pkg-plist
new file mode 100644
index 000000000000..3a9ffc01f7dd
--- /dev/null
+++ b/games/q3base/pkg-plist
@@ -0,0 +1,14 @@
+bin/q3base
+lib/quake3/baseq3/cgame.so
+lib/quake3/baseq3/qagame.so
+lib/quake3/baseq3/ui.so
+lib/quake3/missionpack/cgame.so
+lib/quake3/missionpack/qagame.so
+lib/quake3/missionpack/ui.so
+@dirrm lib/quake3/baseq3
+@dirrm lib/quake3/missionpack
+@unexec rmdir %D/lib/quake3 2>/dev/null || true
+@unexec rmdir %D/share/quake3/q3base 2>/dev/null || true
+@unexec rmdir %D/share/quake3/missionpack 2>/dev/null || true
+@unexec rmdir %D/share/quake3/baseq3 2>/dev/null || true
+@unexec rmdir %D/share/quake3 2>/dev/null || true
diff --git a/games/quake3-q3base/Makefile b/games/quake3-q3base/Makefile
new file mode 100644
index 000000000000..b4a66f1f395a
--- /dev/null
+++ b/games/quake3-q3base/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: q3base
+# Date created: 17 Nov 2005
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= q3base
+PORTVERSION= 0.1
+CATEGORIES= games
+MASTER_SITES= http://quake3.quakesrc.org/files/quake3/q3base/
+PKGNAMEPREFIX= quake3-
+
+MAINTAINER= ed@fxq.nl
+COMMENT= Quake III Arena fork using SDL
+
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+
+USE_BZIP2= yes
+USE_SDL= sdl net
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
+CONFIGURE_TARGET=
+CONFLICTS= q3server-1.32* quake3-[0-9]*
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKSRC}/pkg-message
+
+.if defined(WITHOUT_X11)
+CONFIGURE_ARGS= --disable-client
+.else
+USE_GL= yes
+USE_SDL+= image
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/quake3/baseq3
+ @${MKDIR} ${PREFIX}/share/quake3/missionpack
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/games/quake3-q3base/distinfo b/games/quake3-q3base/distinfo
new file mode 100644
index 000000000000..5a505a8a2f90
--- /dev/null
+++ b/games/quake3-q3base/distinfo
@@ -0,0 +1,3 @@
+MD5 (q3base-0.1.tar.bz2) = d68f1fd6d10ecf428e85f98d43d2abd8
+SHA256 (q3base-0.1.tar.bz2) = f4b78e9cf95df438c56976850dd5ba66716ac2ed0bb6ddf5e6e9f5d797244baf
+SIZE (q3base-0.1.tar.bz2) = 1510780
diff --git a/games/quake3-q3base/files/pkg-message.in b/games/quake3-q3base/files/pkg-message.in
new file mode 100644
index 000000000000..199dc1eeafbc
--- /dev/null
+++ b/games/quake3-q3base/files/pkg-message.in
@@ -0,0 +1,25 @@
+========================================================================
+
+In order to play Quake III Arena or Quake III Team Arena, you need to
+copy the non-free data-files from the CD to:
+
+ %%PREFIX%%/share/quake3
+
+For Quake III Arena, you need to have pak0.pk3 to pak8.pk3 stored in the
+'baseq3' directory. Quake III Team Arena also needs pak0.pk3 stored in
+the 'missionpack' directory.
+
+Below is a list of pk3 files, including their MD5 checksums:
+
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak0.pk3) = 1197ca3df1e65f3c380f8abc10ca43bf
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak1.pk3) = 48911719d91be25adb957f2d325db4a0
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak2.pk3) = d550ce896130c47166ca44b53f8a670a
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak3.pk3) = 968dfd0f30dad67056115c8e92344ddc
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak4.pk3) = 24bb1f4fcabd95f6e320c0e2f62f19ca
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak5.pk3) = 734dcd06d2cbc7a16432ff6697f1c5ba
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak6.pk3) = 873888a73055c023f6c38b8ca3f2ce05
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak7.pk3) = 8fd38c53ed814b64f6ab03b5290965e4
+MD5 (%%PREFIX%%/share/quake3/baseq3/pak8.pk3) = d8b96d429ca4a9c289071cb7e77e14d2
+MD5 (%%PREFIX%%/share/quake3/missionpack/pak0.pk3) = e8ba9e3bf06210930bc0e7fdbcdd01c2
+
+========================================================================
diff --git a/games/quake3-q3base/pkg-descr b/games/quake3-q3base/pkg-descr
new file mode 100644
index 000000000000..3461227ea440
--- /dev/null
+++ b/games/quake3-q3base/pkg-descr
@@ -0,0 +1,13 @@
+Q3Base is a fork of Quake III Arena. It has the following advantages
+over Quake III Arena itself:
+
+- It uses SDL for establishing network connections. The client also uses
+ it for loading textures (thus adding PNG support) and OpenGL
+ rendering.
+- It supports FreeBSD out of the box
+- It hardcodes the shared object and datafile directories, thus removing
+ the need of startup scripts
+
+Q3Base is developed by the folks at Quakesrc.org.
+
+WWW: http://www.quakesrc.org/
diff --git a/games/quake3-q3base/pkg-plist b/games/quake3-q3base/pkg-plist
new file mode 100644
index 000000000000..3a9ffc01f7dd
--- /dev/null
+++ b/games/quake3-q3base/pkg-plist
@@ -0,0 +1,14 @@
+bin/q3base
+lib/quake3/baseq3/cgame.so
+lib/quake3/baseq3/qagame.so
+lib/quake3/baseq3/ui.so
+lib/quake3/missionpack/cgame.so
+lib/quake3/missionpack/qagame.so
+lib/quake3/missionpack/ui.so
+@dirrm lib/quake3/baseq3
+@dirrm lib/quake3/missionpack
+@unexec rmdir %D/lib/quake3 2>/dev/null || true
+@unexec rmdir %D/share/quake3/q3base 2>/dev/null || true
+@unexec rmdir %D/share/quake3/missionpack 2>/dev/null || true
+@unexec rmdir %D/share/quake3/baseq3 2>/dev/null || true
+@unexec rmdir %D/share/quake3 2>/dev/null || true