aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2013-09-28 00:36:58 +0800
committernox <nox@FreeBSD.org>2013-09-28 00:36:58 +0800
commit695fee72c6760a7d48f7ee2012e7f5319f698e92 (patch)
tree903987cc192a2b20bd137fd5850ee3d1e2790858 /games
parentae1c7b16b4403456415a161707cca7005fbd2cfb (diff)
downloadfreebsd-ports-gnome-695fee72c6760a7d48f7ee2012e7f5319f698e92.tar.gz
freebsd-ports-gnome-695fee72c6760a7d48f7ee2012e7f5319f698e92.tar.zst
freebsd-ports-gnome-695fee72c6760a7d48f7ee2012e7f5319f698e92.zip
- Switch to USES= gmake tcl:84. (newer tcl versions cause crashes)
- Remove shlib major versions from LIB_DEPENDS. - Don't add CPPFLAGS to CONFIGURE_ENV a second time. - Remove indefinite article from COMMENT. - Bump PORTREVISION. Submitted by: beefy1 via pkg-fallout
Diffstat (limited to 'games')
-rw-r--r--games/gracer/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/games/gracer/Makefile b/games/gracer/Makefile
index 392ae618ef0f..944908081a84 100644
--- a/games/gracer/Makefile
+++ b/games/gracer/Makefile
@@ -3,28 +3,25 @@
PORTNAME= gracer
PORTVERSION= 0.1.5
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= games
MASTER_SITES= SF
MAINTAINER= nox@FreeBSD.org
-COMMENT= A 3D motor sport simulator
+COMMENT= 3D motor sport simulator
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
-LIB_DEPENDS= gif.5:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif:${PORTSDIR}/graphics/giflib \
png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- tcl84.1:${PORTSDIR}/lang/tcl84
+ jpeg:${PORTSDIR}/graphics/jpeg
USE_GL= glut
-USES= perl5
+USES= gmake perl5 tcl:84
USE_PERL5= build
USE_AUTOTOOLS= autoconf213
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
- CPPFLAGS="${CPPFLAGS}"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include \
- -I${LOCALBASE}/include/tcl8.4
-USE_GMAKE= yes
+ -I${TCL_INCLUDEDIR}
NO_STAGE= yes
# for plib (sound):
CONFIGURE_ARGS+= --with-plib=${LOCALBASE}/plib