aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-10-19 22:50:52 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-10-19 22:50:52 +0800
commit6a98fceb0a6004a4c5a1fd86d54347f6a29f74c4 (patch)
tree72fd93ae39b43490b34dc8479465e07b453d126e /games
parente18413661fadcae47bb20ec0de548623410227ad (diff)
downloadfreebsd-ports-gnome-6a98fceb0a6004a4c5a1fd86d54347f6a29f74c4.tar.gz
freebsd-ports-gnome-6a98fceb0a6004a4c5a1fd86d54347f6a29f74c4.tar.zst
freebsd-ports-gnome-6a98fceb0a6004a4c5a1fd86d54347f6a29f74c4.zip
Improve shebangfix framework
- Support multiple values in *_OLD_CMD, i.e. we can now fix both "/usr/bin/python" and "/usr/bin/env python" at the same time - Default *_OLD_CMD values are now always appended, so you don't need to specify them in individual ports - Add lua support (depends on USES=lua) - Add more default values, such as "/usr/bin/env foo" for python, perl, bash, ruby and lua - Shebangfix now matches whole words, e.g. we will no longer (erroneously) replace "/usr/bin/perl5.005" with "${perl_CMD}5.005" (but "/usr/bin/perl -tt" is still (correctly) replaced with "${perl_CMD} -tt") Note that *_OLD_CMD items containing spaces must now be quoted (e.g. perl_OLD_CMD=/bin/perl /usr/bin/perl "/usr/bin/env perl") Update shebangfix usage according to new rules in many ports: - Remove *_OLD_CMD for patterns now replaced by default - Quote custom *_OLD_CMD which contain spaces Fix shebangfix usage in many ports (irrelevant to infrastructure change): - Remove redundant SHEBANG_LANG (no need to duplicate default langs) - Remove redundant *_CMD (such as python_CMD=${LOCALBASE}/bin/python${PYTHON_VER} when USES=python is present) - Never use *_OLD_CMD in REINPLACE_CMD matchers, these should always look for exact string Approved by: portmgr (bapt) Differential Revision: D3756
Diffstat (limited to 'games')
-rw-r--r--games/childsplay/Makefile2
-rw-r--r--games/linux-enemyterritory-jaymod-21/Makefile2
-rw-r--r--games/linux-enemyterritory-jaymod/Makefile2
-rw-r--r--games/lostfeathers/Makefile1
-rw-r--r--games/oneisenough/Makefile1
-rw-r--r--games/schwarzweiss/Makefile1
-rw-r--r--games/starfighter/Makefile1
-rw-r--r--games/super_mario_bros_python/Makefile1
8 files changed, 2 insertions, 9 deletions
diff --git a/games/childsplay/Makefile b/games/childsplay/Makefile
index a54caba4b947..3e7dcee42f93 100644
--- a/games/childsplay/Makefile
+++ b/games/childsplay/Makefile
@@ -21,8 +21,6 @@ NO_BUILD= yes
USES= gettext shebangfix tar:tgz python:2
USE_GNOME= pygtk2
-python_OLD_CMD= /usr/bin/env python
-python_CMD= ${SETENV} python2
SHEBANG_FILES= childsplay.py
.for i in buttons funcs text dialogs gtk_widgets base
SHEBANG_FILES+= SPWidgets/$i.py
diff --git a/games/linux-enemyterritory-jaymod-21/Makefile b/games/linux-enemyterritory-jaymod-21/Makefile
index 7ea6ffe8bd7f..3ed2139f8ffb 100644
--- a/games/linux-enemyterritory-jaymod-21/Makefile
+++ b/games/linux-enemyterritory-jaymod-21/Makefile
@@ -22,7 +22,7 @@ PLIST_SUB= VERSTR="${VERSTR}"
USES= shebangfix
SHEBANG_FILES= linux/convert_shrub
-perl_OLD_CMD= /bin/env perl
+perl_OLD_CMD= "/bin/env perl"
USE_LINUX= yes
PORTSCOUT= limit:^2\.1\.7
diff --git a/games/linux-enemyterritory-jaymod/Makefile b/games/linux-enemyterritory-jaymod/Makefile
index 31c9341874c7..59e564052d66 100644
--- a/games/linux-enemyterritory-jaymod/Makefile
+++ b/games/linux-enemyterritory-jaymod/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
USES= shebangfix
SHEBANG_FILES= linux/convert_shrub
-perl_OLD_CMD= /bin/env perl
+perl_OLD_CMD= "/bin/env perl"
USE_LINUX= yes
OPTIONS_DEFINE= DOCS OMNIBOT
diff --git a/games/lostfeathers/Makefile b/games/lostfeathers/Makefile
index 75af257002c6..7fbc76708946 100644
--- a/games/lostfeathers/Makefile
+++ b/games/lostfeathers/Makefile
@@ -20,7 +20,6 @@ RUN_DEPENDS= avbin>=0:${PORTSDIR}/multimedia/avbin
USES= python shebangfix zip
SHEBANG_FILES= run_game.py
-python_OLD_CMD= /usr/bin/env python
USE_GNOME= pygtk2 librsvg2
PORTDOCS= README.txt
diff --git a/games/oneisenough/Makefile b/games/oneisenough/Makefile
index 5f33ae658250..6f044523bb75 100644
--- a/games/oneisenough/Makefile
+++ b/games/oneisenough/Makefile
@@ -24,7 +24,6 @@ USES= dos2unix python:2 shebangfix zip
DOS2UNIX_FILES= *.txt bin/*.py
DOS2UNIX_REGEX= .*.[^pt][^nt][^gf]
SHEBANG_FILES= run_game.py bin/mainmenu.py
-python_OLD_CMD= /usr/bin/env python
PORTDOCS= README.txt
OPTIONS_DEFINE= DOCS
diff --git a/games/schwarzweiss/Makefile b/games/schwarzweiss/Makefile
index a34e3f1838c3..24900210e4ab 100644
--- a/games/schwarzweiss/Makefile
+++ b/games/schwarzweiss/Makefile
@@ -25,7 +25,6 @@ GH_TAGNAME= d95263f
USES= python:2 shebangfix
SHEBANG_FILES= schwarzweiss_start.py data/*.py
-python_OLD_CMD= /usr/bin/env python
PORTDOCS= readme.txt
OPTIONS_DEFINE= DOCS
diff --git a/games/starfighter/Makefile b/games/starfighter/Makefile
index b3fc1c03037b..d8efbf4c5940 100644
--- a/games/starfighter/Makefile
+++ b/games/starfighter/Makefile
@@ -24,7 +24,6 @@ WITH_ZLIB= yes
MAKEFILE= makefile
SHEBANG_FILES= pack.py unpack.py
-python_OLD_CMD= /usr/bin/env python
INSTALLS_ICONS= yes
diff --git a/games/super_mario_bros_python/Makefile b/games/super_mario_bros_python/Makefile
index 250f20514960..d2e149630a4a 100644
--- a/games/super_mario_bros_python/Makefile
+++ b/games/super_mario_bros_python/Makefile
@@ -24,7 +24,6 @@ WRKSRC= ${WRKDIR}/Super-Mario-Bros-Python-v${DISTVERSION}release
USES= shebangfix python:2 zip
SHEBANG_FILES= gamelib/*.py start.py
-python_OLD_CMD= /usr/bin/env python
PORTDOCS= changelog.txt readme.txt
OPTIONS_DEFINE= DOCS