aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-07-30 06:09:53 +0800
committerAntoine Brodin <antoine@FreeBSD.org>2015-07-30 06:09:53 +0800
commit6e381a9d5323dc4984a1f1ddeb2ffbaa7deeec9c (patch)
tree39f5db5e677aac0352369cb6e46374b5bd11a774 /games
parent71c37a22dfbe5fdf7ff290ef8fcfa63c72e0cc77 (diff)
downloadfreebsd-ports-gnome-6e381a9d5323dc4984a1f1ddeb2ffbaa7deeec9c.tar.gz
freebsd-ports-gnome-6e381a9d5323dc4984a1f1ddeb2ffbaa7deeec9c.tar.zst
freebsd-ports-gnome-6e381a9d5323dc4984a1f1ddeb2ffbaa7deeec9c.zip
Switch default python_CMD used by shebangfix to ${PYTHON_CMD} for ports
using python PR: 201077 Reviewed by: mat With hat: portmgr Differential Revision: https://reviews.freebsd.org/D2955
Diffstat (limited to 'games')
-rw-r--r--games/lostfeathers/Makefile1
-rw-r--r--games/oneisenough/Makefile3
-rw-r--r--games/schwarzweiss/Makefile1
-rw-r--r--games/starfighter/Makefile3
-rw-r--r--games/super_mario_bros_python/Makefile1
5 files changed, 2 insertions, 7 deletions
diff --git a/games/lostfeathers/Makefile b/games/lostfeathers/Makefile
index 0b5ea0dd3ccd..75af257002c6 100644
--- a/games/lostfeathers/Makefile
+++ b/games/lostfeathers/Makefile
@@ -21,7 +21,6 @@ RUN_DEPENDS= avbin>=0:${PORTSDIR}/multimedia/avbin
USES= python shebangfix zip
SHEBANG_FILES= run_game.py
python_OLD_CMD= /usr/bin/env python
-python_CMD?= ${PYTHON_CMD}
USE_GNOME= pygtk2 librsvg2
PORTDOCS= README.txt
diff --git a/games/oneisenough/Makefile b/games/oneisenough/Makefile
index e191d00b0ac3..5f33ae658250 100644
--- a/games/oneisenough/Makefile
+++ b/games/oneisenough/Makefile
@@ -24,8 +24,7 @@ USES= dos2unix python:2 shebangfix zip
DOS2UNIX_FILES= *.txt bin/*.py
DOS2UNIX_REGEX= .*.[^pt][^nt][^gf]
SHEBANG_FILES= run_game.py bin/mainmenu.py
-python_OLD_CMD?= /usr/bin/env python
-python_CMD?= ${PYTHON_CMD}
+python_OLD_CMD= /usr/bin/env python
PORTDOCS= README.txt
OPTIONS_DEFINE= DOCS
diff --git a/games/schwarzweiss/Makefile b/games/schwarzweiss/Makefile
index 920822abb432..a34e3f1838c3 100644
--- a/games/schwarzweiss/Makefile
+++ b/games/schwarzweiss/Makefile
@@ -26,7 +26,6 @@ GH_TAGNAME= d95263f
USES= python:2 shebangfix
SHEBANG_FILES= schwarzweiss_start.py data/*.py
python_OLD_CMD= /usr/bin/env python
-python_CMD?= ${PYTHON_CMD}
PORTDOCS= readme.txt
OPTIONS_DEFINE= DOCS
diff --git a/games/starfighter/Makefile b/games/starfighter/Makefile
index 53cad5359920..b3fc1c03037b 100644
--- a/games/starfighter/Makefile
+++ b/games/starfighter/Makefile
@@ -24,8 +24,7 @@ WITH_ZLIB= yes
MAKEFILE= makefile
SHEBANG_FILES= pack.py unpack.py
-python_OLD_CMD= ${SETENV} python
-python_CMD= ${PYTHON_CMD}
+python_OLD_CMD= /usr/bin/env python
INSTALLS_ICONS= yes
diff --git a/games/super_mario_bros_python/Makefile b/games/super_mario_bros_python/Makefile
index ffe190c37190..250f20514960 100644
--- a/games/super_mario_bros_python/Makefile
+++ b/games/super_mario_bros_python/Makefile
@@ -25,7 +25,6 @@ WRKSRC= ${WRKDIR}/Super-Mario-Bros-Python-v${DISTVERSION}release
USES= shebangfix python:2 zip
SHEBANG_FILES= gamelib/*.py start.py
python_OLD_CMD= /usr/bin/env python
-python_CMD?= ${PYTHON_CMD}
PORTDOCS= changelog.txt readme.txt
OPTIONS_DEFINE= DOCS