aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-01-20 16:00:42 +0800
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-01-20 16:00:42 +0800
commit6ef3a9770732e89b1f5d23412032ea01715186f5 (patch)
tree6a38561b475d74583a939cd02f05468bb6e47ea3 /games
parent92cffc4603d85ec8c6d4eef6b58b8fe063d9d77b (diff)
downloadfreebsd-ports-gnome-6ef3a9770732e89b1f5d23412032ea01715186f5.tar.gz
freebsd-ports-gnome-6ef3a9770732e89b1f5d23412032ea01715186f5.tar.zst
freebsd-ports-gnome-6ef3a9770732e89b1f5d23412032ea01715186f5.zip
games/nwndata: Makefile improvements
- Replace EXTRACT_DEPENDS with USES for 7z extraction. - Use P7ZIP_CMD instead of 7z directly. - Delint Makefile a bit. PR: 252746 Submitted by: scf@FreeBSD.org (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/nwndata/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/games/nwndata/Makefile b/games/nwndata/Makefile
index b2922b2245d3..b558b11d26f2 100644
--- a/games/nwndata/Makefile
+++ b/games/nwndata/Makefile
@@ -15,13 +15,18 @@ DISTFILES=
MAINTAINER= scf@FreeBSD.org
COMMENT= Neverwinter Nights Data Files
+LICENSE= Proprietary
+
+ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS_REASON= Binary Distribution on x86 only
+
# Setup port based upon whether this is the Diamond edition or straight NWN.
.if defined(CDROM_MOUNT) && exists(${CDROM_MOUNT}/KingmakerSetup.exe)
NWNVER= 1.61
NWNREV= 0
NWN_DIAMOND= yes
-EXTRACT_DEPENDS+= 7z:archivers/p7zip
+USES= 7z:p7zip zip
PLIST_SUB+= DIAMOND="" ORIGINAL="@comment "
.else
@@ -36,16 +41,14 @@ NO_BUILD= yes
WRKSRC= ${WRKDIR}/nwn
RESTRICTED= Distribution not allowed
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= Binary Distribution on x86 only
-
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
.if defined(NWN_DIAMOND)
- 7z e -y -x'r!*.dll' -x'r!*.exe' -o${WRKSRC}/Kingmaker\
- ${CDROM_MOUNT}/KingmakerSetup.exe
+ ${LOCALBASE}/bin/${P7ZIP_CMD} e -y -x'r!*.dll' -x'r!*.exe'\
+ -o${WRKSRC}/Kingmaker ${CDROM_MOUNT}/KingmakerSetup.exe
.for zipfile in Data_Shared.zip Data_linux.zip data/XP1.zip data/XP2.zip
- (cd ${STAGEDIR}${DATADIR} && ${UNZIP_CMD} -o ${CDROM_MOUNT}/${zipfile})
+ (cd ${STAGEDIR}${DATADIR} && ${UNZIP_NATIVE_CMD}\
+ -o ${CDROM_MOUNT}/${zipfile})
.endfor
.else
(cd ${WRKSRC} && ${FIND} . -print | \