aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-01-10 07:58:25 +0800
committeredwin <edwin@FreeBSD.org>2005-01-10 07:58:25 +0800
commit6f4e8a61d220b5fc4f1e62b6d013d59b733d7149 (patch)
tree1b8f1c0c60606c1f12c944b514bd7474ee3901fe /games
parentf164b7ad8bc959877958d599a9001982ffb0757f (diff)
downloadfreebsd-ports-gnome-6f4e8a61d220b5fc4f1e62b6d013d59b733d7149.tar.gz
freebsd-ports-gnome-6f4e8a61d220b5fc4f1e62b6d013d59b733d7149.tar.zst
freebsd-ports-gnome-6f4e8a61d220b5fc4f1e62b6d013d59b733d7149.zip
update games/scummvm-tools to 0.7.0
sync with scummvm PR: ports/75799 Submitted by: Miguel Mendez <flynn@energyhq.es.eu.org>
Diffstat (limited to 'games')
-rw-r--r--games/scummvm-tools/Makefile2
-rw-r--r--games/scummvm-tools/distinfo4
-rw-r--r--games/scummvm-tools/files/patch-simon1descr.c36
3 files changed, 21 insertions, 21 deletions
diff --git a/games/scummvm-tools/Makefile b/games/scummvm-tools/Makefile
index b41b22b69bb9..9e12bbf8bec8 100644
--- a/games/scummvm-tools/Makefile
+++ b/games/scummvm-tools/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scummvm-tools
-PORTVERSION= 0.6.0
+PORTVERSION= 0.7.0
CATEGORIES= games emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= scummvm
diff --git a/games/scummvm-tools/distinfo b/games/scummvm-tools/distinfo
index f901ab3ec6be..e375e0688413 100644
--- a/games/scummvm-tools/distinfo
+++ b/games/scummvm-tools/distinfo
@@ -1,2 +1,2 @@
-MD5 (scummvm-tools-0.6.0.tar.bz2) = 09ded7a8177fda1b861731052b8693c4
-SIZE (scummvm-tools-0.6.0.tar.bz2) = 75514
+MD5 (scummvm-tools-0.7.0.tar.bz2) = eeebbd4e309a8564dd911d5c26fed2f0
+SIZE (scummvm-tools-0.7.0.tar.bz2) = 98664
diff --git a/games/scummvm-tools/files/patch-simon1descr.c b/games/scummvm-tools/files/patch-simon1descr.c
index 80dc425759a1..47e16abf6c16 100644
--- a/games/scummvm-tools/files/patch-simon1descr.c
+++ b/games/scummvm-tools/files/patch-simon1descr.c
@@ -1,19 +1,19 @@
---- simon1decr.c.orig Tue May 27 16:34:14 2003
-+++ simon1decr.c Tue May 27 16:34:34 2003
+--- simon1decr.c.orig Mon Apr 12 00:10:19 2004
++++ simon1decr.c Tue Jan 4 15:36:39 2005
@@ -26,14 +26,9 @@
-
- #define EndGetM32(a) ((((a)[0])<<24)|(((a)[1])<<16)|(((a)[2])<<8)|((a)[3]))
-
--#define SD_GETBIT(var) do { \
-- if (!bits--) { s -= 4; if (s < src) return 0; bb=EndGetM32(s); bits=31; } \
-- (var) = bb & 1; bb >>= 1; \
--} while (0)
-+#define SD_GETBIT(var) do { if (!bits--) { s -= 4; if (s < src) return 0; bb=EndGetM32(s); bits=31; } (var) = bb & 1; bb >>= 1; } while (0)
-
--#define SD_GETBITS(var, nbits) do { \
-- bc=(nbits); (var)=0; while (bc--) {(var)<<=1; SD_GETBIT(bit); (var)|=bit; } \
--} while (0)
-+#define SD_GETBITS(var, nbits) do { bc=(nbits); (var)=0; while (bc--) {(var)<<=1; SD_GETBIT(bit); (var)|=bit; } } while (0)
-
- #define SD_TYPE_LITERAL (0)
- #define SD_TYPE_MATCH (1)
+
+ #define EndGetM32(a) ((((a)[0])<<24)|(((a)[1])<<16)|(((a)[2])<<8)|((a)[3]))
+
+-#define SD_GETBIT(var) do { \
+- if (!bits--) { s -= 4; if (s < src) return 0; bb=EndGetM32(s); bits=31; } \
+- (var) = bb & 1; bb >>= 1; \
+-} while (0)
++#define SD_GETBIT(var) do { if (!bits--) { s -= 4; if (s < src) return 0; bb=EndGetM32(s); bits=31; } (var) = bb & 1; bb >>= 1; } while (0)
+
+-#define SD_GETBITS(var, nbits) do { \
+- bc=(nbits); (var)=0; while (bc--) {(var)<<=1; SD_GETBIT(bit); (var)|=bit; } \
+-} while (0)
++#define SD_GETBITS(var, nbits) do { bc=(nbits); (var)=0; while (bc--) {(var)<<=1; SD_GETBIT(bit); (var)|=bit; } } while (0)
+
+ #define SD_TYPE_LITERAL (0)
+ #define SD_TYPE_MATCH (1)