aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2014-03-31 00:17:03 +0800
committerdinoex <dinoex@FreeBSD.org>2014-03-31 00:17:03 +0800
commit717769c3b333707548de8bffa71ea25e4e28e404 (patch)
tree5e5506b817c9689b7a16c6780cf61b304c5e888b /games
parentc97768e09a1666d8e06efd4a7de354f8e8750545 (diff)
downloadfreebsd-ports-gnome-717769c3b333707548de8bffa71ea25e4e28e404.tar.gz
freebsd-ports-gnome-717769c3b333707548de8bffa71ea25e4e28e404.tar.zst
freebsd-ports-gnome-717769c3b333707548de8bffa71ea25e4e28e404.zip
- make -usedefcmap and sound default
now desktops do not need to pass this arguments Obtained from: OpenBSD
Diffstat (limited to 'games')
-rw-r--r--games/xboing/Makefile2
-rw-r--r--games/xboing/files/patch-debian11
-rw-r--r--games/xboing/files/patch-init.c82
-rw-r--r--games/xboing/files/patch-xboing.man29
4 files changed, 112 insertions, 12 deletions
diff --git a/games/xboing/Makefile b/games/xboing/Makefile
index ccbf6b4044c1..e5fa41dd832d 100644
--- a/games/xboing/Makefile
+++ b/games/xboing/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xboing
PORTVERSION= 2.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= games
diff --git a/games/xboing/files/patch-debian b/games/xboing/files/patch-debian
index d9b60e720496..2d031b4ce778 100644
--- a/games/xboing/files/patch-debian
+++ b/games/xboing/files/patch-debian
@@ -120,17 +120,6 @@
else
strcpy(filename, HIGH_SCORE_FILE);
---- init.c
-+++ init.c
-@@ -438,7 +438,7 @@
- WarningMessage("Your X Window system display variable is not set.");
- else
- {
-- sprintf(string, "Cannot connect to display called <%s>.", displayName);
-+ snprintf(string, sizeof(string) - 1, "Cannot connect to display called <%s>.", displayName);
- WarningMessage(string);
- }
- }
--- misc.c
+++ misc.c
@@ -427,7 +431,7 @@
diff --git a/games/xboing/files/patch-init.c b/games/xboing/files/patch-init.c
new file mode 100644
index 000000000000..a6f56e17385c
--- /dev/null
+++ b/games/xboing/files/patch-init.c
@@ -0,0 +1,82 @@
+--- init.c.orig 1996-11-22 02:28:46.000000000 +0100
++++ init.c 2014-03-30 18:05:40.000000000 +0200
+@@ -438,7 +438,7 @@
+ WarningMessage("Your X Window system display variable is not set.");
+ else
+ {
+- sprintf(string, "Cannot connect to display called <%s>.", displayName);
++ snprintf(string, sizeof(string), "Cannot connect to display called <%s>.", displayName);
+ WarningMessage(string);
+ }
+ }
+@@ -471,10 +471,10 @@
+ "Usage: XBoing [-version] [-usage] [-help] [-sync] ",
+ "[-display <displayName>]\n");
+ fprintf(stdout, "%s%s\n%s%s\n%s\n",
+- " [-speed <1-9>] [-scores] [-keys] [-sound] [-setup]",
++ " [-speed <1-9>] [-scores] [-keys] [-no-sound] [-setup]",
+ " [-nosfx]",
+ " [-grab] [-maxvol <1-100>] [-startlevel <1-MAX>]",
+- " [-usedefcmap]",
++ " [-no-usedefcmap]",
+ " [-nickname <name>] [-noicon]");
+
+ /* Exit now */
+@@ -548,10 +548,11 @@
+ " -scores - Print out the current highscores.\n",
+ " -keys - Use keys instead of mouse control.\n",
+ " -sound - Turn audio ON for game.\n",
++ " -no-sound - Turn audio OFF for game.\n",
+ " -setup - Print setup information.\n",
+ " -nosfx - Do not use some special effects.\n",
+ " -grab - Turn ON pointer grab.\n",
+- " -usedefcmap - Use the default colourmap.\n",
++ " -no-usedefcmap - Don't use the default colourmap.\n",
+ " -nickname <name> - Use nickname instead of real name.\n",
+ " -noicon - Do not create a custom icon.\n",
+ " -display <display> - Set the display for the game.\n");
+@@ -599,13 +600,13 @@
+ syncOn = False;
+ debug = False;
+ grabPointer = False;
+- useDefaultColourmap = False;
++ useDefaultColourmap = True;
+
+ /* This will force the use of the users real name */
+ SetNickName("");
+
+- /* The audio is off by default */
+- noSound = True;
++ /* The audio is on by default */
++ noSound = False;
+ noicon = False;
+
+ /* So the audio code will use system default */
+@@ -687,6 +688,13 @@
+ /* Print out the version information and quit */
+ PrintVersion();
+
++ } else if (!compareArgument(argv[i], "-no-sound", 8))
++ {
++ /* Enable the sound in the game */
++ noSound = True;
++
++ DEBUG("Sound turned off.")
++
+ } else if (!compareArgument(argv[i], "-sound", 5))
+ {
+ /* Enable the sound in the game */
+@@ -751,6 +759,13 @@
+
+ DEBUG("Using default colourmap please.")
+
++ } else if (!compareArgument(argv[i], "-no-usedefcmap", 13))
++ {
++ /* Try to use the default colourmap */
++ useDefaultColourmap = False;
++
++ DEBUG("Not using default colourmap.")
++
+ } else if (!compareArgument(argv[i], "-speed", 5))
+ {
+ /* Set the speed for the game */
diff --git a/games/xboing/files/patch-xboing.man b/games/xboing/files/patch-xboing.man
new file mode 100644
index 000000000000..b879f8ae68d0
--- /dev/null
+++ b/games/xboing/files/patch-xboing.man
@@ -0,0 +1,29 @@
+--- xboing.man.orig 1996-11-22 02:28:46.000000000 +0100
++++ xboing.man 2014-03-30 18:01:26.000000000 +0200
+@@ -45,7 +45,7 @@
+ xboing \- An X Window System based blockout clone. V2.4
+ .SH SYNOPSIS
+ .B xboing
+-[-version] [-usage] [-help] [-sync] [-display <displayName>] [-speed <1-10>] [-scores] [-keys] [-sound] [-setup] [-nosfx] [-grab] [-maxvol <1-100>] [-startlevel <1-MAXLEVELS>] [-usedefcmap] [-nickname <name>] [-noicon]
++[-version] [-usage] [-help] [-sync] [-display <displayName>] [-speed <1-10>] [-scores] [-keys] [-no-sound] [-setup] [-nosfx] [-grab] [-maxvol <1-100>] [-startlevel <1-MAXLEVELS>] [-no-usedefcmap] [-nickname <name>] [-noicon]
+ .IP
+ -speed <n> - The game speed, 1 - 9. 9=Fast
+ .br
+@@ -67,6 +67,8 @@
+ .br
+ -sound - Turn audio ON for game
+ .br
++-no-sound - Turn audio OFF for game
++.br
+ -setup - Print setup information
+ .br
+ -nosfx - Turn off special effects
+@@ -75,6 +77,8 @@
+ .br
+ -usedefcmap - Use the default colourmap
+ .br
++-no-usedefcmap - Do not use the default colourmap
++.br
+ -nickname <name> - Use nickname instead of real one
+ .br
+ -noicon - Do not create a custom icon