aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2016-01-11 00:55:26 +0800
committerbapt <bapt@FreeBSD.org>2016-01-11 00:55:26 +0800
commit722399dd9a50a81b1e08fff9701c22c51a1d111a (patch)
treea1803c12d7ed1ddd17231d7c51bd8ecd19c12c72 /games
parentf7755256283634d3b9ec0c5384c3bbbed111cefb (diff)
downloadfreebsd-ports-gnome-722399dd9a50a81b1e08fff9701c22c51a1d111a.tar.gz
freebsd-ports-gnome-722399dd9a50a81b1e08fff9701c22c51a1d111a.tar.zst
freebsd-ports-gnome-722399dd9a50a81b1e08fff9701c22c51a1d111a.zip
Convert g* and i* to USES=sqlite and USES=firebird
Diffstat (limited to 'games')
-rw-r--r--games/crossfire-server/Makefile3
-rw-r--r--games/flightgear/Makefile4
-rw-r--r--games/freeciv/Makefile3
-rw-r--r--games/gcompris/Makefile3
-rw-r--r--games/kajongg/Makefile3
-rw-r--r--games/latrine/Makefile3
-rw-r--r--games/lightsoff/Makefile3
-rw-r--r--games/stonesoup/Makefile3
-rw-r--r--games/stratagus/Makefile3
-rw-r--r--games/wyrmgus/Makefile3
-rw-r--r--games/xmoto/Makefile3
11 files changed, 12 insertions, 22 deletions
diff --git a/games/crossfire-server/Makefile b/games/crossfire-server/Makefile
index 5981e9d1aaba..620dd4d56ce4 100644
--- a/games/crossfire-server/Makefile
+++ b/games/crossfire-server/Makefile
@@ -22,8 +22,7 @@ LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USES= gmake libtool localbase perl5 python uidfix
-USE_SQLITE= 3
+USES= gmake libtool localbase perl5 python sqlite uidfix
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static --with-check=no --localstatedir=/var/games
CONFIGURE_SHELL=${LOCALBASE}/bin/bash
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index feef29f581c1..e1c9ec7dc628 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -30,10 +30,10 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
USE_XORG= ice sm x11 xext xft xi xinerama xt xmu
USE_GL= gl glu glut
-USE_SQLITE= 3
USE_QT5= core buildtools qmake widgets
-USES= alias cpe dos2unix cmake compiler jpeg openal:al,alut tar:bzip2
+USES= alias cpe dos2unix cmake compiler jpeg openal:al,alut sqlite \
+ tar:bzip2
DOS2UNIX_REGEX= .*\.(c|h|cxx|cpp|hxx|hpp)
CMAKE_ARGS+= -DENABLE_JS_SERVER:BOOL=ON \
-DSYSTEM_SQLITE:BOOL=ON \
diff --git a/games/freeciv/Makefile b/games/freeciv/Makefile
index e255991b9a62..f86de1e3d13b 100644
--- a/games/freeciv/Makefile
+++ b/games/freeciv/Makefile
@@ -13,8 +13,7 @@ RUN_DEPENDS= hicolor-icon-theme>=0:${PORTSDIR}/misc/hicolor-icon-theme
LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
libcurl.so:${PORTSDIR}/ftp/curl
-USES= gettext gmake iconv libtool pkgconfig tar:bzip2 python
-USE_SQLITE= yes
+USES= gettext gmake iconv libtool pkgconfig tar:bzip2 python sqlite
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/gcompris/Makefile b/games/gcompris/Makefile
index 8acb913fd686..6d5444aa33f0 100644
--- a/games/gcompris/Makefile
+++ b/games/gcompris/Makefile
@@ -22,11 +22,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
gnucap:${PORTSDIR}/cad/gnucap
USES= display:configure gettext gmake libtool pathfix pkgconfig \
- python:2 shebangfix tar:bzip2
+ python:2 shebangfix sqlite tar:bzip2
SHEBANG_FILES= boards/voices/*.sh
GNU_CONFIGURE= yes
USE_GSTREAMER= yes
-USE_SQLITE= 3
USE_SDL= mixer
USE_GNOME= intlhack gnomeprefix gtk20 pygtk2 libxml2 librsvg2
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/kajongg/Makefile b/games/kajongg/Makefile
index a1b8be22498c..d6f15f82b006 100644
--- a/games/kajongg/Makefile
+++ b/games/kajongg/Makefile
@@ -10,10 +10,9 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource python tar:xz twisted:run
+USES= cmake:outsource python tar:xz twisted:run sqlite
USE_KDE4= kdelibs kdeprefix pykde4 automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
-USE_SQLITE= 3
USE_TWISTED_RUN= yes
CMAKE_ARGS= -DINSTALL_KAJONGG:BOOL=TRUE
diff --git a/games/latrine/Makefile b/games/latrine/Makefile
index 8b0aa74c7b01..d10b104d8d8f 100644
--- a/games/latrine/Makefile
+++ b/games/latrine/Makefile
@@ -19,9 +19,8 @@ BUILD_DEPENDS= p5-DBI>0:${PORTSDIR}/databases/p5-DBI
WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_CSTD= gnu89
-USE_SQLITE= 3
USE_PERL5= build
-USES= gettext gmake ncurses perl5
+USES= gettext gmake ncurses perl5 sqlite
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -D_XOPEN_SOURCE_EXTENDED
diff --git a/games/lightsoff/Makefile b/games/lightsoff/Makefile
index 5b4c67f980f7..cf790785961b 100644
--- a/games/lightsoff/Makefile
+++ b/games/lightsoff/Makefile
@@ -16,12 +16,11 @@ LIB_DEPENDS= libclutter-gtk-1.0.so:${PORTSDIR}/graphics/clutter-gtk3
PORTSCOUT= limitw:1,even
-USES= gettext gmake pathfix pkgconfig tar:xz
+USES= gettext gmake pathfix pkgconfig sqlite tar:xz
USE_GNOME= gtk30 intlhack librsvg2 libxml2:build
INSTALLS_ICONS= yes
USE_XORG= x11
USE_GL= gl
-USE_SQLITE= 3
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index 70345eb94a81..68cd0f0c02bb 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -14,9 +14,8 @@ COMMENT= Dungeon Crawl Stone Soup - a fun, free rogue-like game
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/../licence.txt
-USE_SQLITE= yes
USES= bison compiler:c++11-lib gmake lua:51 perl5 pkgconfig \
- shebangfix tar:xz
+ shebangfix sqlite tar:xz
USE_PERL5= build
SHEBANG_FILES= util/gen-mi-enum \
diff --git a/games/stratagus/Makefile b/games/stratagus/Makefile
index 93345c27e954..27675656e085 100644
--- a/games/stratagus/Makefile
+++ b/games/stratagus/Makefile
@@ -18,8 +18,7 @@ LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
USE_GL= gl glu
USE_SDL= sdl
-USE_SQLITE= 3
-USES= cmake:outsource lua:51 pkgconfig
+USES= cmake:outsource lua:51 pkgconfig sqlite
CMAKE_ARGS= -DGAMEDIR:STRING="bin" \
-DTOLUA++_APP:STRING="tolua++-${LUA_VER}" \
-DTOLUA++_INCLUDE_DIR:STRING="${LUA_INCDIR}" \
diff --git a/games/wyrmgus/Makefile b/games/wyrmgus/Makefile
index e62534741449..50e56b208a6f 100644
--- a/games/wyrmgus/Makefile
+++ b/games/wyrmgus/Makefile
@@ -21,8 +21,7 @@ GH_PROJECT= Wyrmgus
USE_GL= gl glu
USE_SDL= sdl
-USE_SQLITE= 3
-USES= compiler:c++11-lib cmake:outsource lua:51 pkgconfig
+USES= compiler:c++11-lib cmake:outsource lua:51 pkgconfig sqlite
CMAKE_ARGS= -DGAMEDIR:STRING="bin" \
-DTOLUA++_APP:STRING="tolua++-${LUA_VER}" \
-DTOLUA++_INCLUDE_DIR:STRING="${LUA_INCDIR}" \
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 3dee737bfa94..2741be4150a1 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -21,9 +21,8 @@ LICENSE= GPLv2 # or later
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-USES= compiler:features dos2unix gmake jpeg lua:51
+USES= compiler:features dos2unix gmake jpeg lua:51 sqlite
USE_GNOME= libxml2
-USE_SQLITE= 3
USE_SDL= sdl mixer ttf net
USE_GL= gl glu
DOS2UNIX_GLOB= *.cpp *.h