aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-08-19 22:06:36 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-08-19 22:06:36 +0800
commit74391bf16ceb6f795e34816f09e1c2d57a1f07b5 (patch)
tree628c4d4d692b18a63953f2dc45cb4d8473c33019 /games
parent743f6a6499a39d0406c4efce5f4628348d70b4ef (diff)
downloadfreebsd-ports-gnome-74391bf16ceb6f795e34816f09e1c2d57a1f07b5.tar.gz
freebsd-ports-gnome-74391bf16ceb6f795e34816f09e1c2d57a1f07b5.tar.zst
freebsd-ports-gnome-74391bf16ceb6f795e34816f09e1c2d57a1f07b5.zip
- Clarify LICENSE
- Add LICENSE_FILE - Optionize NLS - Fix WWW:
Diffstat (limited to 'games')
-rw-r--r--games/manaplus/Makefile16
-rw-r--r--games/manaplus/pkg-descr2
-rw-r--r--games/manaplus/pkg-plist44
3 files changed, 34 insertions, 28 deletions
diff --git a/games/manaplus/Makefile b/games/manaplus/Makefile
index e53e42c38902..12b8cf7ef802 100644
--- a/games/manaplus/Makefile
+++ b/games/manaplus/Makefile
@@ -9,25 +9,31 @@ MASTER_SITES= http://download.evolonline.org/manaplus/download/${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Free open source 2D MMORPG client for athena and evol servers
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libxml2.so:textproc/libxml2 \
libpng.so:graphics/png \
libcurl.so:ftp/curl \
libphysfs.so:devel/physfs
-USES= gettext pkgconfig:build tar:xz
+USES= pkgconfig:build tar:xz
USE_XORG= x11
USE_SDL= sdl2 gfx2 image2 mixer2 net2 ttf2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE} --with-sdl2 \
+CONFIGURE_ARGS= --with-sdl2 \
--without-internalsdlgfx
-LDFLAGS+= -L${LOCALBASE}/lib -lintl
-OPTIONS_DEFINE= OPENGL
+OPTIONS_DEFINE= OPENGL NLS
OPTIONS_DEFAULT= OPENGL
+OPTIONS_SUB= yes
OPENGL_CONFIGURE_WITH= opengl
OPENGL_USE= GL=gl
+NLS_USES= gettext
+NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
+NLS_LDFLAGS= -L${LOCALBASE}/lib -lintl
+NLS_CONFIGURE_ENABLE= nls
+
.include <bsd.port.mk>
diff --git a/games/manaplus/pkg-descr b/games/manaplus/pkg-descr
index 03cc2bd5b8fb..df13d6991330 100644
--- a/games/manaplus/pkg-descr
+++ b/games/manaplus/pkg-descr
@@ -2,4 +2,4 @@ ManaPlus is a 2D MMORPG client for games running on tmwAthena, evol or
eathena servers. It fully supports Evol Online, The Mana World and Land Of
Fire.
-WWW: http://www.manaplus.org
+WWW: http://www.manaplus.org/
diff --git a/games/manaplus/pkg-plist b/games/manaplus/pkg-plist
index 0321f886d8f1..5060348f73e0 100644
--- a/games/manaplus/pkg-plist
+++ b/games/manaplus/pkg-plist
@@ -4,28 +4,28 @@ man/man6/manaplus.6.gz
man/man6/manaplustest.6.gz
share/applications/manaplus.desktop
share/applications/manaplustest.desktop
-share/locale/ca/LC_MESSAGES/manaplus.mo
-share/locale/cs/LC_MESSAGES/manaplus.mo
-share/locale/de/LC_MESSAGES/manaplus.mo
-share/locale/es/LC_MESSAGES/manaplus.mo
-share/locale/fi/LC_MESSAGES/manaplus.mo
-share/locale/fr/LC_MESSAGES/manaplus.mo
-share/locale/id/LC_MESSAGES/manaplus.mo
-share/locale/it/LC_MESSAGES/manaplus.mo
-share/locale/ja/LC_MESSAGES/manaplus.mo
-share/locale/nl/LC_MESSAGES/manaplus.mo
-share/locale/nl_BE/LC_MESSAGES/manaplus.mo
-share/locale/pl/LC_MESSAGES/manaplus.mo
-share/locale/pt/LC_MESSAGES/manaplus.mo
-share/locale/pt_BR/LC_MESSAGES/manaplus.mo
-share/locale/ru/LC_MESSAGES/manaplus.mo
-share/locale/sr/LC_MESSAGES/manaplus.mo
-share/locale/sv/LC_MESSAGES/manaplus.mo
-share/locale/sv_SE/LC_MESSAGES/manaplus.mo
-share/locale/tr/LC_MESSAGES/manaplus.mo
-share/locale/uk/LC_MESSAGES/manaplus.mo
-share/locale/zh_CN/LC_MESSAGES/manaplus.mo
-share/locale/zh_HK/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/de/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/es/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/id/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/it/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/nl_BE/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/sv_SE/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/manaplus.mo
+%%NLS%%share/locale/zh_HK/LC_MESSAGES/manaplus.mo
%%DATADIR%%/data/fonts/dejavusans-bold.ttf
%%DATADIR%%/data/fonts/dejavusans.ttf
%%DATADIR%%/data/fonts/dejavusansmono-bold.ttf