aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2014-06-10 13:27:47 +0800
committerknu <knu@FreeBSD.org>2014-06-10 13:27:47 +0800
commit74607e266d7c33417cec582e71fc547229102c76 (patch)
tree979ac09d9d4d481f49a0662aceb95a8e11ef332d /games
parent8d81bc46ad8a97ea7b0938a4a02e2a8d8e93eaba (diff)
downloadfreebsd-ports-gnome-74607e266d7c33417cec582e71fc547229102c76.tar.gz
freebsd-ports-gnome-74607e266d7c33417cec582e71fc547229102c76.tar.zst
freebsd-ports-gnome-74607e266d7c33417cec582e71fc547229102c76.zip
Add staging support and remove NO_STAGEDIR.
Legacy pkg_tools support may have been broken.
Diffstat (limited to 'games')
-rw-r--r--games/unnethack/Makefile21
-rw-r--r--games/unnethack/pkg-plist14
2 files changed, 25 insertions, 10 deletions
diff --git a/games/unnethack/Makefile b/games/unnethack/Makefile
index d68f6c0fd1cc..ef321bcc7f55 100644
--- a/games/unnethack/Makefile
+++ b/games/unnethack/Makefile
@@ -19,28 +19,29 @@ MAKE_JOBS_UNSAFE= yes
VARDIR_REL= var/games/${PORTNAME}
VARDIR= ${PREFIX}/${VARDIR_REL}
CONFIGURE_ARGS= --datadir="${DATADIR:H}" --localstatedir="${VARDIR:H}" --docdir="${DOCSDIR:H}" \
- --with-owner=games --with-group=games \
+ --with-owner=no --with-group=no \
--enable-data-librarian
-MAKE_ARGS= FILEPERM=0664 \
- VARFILEPERM=0664 \
- VARDIRPERM=0775
+MAKE_ARGS= MANPREFIX="${STAGEDIR}${MANPREFIX}"
INSTALL_TARGET= install manpages
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SUB_FILES= pkg-deinstall
SUB_LIST= VARDIR="${VARDIR}"
PLIST_SUB= VARDIR="${VARDIR_REL}"
-# This port accually conflicts with other nethack variant ports on
-# these commands that are only significant for those who want to
-# "hack" the game in deep.
-MAN6= dgn_comp.6 dlb.6 lev_comp.6 recover.6 ${PORTNAME}.6
-NO_STAGE= yes
post-patch:
${MV} ${WRKSRC}/doc/nethack.6 ${WRKSRC}/doc/${PORTNAME}.6
post-install:
+ cd ${STAGEDIR}${PREFIX}/man/man6; \
+ for f in ${WRKSRC}/doc/*.6; do \
+ fn=$${f##*/}; \
+ case $$fn in \
+ unnethack.6) ;; \
+ *) ${MV} $$fn unnethack_$$fn ;; \
+ esac; \
+ done
.if !defined(NOPORTDOCS)
- ${INSTALL_DATA} ${FILESDIR}/sample.unnethackrc ${DOCSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/sample.unnethackrc ${STAGEDIR}${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/games/unnethack/pkg-plist b/games/unnethack/pkg-plist
index 8a50d3e89315..85c5fc8fb04d 100644
--- a/games/unnethack/pkg-plist
+++ b/games/unnethack/pkg-plist
@@ -1,16 +1,30 @@
+@owner games
+@group games
+@mode 2755
bin/unnethack
+@mode
%%DATADIR%%/nhdat
%%DATADIR%%/recover
%%DATADIR%%/unnethack
@dirrm %%DATADIR%%
+@mode 664
%%VARDIR%%/logfile
%%VARDIR%%/perm
%%VARDIR%%/record
%%VARDIR%%/xlogfile
+@mode 775
@dirrmtry %%VARDIR%%/bones
@dirrmtry %%VARDIR%%/level
@dirrmtry %%VARDIR%%/saves
@unexec rmdir -p %D/%%VARDIR%% 2>/dev/null || true
+@owner
+@group
+@mode
+man/man6/unnethack_dgn_comp.6.gz
+man/man6/unnethack_dlb.6.gz
+man/man6/unnethack_lev_comp.6.gz
+man/man6/unnethack_recover.6.gz
+man/man6/unnethack.6.gz
%%DOCSDIR%%/Guidebook.txt
%%DOCSDIR%%/license
%%PORTDOCS%%%%DOCSDIR%%/sample.unnethackrc