aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-04-10 20:52:33 +0800
committerpav <pav@FreeBSD.org>2004-04-10 20:52:33 +0800
commit74cc2109180586a2c3111b7bda66d289df7f7d8d (patch)
tree340c1bc888b02f1ea7d097d03b74dbe653519367 /games
parent4fea612e421592c5065ec0f2d659eda20576140b (diff)
downloadfreebsd-ports-gnome-74cc2109180586a2c3111b7bda66d289df7f7d8d.tar.gz
freebsd-ports-gnome-74cc2109180586a2c3111b7bda66d289df7f7d8d.tar.zst
freebsd-ports-gnome-74cc2109180586a2c3111b7bda66d289df7f7d8d.zip
Add phpua-ut2003, Unreal Tournament 2003 plug-in for phpUA.
PR: ports/65193 Submitted by: Hideki Machida <hido@neojapangz.com>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/phpua-ut2003/Makefile51
-rw-r--r--games/phpua-ut2003/distinfo2
-rw-r--r--games/phpua-ut2003/files/pkg-opts10
-rw-r--r--games/phpua-ut2003/pkg-descr11
-rw-r--r--games/phpua-ut2003/pkg-plist15
6 files changed, 90 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index aa5a8f36ea48..62e91743c516 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -332,6 +332,7 @@
SUBDIR += phpua-hl
SUBDIR += phpua-q3
SUBDIR += phpua-ut
+ SUBDIR += phpua-ut2003
SUBDIR += pinball
SUBDIR += pipenightdreams
SUBDIR += pmars
diff --git a/games/phpua-ut2003/Makefile b/games/phpua-ut2003/Makefile
new file mode 100644
index 000000000000..6bf9312462ae
--- /dev/null
+++ b/games/phpua-ut2003/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: phpua-plugin_ut2003
+# Date created: 29 March 2003
+# Whom: hideki
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpua-plugin_ut2003
+PORTVERSION= 1.1.0b
+CATEGORIES= games www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= phpua
+
+MAINTAINER= hido@neojapangz.com
+COMMENT= An Unreal Tournament 2003 plugin for phpUA
+
+RUN_DEPENDS= ${PKG_DBDIR}/phpua-engine-1.1.0b:${PORTSDIR}/games/phpua-engine
+
+# Some variables you can change
+PHPUA?= www/data/phpua
+USER?= www
+GROUP?= www
+
+# Static Variables
+PKGOPTS= ${FILESDIR}/pkg-opts
+
+NO_BUILD= yes
+
+PLIST_SUB+= PHPUA=${PHPUA}
+
+options:
+ @ ${ECHO_MSG} "===> Build options for ${PKGNAME}:"
+ @ ${CAT} ${PKGOPTS}
+
+pre-everything::
+.if !defined(BATCH)
+ @ ${TEST} -r ${PKGOPTS} && \
+ (${ECHO_MSG} '-------------------------------------------------------------------------'; \
+ ${ECHO_MSG} 'Perform a "make options" to see a list of available installation options.'; \
+ ${ECHO_MSG} '-------------------------------------------------------------------------')
+.endif
+
+do-install:
+ @ ${CP} -R ${WRKDIR}/plugins ${PREFIX}/${PHPUA}/
+ @ ${CP} -R ${WRKDIR}/templates ${PREFIX}/${PHPUA}/
+ @ ${CHOWN} -R ${USER}:${GROUP} ${PREFIX}/${PHPUA}
+ @ ${ECHO_MSG} ""
+ @ ${ECHO_MSG} "* Files have been installed in"
+ @ ${ECHO_MSG} "* ${PREFIX}/${PHPUA}"
+ @ ${ECHO_MSG} "*"
+.include <bsd.port.mk>
diff --git a/games/phpua-ut2003/distinfo b/games/phpua-ut2003/distinfo
new file mode 100644
index 000000000000..35f2766e4c67
--- /dev/null
+++ b/games/phpua-ut2003/distinfo
@@ -0,0 +1,2 @@
+MD5 (phpua-plugin_ut2003-1.1.0b.tar.gz) = 306d20384154dce98d13dc8147bddd74
+SIZE (phpua-plugin_ut2003-1.1.0b.tar.gz) = 7646
diff --git a/games/phpua-ut2003/files/pkg-opts b/games/phpua-ut2003/files/pkg-opts
new file mode 100644
index 000000000000..60e0b3999572
--- /dev/null
+++ b/games/phpua-ut2003/files/pkg-opts
@@ -0,0 +1,10 @@
+
+> PHPUA [www/data/phpua]
+ The DocumentRoot for your webserver under ${PREFIX}
+
+> USER [www]
+ The user ID under which your webserver runs
+
+> GROUP [www]
+ The group ID under which your webserver runs
+
diff --git a/games/phpua-ut2003/pkg-descr b/games/phpua-ut2003/pkg-descr
new file mode 100644
index 000000000000..4fbdb69aa2ce
--- /dev/null
+++ b/games/phpua-ut2003/pkg-descr
@@ -0,0 +1,11 @@
+phpUA is a PHP script that enables gaming server administrators
+to manage their servers via a website interface and to display
+server information including live statistics to the public.
+Plug-ins allow for game, language and website design compatibility.
+
+This is a plug-in for Unreal Tournament 2003.
+
+WWW: http://phpua.sourceforge.net/
+
+- Hideki
+hido@neojapangz.com
diff --git a/games/phpua-ut2003/pkg-plist b/games/phpua-ut2003/pkg-plist
new file mode 100644
index 000000000000..8236d0ca9fe1
--- /dev/null
+++ b/games/phpua-ut2003/pkg-plist
@@ -0,0 +1,15 @@
+%%PHPUA%%/plugins/plugin_ut2003/plugin_ut2003.inc
+%%PHPUA%%/plugins/plugin_ut2003/plugin_ut2003_mode_info.inc
+%%PHPUA%%/plugins/plugin_ut2003/plugin_ut2003_mode_rules.inc
+%%PHPUA%%/plugins/plugin_ut2003/plugin_ut2003_mode_watch.inc
+%%PHPUA%%/templates/default/plugin_ut2003/info.tpl
+%%PHPUA%%/templates/default/plugin_ut2003/rules.tpl
+%%PHPUA%%/templates/default/plugin_ut2003/watch.js
+%%PHPUA%%/templates/default/plugin_ut2003/watch.tpl
+%%PHPUA%%/templates/default/plugin_ut2003/x.js
+%%PHPUA%%/templates/javascript/plugin_ut2003/info.tpl
+%%PHPUA%%/templates/wap/plugin_ut2003/info.tpl
+@dirrm %%PHPUA%%/templates/wap/plugin_ut2003
+@dirrm %%PHPUA%%/templates/javascript/plugin_ut2003
+@dirrm %%PHPUA%%/templates/default/plugin_ut2003
+@dirrm %%PHPUA%%/plugins/plugin_ut2003