aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2009-09-16 14:41:29 +0800
committerdanfe <danfe@FreeBSD.org>2009-09-16 14:41:29 +0800
commit76cbb17d4612a07f2757ff003a61dca2a05511bb (patch)
tree786a3014f26f35d1c75963df263f9b2244e04fe7 /games
parenta6ffc9b07563c90b8d04053945558ca6079707f7 (diff)
downloadfreebsd-ports-gnome-76cbb17d4612a07f2757ff003a61dca2a05511bb.tar.gz
freebsd-ports-gnome-76cbb17d4612a07f2757ff003a61dca2a05511bb.tar.zst
freebsd-ports-gnome-76cbb17d4612a07f2757ff003a61dca2a05511bb.zip
Check for WITH_NVIDIA_GL knob and correctly depend on linux-libGL/libGLU
provider ports. Submitted by: bsam Feature safe: yes
Diffstat (limited to 'games')
-rw-r--r--games/linux-worldofgoo-demo/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/games/linux-worldofgoo-demo/Makefile b/games/linux-worldofgoo-demo/Makefile
index 04bee2ac8e3a..383fb852d6f3 100644
--- a/games/linux-worldofgoo-demo/Makefile
+++ b/games/linux-worldofgoo-demo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= worldofgoo
PORTVERSION= 1.41
+PORTREVISION= 1
CATEGORIES= games linux
MASTER_SITES= http://freebsd.nsu.ru/distfiles/
PKGNAMEPREFIX= linux-
@@ -18,12 +19,19 @@ COMMENT= Demo version of incredible physics based puzzle/construction game
ONLY_FOR_ARCHS= i386 amd64
USE_LINUX= yes
-USE_LINUX_APPS= libglu libvorbis mikmod sdl12 sdlmixer
+USE_LINUX_APPS= libvorbis mikmod sdl12 sdlmixer
NO_BUILD= yes
WRKSRC= ${WRKDIR}/WorldOfGooDemo
DATADIR= ${PREFIX}/share/WorldOfGoo
DOCSDIR= ${PREFIX}/share/doc/WorldOfGoo
+.if defined(WITH_NVIDIA_GL)
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+USE_LINUX_APPS+= libglu
+.else
+USE_LINUX_APPS+= dri
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"