aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-04-21 22:15:45 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-04-21 22:15:45 +0800
commit76ff92c827012c55e4b36fcf131c7bf2950ac6ee (patch)
tree84e12aaba2abcb0f97e777451ac5e2dfd48d1a1a /games
parente2ff85837e29c5661a7df29573cec7a953b61124 (diff)
downloadfreebsd-ports-gnome-76ff92c827012c55e4b36fcf131c7bf2950ac6ee.tar.gz
freebsd-ports-gnome-76ff92c827012c55e4b36fcf131c7bf2950ac6ee.tar.zst
freebsd-ports-gnome-76ff92c827012c55e4b36fcf131c7bf2950ac6ee.zip
- Fix shebangs
- Switch to options helpers
Diffstat (limited to 'games')
-rw-r--r--games/tuxfighter/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/games/tuxfighter/Makefile b/games/tuxfighter/Makefile
index 52ee375c15f4..43a8ccd085fa 100644
--- a/games/tuxfighter/Makefile
+++ b/games/tuxfighter/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tuxfighter
PORTVERSION= 54
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games python
MASTER_SITES= SF/pygamebook/TuxFighter/TuxFighter${PORTVERSION}_source/ \
SF/nemysisfreebsdp/games/:icons
@@ -21,10 +21,10 @@ RUN_DEPENDS= ${PYGAME}
WRKSRC= ${WRKDIR}
-USES= python:2
+USES= python:2 shebangfix
+SHEBANG_FILES= TuxFighter54.py
PORTDOCS= readme_TuxFighter54.txt
-OPTIONS_DEFINE= DOCS
INSTALLS_ICONS= yes
ICON_SIZES= 48x48 64x64 72x72 96x96
@@ -34,6 +34,8 @@ SUB_FILES= ${PORTNAME} pkg-message
DESKTOP_ENTRIES="TuxFighter" "" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" ""
+OPTIONS_DEFINE= DOCS
+
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}
@${PYTHON_CMD} -O -m compileall ${WRKSRC}
@@ -56,6 +58,7 @@ do-install:
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}