aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-10-27 08:52:29 +0800
committerjbeich <jbeich@FreeBSD.org>2018-10-27 08:52:29 +0800
commit8027d7c9f52bf47c5512b0a27e355d9ae0ea4459 (patch)
tree3c2574cbf87ff74c664eaf3f0ee84062ee7d87e4 /games
parent7b8ea0338ad4cfc41f95b155a15acf8fe0b39173 (diff)
downloadfreebsd-ports-gnome-8027d7c9f52bf47c5512b0a27e355d9ae0ea4459.tar.gz
freebsd-ports-gnome-8027d7c9f52bf47c5512b0a27e355d9ae0ea4459.tar.zst
freebsd-ports-gnome-8027d7c9f52bf47c5512b0a27e355d9ae0ea4459.zip
games/spring: unbreak with boost 1.69
CMake Error at /usr/local/share/cmake/Modules/FindBoost.cmake:2049 (message): Unable to find the requested Boost libraries. Boost version: 1.69.0 Boost include path: /usr/local/include Could not find the following Boost libraries: boost_signals Some (but not all) of the required Boost libraries were found. You may need to install these additional Boost libraries. Alternatively, set BOOST_LIBRARYDIR to the directory containing Boost libraries or BOOST_ROOT to the location of Boost. Call Stack (most recent call first): CMakeLists.txt:245 (FIND_PACKAGE) PR: 232525
Diffstat (limited to 'games')
-rw-r--r--games/spring/files/patch-boost-1.6931
1 files changed, 31 insertions, 0 deletions
diff --git a/games/spring/files/patch-boost-1.69 b/games/spring/files/patch-boost-1.69
new file mode 100644
index 000000000000..22c97fbf39c3
--- /dev/null
+++ b/games/spring/files/patch-boost-1.69
@@ -0,0 +1,31 @@
+https://github.com/spring/spring/commit/a385d9d7715a
+
+CMake Error at /usr/local/share/cmake/Modules/FindBoost.cmake:2049 (message):
+ Unable to find the requested Boost libraries.
+
+ Boost version: 1.69.0
+
+ Boost include path: /usr/local/include
+
+ Could not find the following Boost libraries:
+
+ boost_signals
+
+ Some (but not all) of the required Boost libraries were found. You may
+ need to install these additional Boost libraries. Alternatively, set
+ BOOST_LIBRARYDIR to the directory containing Boost libraries or BOOST_ROOT
+ to the location of Boost.
+Call Stack (most recent call first):
+ CMakeLists.txt:245 (FIND_PACKAGE)
+
+--- CMakeLists.txt.orig 2014-10-07 20:09:51 UTC
++++ CMakeLists.txt
+@@ -242,7 +242,7 @@ if (MINGW)
+ set(SDL2_INCLUDE_DIR "${MINGWLIBS}/include/SDL2")
+ endif (MINGW)
+
+-FIND_PACKAGE(Boost 1.47.0 COMPONENTS thread regex program_options system chrono signals filesystem REQUIRED)
++FIND_PACKAGE(Boost 1.47.0 COMPONENTS thread regex program_options system chrono filesystem REQUIRED)
+ FIND_PACKAGE(Boost 1.47.0 COMPONENTS timer)
+ INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIR})
+