aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-09-18 22:01:15 +0800
committerrafan <rafan@FreeBSD.org>2006-09-18 22:01:15 +0800
commit80c4624be94b3ea2ca9162dc13ab831f3f4ae6a7 (patch)
treecbec1abd0761c1086a025f64f8b9900c210f52b6 /games
parent1b39ea4b0a953f0828ae9da9ab26c1276432c554 (diff)
downloadfreebsd-ports-gnome-80c4624be94b3ea2ca9162dc13ab831f3f4ae6a7.tar.gz
freebsd-ports-gnome-80c4624be94b3ea2ca9162dc13ab831f3f4ae6a7.tar.zst
freebsd-ports-gnome-80c4624be94b3ea2ca9162dc13ab831f3f4ae6a7.zip
- Add option for installing of the official bonus packs collection
- Change DIST_SUBDIR for compatible with games/linux-ut - Remove USE_PERL5 and lang/perl5.8 dependencies - Restore netgames patch which broken in previous 451 port version - Allow using more game options in ucc_map for rc_subr script such as "DM-Morbias][?game=BotPack.TeamGamePlus?mutator=" PR: ports/102212 Submitted by: Alexander Logvinov <ports at logvinov.com> (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/utserver/Makefile74
-rw-r--r--games/utserver/distinfo15
-rw-r--r--games/utserver/files/excludefiles2
-rw-r--r--games/utserver/files/ucc.in2
-rw-r--r--games/utserver/pkg-plist57
5 files changed, 126 insertions, 24 deletions
diff --git a/games/utserver/Makefile b/games/utserver/Makefile
index 2b5c5749435e..0d6c86f0103c 100644
--- a/games/utserver/Makefile
+++ b/games/utserver/Makefile
@@ -7,24 +7,25 @@
PORTNAME= utserver
PORTVERSION= 451
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games linux
MASTER_SITES= http://freebsd.unixfreunde.de/sources/:p436 \
ftp://ftp.wireplay.co.uk/pub/unrealtournament/server/:p436 \
ftp://ftp.fh-niederrhein.de/pub/win9x/gamesup/ut/:p436 \
http://www.utpg.org/patches/:p451
-DISTFILES= ut-server-436.tar.gz:p436 ${PATCH451FILES}
-EXTRACT_ONLY= ut-server-436.tar.gz
+DISTFILES= ${MAINFILE}:p436 ${PATCH451FILE}:p451
+DIST_SUBDIR= linux-ut
+EXTRACT_ONLY= ${MAINFILE}
MAINTAINER= ports@logvinov.com
COMMENT= Unreal Tournament Dedicated Server for Linux
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
-BUILD_DEPENDS= ${RUN_DEPENDS}
+
+OPTIONS= BONUSPACKS 'install the official bonus packs collection' on
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
-USE_PERL5= yes
NO_CDROM= Size; the data set is much too big
NO_BUILD= yes
WRKSRC= ${WRKDIR}/ut-server
@@ -34,28 +35,67 @@ UTDIR= ut-server
PLIST_SUB= UTDIR="${UTDIR}/"
SUB_LIST= UTDIR="${PREFIX}/${UTDIR}"
SUB_FILES= pkg-message
-PATCH451FILES= UTPGPatch451.tar.bz2:p451
+MAINFILE= ut-server-436.tar.gz
+PATCH451FILE= UTPGPatch451.tar.bz2
EXTRA_PATCHES= ${WRKDIR}/patch-ngstatsut
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+PATCH_DEPENDS+= bsdtar:${PORTSDIR}/archivers/libarchive
+BSDTAR= ${LOCALBASE}/bin/bsdtar
+.else
+BSDTAR= ${TAR}
+.endif
+
+.if !defined(WITHOUT_BONUSPACKS)
+MASTER_SITES+= http://liflg.0wnitsch.de/files/native/:pbonus
+BONUSFILE= unreal.tournament.official.bonus.pack.collection.run
+DISTFILES+= ${BONUSFILE}:pbonus
+PLIST_SUB+= WITH_BONUSPACKS=""
+.else
+PLIST_SUB+= WITH_BONUSPACKS="@comment "
+.endif
+
+pre-fetch:
+.if exists(${DISTDIR}/${MAINFILE})
+ @${MKDIR} ${_DISTDIR}
+ @${MV} ${DISTDIR}/${MAINFILE} ${_DISTDIR}/
+.endif
+.if exists(${DISTDIR}/${PATCH451FILE})
+ @${MKDIR} ${_DISTDIR}
+ @${MV} ${DISTDIR}/${PATCH451FILE} ${_DISTDIR}/
+.endif
+
pre-patch:
@${SED} -e "s!%%LOCALBASE%%!${LOCALBASE}!" \
- -e "s!%%UTDIR%%!${PREFIX}/${UTDIR}!" \
- ${FILESDIR}/template-patch-ngstatsut > \
- ${WRKDIR}/patch-ngstatsut
-
-do-patch:
- @${TAR} jx -C ${WRKSRC} -X ${FILESDIR}/excludefiles \
- -f ${_DISTDIR}/${PATCH451FILES:C/:.*//}
+ -e "s!%%UTDIR%%!${PREFIX}/${UTDIR}!" \
+ ${FILESDIR}/template-patch-ngstatsut > \
+ ${WRKDIR}/patch-ngstatsut
+.if !defined(WITHOUT_BONUSPACKS)
+ @${SED} -e '1,/exit $$res/d' ${_DISTDIR}/${BONUSFILE} | \
+ ${BSDTAR} xf - -C ${WRKDIR} -X ${FILESDIR}/excludefiles
+.for file in "bp1.tar.bz2 bp2.tar.bz2 bp3.tar.bz2 bp4.tar.bz2"
+ @${BSDTAR} x -C ${WRKSRC} -f ${WRKDIR}/${file}
+.endfor
+ @${MV} ${WRKDIR}/README.bonus.pack.collection ${WRKSRC}/Help
+.endif
+ @${BSDTAR} x -C ${WRKSRC} -X ${FILESDIR}/excludefiles \
+ -f ${_DISTDIR}/${PATCH451FILE}
+ @${RM} -f ${WRKSRC}/System/libSDL-1.1.so.0
# remove trailing ^M
@${FIND} -E ${WRKSRC} -type f \
- -iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|int|lst|pl|pm|sc|sh|scr|txt|url|uhtm|inc)" \
- -exec ${PERL} -pi -ne 's!\r\n!\n!' {} 1>/dev/null 2>&1 \;
+ -iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|int|lst| \
+ pl|pm|sc|sh|scr|txt|url|uhtm|inc|ver)" \
+ -exec ${SH} -c "${SED} "s/`printf '\r'`//" '{}' \
+ >${WRKDIR}/tmp.txt; ${MV} ${WRKDIR}/tmp.txt '{}'" \;
+post-patch:
+ @${FIND} -E ${WRKSRC} -type f -name '*.orig' -exec ${RM} '{}' \;
do-install:
@${CP} -Rp ${WRKSRC}/ ${PREFIX}/${UTDIR}
- @${RM} -f ${PREFIX}/${UTDIR}/System/libSDL-1.1.so.0
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/utserver/distinfo b/games/utserver/distinfo
index b2cc5630f624..039b9e315262 100644
--- a/games/utserver/distinfo
+++ b/games/utserver/distinfo
@@ -1,6 +1,9 @@
-MD5 (ut-server-436.tar.gz) = 10cd7353aa9d758a075c600a6dd193fd
-SHA256 (ut-server-436.tar.gz) = 282b5d71d53322c76052af3aa9e73292efcd42b1b074bd924631a9766b9e00f6
-SIZE (ut-server-436.tar.gz) = 92769123
-MD5 (UTPGPatch451.tar.bz2) = 77a735a78b1eb819042338859900b83b
-SHA256 (UTPGPatch451.tar.bz2) = 31a07fb289841ceba36ca707fafd8180f48e462a53a62a2b34d5bc0f61c2481d
-SIZE (UTPGPatch451.tar.bz2) = 3064473
+MD5 (linux-ut/ut-server-436.tar.gz) = 10cd7353aa9d758a075c600a6dd193fd
+SHA256 (linux-ut/ut-server-436.tar.gz) = 282b5d71d53322c76052af3aa9e73292efcd42b1b074bd924631a9766b9e00f6
+SIZE (linux-ut/ut-server-436.tar.gz) = 92769123
+MD5 (linux-ut/UTPGPatch451.tar.bz2) = 77a735a78b1eb819042338859900b83b
+SHA256 (linux-ut/UTPGPatch451.tar.bz2) = 31a07fb289841ceba36ca707fafd8180f48e462a53a62a2b34d5bc0f61c2481d
+SIZE (linux-ut/UTPGPatch451.tar.bz2) = 3064473
+MD5 (linux-ut/unreal.tournament.official.bonus.pack.collection.run) = 82e71a81de1eaf4e09648372c0ca7289
+SHA256 (linux-ut/unreal.tournament.official.bonus.pack.collection.run) = b4ac49ab1df2bd9644d05e0dfe6a67effbaeab739b6073c98220872eb9eec464
+SIZE (linux-ut/unreal.tournament.official.bonus.pack.collection.run) = 37213789
diff --git a/games/utserver/files/excludefiles b/games/utserver/files/excludefiles
index 24de4f1c7980..1a29796929c2 100644
--- a/games/utserver/files/excludefiles
+++ b/games/utserver/files/excludefiles
@@ -22,3 +22,5 @@ System/ut-bin
System/editorres
checkfiles.sh
patch.md5
+setup.data
+setup.sh
diff --git a/games/utserver/files/ucc.in b/games/utserver/files/ucc.in
index b102bcf0309f..661f952feb64 100644
--- a/games/utserver/files/ucc.in
+++ b/games/utserver/files/ucc.in
@@ -25,7 +25,7 @@ load_rc_config $name
pidfile=${ucc_pidfile}
command="%%UTDIR%%/System/ucc-bin"
-command_args="server ${ucc_map} ini=${ucc_config}"
+command_args="server \"${ucc_map}\" ini=${ucc_config}"
start_cmd="ucc_startcmd"
ucc_startcmd()
diff --git a/games/utserver/pkg-plist b/games/utserver/pkg-plist
index 24df2b291d41..1fd8d822785c 100644
--- a/games/utserver/pkg-plist
+++ b/games/utserver/pkg-plist
@@ -4,6 +4,11 @@
%%UTDIR%%Help/UnrealTournamentSetupLogo.bmp
%%UTDIR%%Help/UnrealTournamentSetupLogo.gif
%%UTDIR%%Help/ReleaseNotes.htm
+%%WITH_BONUSPACKS%%%%UTDIR%%Help/BP4README.txt
+%%WITH_BONUSPACKS%%%%UTDIR%%Help/BonusPackReadme.txt
+%%WITH_BONUSPACKS%%%%UTDIR%%Help/README.bonus.pack.collection
+%%WITH_BONUSPACKS%%%%UTDIR%%Help/demutators-readme.txt
+%%WITH_BONUSPACKS%%%%UTDIR%%Help/inoxxpack.txt
%%UTDIR%%Logs/delete_me.txt
%%UTDIR%%Maps/AS-Frigate.unr
%%UTDIR%%Maps/AS-Guardia.unr
@@ -21,6 +26,20 @@
%%UTDIR%%Maps/CTF-LavaGiant.unr
%%UTDIR%%Maps/CTF-Niven.unr
%%UTDIR%%Maps/CTF-November.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-Cybrosis][.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-Beatitude.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-Darji16.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-EpicBoy.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-Face-SE.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-Face][.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-HallOfGiants.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-High.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-Hydro16.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-Kosov.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-Noxion16.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-Nucleus.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-Orbital.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/CTF-Ratchet.unr
%%UTDIR%%Maps/DM-Barricade.unr
%%UTDIR%%Maps/DM-Codex.unr
%%UTDIR%%Maps/DM-Conveyor.unr
@@ -45,6 +64,23 @@
%%UTDIR%%Maps/DM-Tempest.unr
%%UTDIR%%Maps/DM-Turbine.unr
%%UTDIR%%Maps/DM-Zeto.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DM-Agony.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DM-ArcaneTemple.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DM-Bishop.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DM-Closer.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DM-Crane.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DM-Cybrosis][.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DM-Grit-TOURNEY.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DM-HealPod][.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DM-Malevolence.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DM-Mojo][.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DM-Shrapnel][.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DM-SpaceNoxx.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DM-Viridian-TOURNEY.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DOM-Bullet.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DOM-Cidom.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DOM-Lament][.unr
+%%WITH_BONUSPACKS%%%%UTDIR%%Maps/DOM-WolfsBay.unr
%%UTDIR%%Maps/DOM-Cinder.unr
%%UTDIR%%Maps/DOM-Condemned.unr
%%UTDIR%%Maps/DOM-Cryptic.unr
@@ -183,6 +219,7 @@
%%UTDIR%%NetGamesUSA.com/ngStats/ngusa.jar
%%UTDIR%%NetGamesUSA.com/ngStats/processedLogs/_tmp
%%UTDIR%%NetGamesUSA.com/ngStats/spawnBrowser.exe
+%%UTDIR%%NetGamesUSA.com/ngWorldStats/bin/bgWorldStats
%%UTDIR%%NetGamesUSA.com/ngWorldStats/bin/ngWS.ver
%%UTDIR%%NetGamesUSA.com/ngWorldStats/bin/ngWorldStats
%%UTDIR%%NetGamesUSA.com/ngWorldStats/bin/ngWorldStats End User License Agreement (EULA).txt
@@ -287,6 +324,19 @@
%%UTDIR%%System/de.int
%%UTDIR%%System/de.u
%%UTDIR%%System/ucc-bin
+%%WITH_BONUSPACKS%%%%UTDIR%%System/EpicCustomModels.u
+%%WITH_BONUSPACKS%%%%UTDIR%%System/MultiMesh.int
+%%WITH_BONUSPACKS%%%%UTDIR%%System/MultiMesh.u
+%%WITH_BONUSPACKS%%%%UTDIR%%System/Relics.int
+%%WITH_BONUSPACKS%%%%UTDIR%%System/Relics.u
+%%WITH_BONUSPACKS%%%%UTDIR%%System/RelicsBindings.int
+%%WITH_BONUSPACKS%%%%UTDIR%%System/RelicsBindings.u
+%%WITH_BONUSPACKS%%%%UTDIR%%System/SkeletalChars.int
+%%WITH_BONUSPACKS%%%%UTDIR%%System/SkeletalChars.u
+%%WITH_BONUSPACKS%%%%UTDIR%%System/TCowMeshSkins.int
+%%WITH_BONUSPACKS%%%%UTDIR%%System/TNaliMeshSkins.int
+%%WITH_BONUSPACKS%%%%UTDIR%%System/TSkMSkins.int
+%%WITH_BONUSPACKS%%%%UTDIR%%System/de-logo.bmp
%%UTDIR%%Textures/AlfaFX.utx
%%UTDIR%%Textures/Ancient.utx
%%UTDIR%%Textures/ArenaTex.utx
@@ -392,6 +442,13 @@
%%UTDIR%%Textures/credits.utx
%%UTDIR%%Textures/eol.utx
%%UTDIR%%Textures/of1.utx
+%%WITH_BONUSPACKS%%%%UTDIR%%Textures/Factory.utx
+%%WITH_BONUSPACKS%%%%UTDIR%%Textures/SGTech1.utx
+%%WITH_BONUSPACKS%%%%UTDIR%%Textures/TCowMeshSkins.utx
+%%WITH_BONUSPACKS%%%%UTDIR%%Textures/TNaliMeshSkins.utx
+%%WITH_BONUSPACKS%%%%UTDIR%%Textures/TSkMSkins.utx
+%%WITH_BONUSPACKS%%%%UTDIR%%Textures/noxxpack.utx
+%%WITH_BONUSPACKS%%%%UTDIR%%Textures/xutfx.utx
%%UTDIR%%Web/current.uhtm
%%UTDIR%%Web/current_console.uhtm
%%UTDIR%%Web/current_console_log.uhtm