aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-05-09 18:04:21 +0800
committeritetcu <itetcu@FreeBSD.org>2006-05-09 18:04:21 +0800
commit83dae055adb80fe201906e91767a48a0b94f853a (patch)
treea396867b5343e55d6e647c33c40035fbeed68768 /games
parentd708eaeba8fe6c06c85ed36b338550db8e9bd5c7 (diff)
downloadfreebsd-ports-gnome-83dae055adb80fe201906e91767a48a0b94f853a.tar.gz
freebsd-ports-gnome-83dae055adb80fe201906e91767a48a0b94f853a.tar.zst
freebsd-ports-gnome-83dae055adb80fe201906e91767a48a0b94f853a.zip
Update to 0.1.1
New Changes in dangerdeep: - new SSE intrinsic code for x86/64 and x86/32 - new sky rendering - MSVC compile fixes - new font and some gui changes - display per torpedo info - sensor detection code once per second, not once per frame, improves performance - convoy fixes (position simulation) - added mission editor - added Kennebac class tanker - fixed widget bugs - more data per model (country etc.) - fixed some models - new panel (smaller), new message display (nicer) - fixes for popups - new popup: rangefinder card - shader fixes - new vessel preview - added doxygen documentation - improved model format (with relations) - fixes for compatibility with newer drivers and OpenGL2.0 - improved water rendering (mirror distorsion effect) - TDC improvements - Parallax angle computation and display - new faulthandler for debugging segfaults - load/save format changed to xml based data - better perlin noise generation - new sounds and music - new background images for menues PR: ports/95767 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe> (maintainer) Approved by: lawrance (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/dangerdeep/Makefile12
-rw-r--r--games/dangerdeep/distinfo6
-rw-r--r--games/dangerdeep/files/patch-SConstruct76
-rw-r--r--games/dangerdeep/files/patch-src_coastmap.cpp11
4 files changed, 18 insertions, 87 deletions
diff --git a/games/dangerdeep/Makefile b/games/dangerdeep/Makefile
index 5b0779bb445c..f7ecf1e0789a 100644
--- a/games/dangerdeep/Makefile
+++ b/games/dangerdeep/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dangerdeep
-PORTVERSION= 0.1.0
+PORTVERSION= 0.1.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= dangerdeep
@@ -15,7 +15,8 @@ MAINTAINER= acardenas@bsd.org.pe
COMMENT= Open source World War II German submarine simulation
BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons
-LIB_DEPENDS= fftw3.3:${PORTSDIR}/math/fftw3
+LIB_DEPENDS= fftw3.3:${PORTSDIR}/math/fftw3 \
+ execinfo.1:${PORTSDIR}/devel/libexecinfo
USE_X_PREFIX= yes
USE_GL= yes
@@ -25,7 +26,8 @@ MAKE_ENV= CC="${CC}" CXX="${CXX}"
SCONS_ARGS= installbindir=${PREFIX}/bin installdatadir=${DATADIR}
PLIST= ${WRKDIR}/pkg-plist
-PLIST_FILES= bin/dangerdeep
+PLIST_FILES= bin/dangerdeep bin/crosssection bin/damagemodel \
+ bin/oceantest bin/portal bin/viewmodel
PLIST_DIRS= %%DATADIR%%
MAN6= dangerdeep.6
@@ -55,7 +57,9 @@ pre-install:
${FIND} * -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/build/freebsd/dangerdeep ${PREFIX}/bin
+ @cd ${WRKSRC}/build/freebsd && \
+ ${INSTALL_PROGRAM} dangerdeep crosssection damagemodel oceantest \
+ portal viewmodel ${PREFIX}/bin
cd ${WRKSRC}/data && \
${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
diff --git a/games/dangerdeep/distinfo b/games/dangerdeep/distinfo
index c590839b35b1..ab83e66cecd4 100644
--- a/games/dangerdeep/distinfo
+++ b/games/dangerdeep/distinfo
@@ -1,3 +1,3 @@
-MD5 (dangerdeep-0.1.0.tar.gz) = 7e95d871b929a5e322d0a6bde37e7151
-SHA256 (dangerdeep-0.1.0.tar.gz) = 6b987559dc637e2d77a9e0f16d60fb1d58db5513c459b395a74942e7b3b31982
-SIZE (dangerdeep-0.1.0.tar.gz) = 12429406
+MD5 (dangerdeep-0.1.1.tar.gz) = 7de20b4594c0fee8d3c1a281f686f943
+SHA256 (dangerdeep-0.1.1.tar.gz) = de6334c88bac6ce1463e48444e550899a61ea85cecf8929a160d07e28f502a20
+SIZE (dangerdeep-0.1.1.tar.gz) = 23831169
diff --git a/games/dangerdeep/files/patch-SConstruct b/games/dangerdeep/files/patch-SConstruct
index 6185b0867f40..b0e95e2a6a1e 100644
--- a/games/dangerdeep/files/patch-SConstruct
+++ b/games/dangerdeep/files/patch-SConstruct
@@ -1,72 +1,10 @@
---- SConstruct.orig Mon Oct 17 20:45:59 2005
-+++ SConstruct Sat Oct 29 14:30:06 2005
-@@ -2,6 +2,11 @@
- import os
- import sys
-
-+################ FreeBSD port variables
-+LOCALBASE = os.environ['LOCALBASE']
-+X11BASE = os.environ['X11BASE']
-+SDL_CONFIG = os.environ['SDL_CONFIG']
-+
- ################ global config values
- version = '0.1.0'
- if ARGUMENTS.get('version', 0):
-@@ -67,10 +72,12 @@
- else:
- print "Compiling for Unix/Posix/Linux Environment"
- env = Environment(ENV = os.environ)
-- env.Append(CPPPATH = ['/usr/include/SDL', '/usr/include/GL'])
-- libpath = ['/usr/X11R6/lib']
-+ env.Replace(CC = os.environ['CC'])
-+ env.Replace(CXX = os.environ['CXX'])
-+ env.Append(CPPPATH = [LOCALBASE + '/include', LOCALBASE + '/include/SDL11', X11BASE + '/include', X11BASE + '/include/GL'])
-+ libpath = [LOCALBASE + '/lib', X11BASE + '/lib']
+--- SConstruct Fri Apr 14 05:13:03 2006
++++ SConstruct Fri Apr 14 16:18:12 2006
+@@ -81,6 +81,7 @@
+ libpath = [LOCALBASE + '/lib', X11BASE + '/lib']
gllibs = ['GL', 'GLU']
-- sdllibs = ['SDL', 'SDL_image']
-+ sdllibs = ['SDL_image']
- ccflags = '-Wall `sdl-config --cflags`'
- if (debug >= 3):
- ccflags += ' -g -pg -O3' # profiling
-@@ -92,31 +99,28 @@
- if (cvedit == 1):
- env.Append(CPPDEFINES = ['CVEDIT'])
- # check for mmx/sse support
-- cpuinfof = open('/proc/cpuinfo', 'r')
-+ cpuinfof = os.popen('sysctl -n hw.instruction_sse')
+ sdllibs = ['SDL_image']
++ extralibs = ['execinfo']
+ cpuinfof = os.popen('sysctl -n hw.instruction_sse')
cpuinfol = cpuinfof.readlines()
mmxsupported = False
- ssesupported = False
- for i in cpuinfol:
-- if i.startswith('flags'):
-- m = Split(i)
-- for j in m:
-- if j == 'mmx':
-- mmxsupported = True
-- elif j == 'sse':
-- ssesupported = True
-- break
-+ if i == '1\n':
-+ mmxsupported = True
-+ ssesupported = True
- if (usex86sse == 0) and (mmxsupported and ssesupported):
- usex86sse = 1
- if usex86sse >= 1:
- env.Append(CPPDEFINES = ['USE_SSE'])
- osspecificsrc += ['water_sse.cpp']
- print 'Using x86 SSE/MMX optimizations.'
-- env.Append(CCFLAGS = ccflags)
-+ env.Replace(CCFLAGS = os.environ['CFLAGS'])
-+ env.Replace(CXXFLAGS = os.environ['CXXFLAGS'] + ' `' + SDL_CONFIG + ' --cflags`')
-+ env.Append(LINKFLAGS = '`' + SDL_CONFIG + ' --libs`')
- datadir = installdatadir
-- build_dir = 'linux'
-+ build_dir = 'freebsd'
- # check for broken libGL, ignore undefined symbols then
-- if (os.system('grep glBindProgram /usr/include/GL/gl*.h > /dev/null') == 0):
-- gllibdirs = ['/usr/X11R6/lib/', '/usr/lib/', '/usr/local/lib/']
-+ if (os.system('grep glBindProgram ' + X11BASE + '/include/GL/gl*.h > /dev/null') == 0):
-+ gllibdirs = [X11BASE + '/lib/', '/usr/lib/', LOCALBASE + '/lib/']
- gllibdir = ''
- for i in gllibdirs:
- if (os.system('test -f '+i+'libGL.so') == 0):
diff --git a/games/dangerdeep/files/patch-src_coastmap.cpp b/games/dangerdeep/files/patch-src_coastmap.cpp
deleted file mode 100644
index 3d225aa265fc..000000000000
--- a/games/dangerdeep/files/patch-src_coastmap.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/coastmap.cpp Mon Jul 18 16:19:30 2005
-+++ src/coastmap.cpp Fri Oct 28 15:30:30 2005
-@@ -1316,7 +1316,7 @@
- maph = surf->h;
- pixelw_real = realwidth/mapw;
- realheight = maph*realwidth/mapw;
-- pixels_per_seg = 1 << unsigned(ceil(log2(60000/pixelw_real)));
-+ pixels_per_seg = 1 << unsigned(ceil(log(60000/pixelw_real)));
- segsx = mapw/pixels_per_seg;
- segsy = maph/pixels_per_seg;
- segw_real = pixelw_real * pixels_per_seg;