aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-04-13 18:36:15 +0800
committerjbeich <jbeich@FreeBSD.org>2016-04-13 18:36:15 +0800
commit883b888942cffae3476d05cb91b882636a1e7977 (patch)
tree4e9607083456960d04d51c761a85448e0510cb47 /games
parentbc50e8ce9a6ac464a36af1dd8f90bc99a219adda (diff)
downloadfreebsd-ports-gnome-883b888942cffae3476d05cb91b882636a1e7977.tar.gz
freebsd-ports-gnome-883b888942cffae3476d05cb91b882636a1e7977.tar.zst
freebsd-ports-gnome-883b888942cffae3476d05cb91b882636a1e7977.zip
Consistently prefer ${CONFIGURE_CMD} over ./${CONFIGURE_SCRIPT}
This also fixes SET_LATE_CONFIGURE_ARGS with custom CONFIGURE_CMD. PR: 208294 Exp-run by: antoine Approved by: portmgr (antoine), perl (mat) Differential Revision: https://reviews.freebsd.org/D4158
Diffstat (limited to 'games')
-rw-r--r--games/eboard/Makefile2
-rw-r--r--games/nimuh/Makefile2
-rw-r--r--games/volleyball/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index 5afcc0dfbf2e..015c4eb15895 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -76,7 +76,7 @@ post-install:
.endfor
.endif
.for extra in ${EXTRAS}
- @cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} EBOARDCONFIG=${STAGEDIR}${PREFIX}/bin/eboard-config ./${CONFIGURE_SCRIPT} --prefix=${PREFIX}
+ @cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} EBOARDCONFIG=${STAGEDIR}${PREFIX}/bin/eboard-config ${CONFIGURE_CMD} --prefix=${PREFIX}
@cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} ${MAKE_ENV} ${MAKE} install DATADIR=${STAGEDIR}${DATADIR}
.endfor
@${INSTALL_DATA} ${WRKSRC}/icon-eboard.xpm ${STAGEDIR}${PREFIX}/share/pixmaps/eboard.xpm
diff --git a/games/nimuh/Makefile b/games/nimuh/Makefile
index 0e1a6d2ded51..a878e829a91d 100644
--- a/games/nimuh/Makefile
+++ b/games/nimuh/Makefile
@@ -30,7 +30,7 @@ post-patch:
@${REINPLACE_CMD} -e '/LIBS/ s|-lSDL_[a-z]*|& $${SDL_LIBS}|' ${WRKSRC}/configure
post-configure:
- @cd ${DATA_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
+ @cd ${DATA_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${CONFIGURE_CMD} ${CONFIGURE_ARGS}
post-install:
@cd ${DATA_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}
diff --git a/games/volleyball/Makefile b/games/volleyball/Makefile
index f9a61f123c81..fb2a071e8b27 100644
--- a/games/volleyball/Makefile
+++ b/games/volleyball/Makefile
@@ -41,7 +41,7 @@ post-patch:
post-configure:
cd ${WRKDIR}/${PORTNAME}-data-${DATAVERSION} && \
- ${SETENV} ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
+ ${SETENV} ${CONFIGURE_ENV} ${CONFIGURE_CMD} ${CONFIGURE_ARGS}
post-install:
cd ${WRKDIR}/${PORTNAME}-data-${DATAVERSION} && \