aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2019-06-22 03:12:43 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2019-06-22 03:12:43 +0800
commit8db1bc092d7024cfd4cd9ea0b4361b83f2e3bd40 (patch)
tree434100f1a0d8aacb87f4c368c1076468a52a051e /games
parentd9538f2f7bc97b5a99403f13461dba6fa69e22cd (diff)
downloadfreebsd-ports-gnome-8db1bc092d7024cfd4cd9ea0b4361b83f2e3bd40.tar.gz
freebsd-ports-gnome-8db1bc092d7024cfd4cd9ea0b4361b83f2e3bd40.tar.zst
freebsd-ports-gnome-8db1bc092d7024cfd4cd9ea0b4361b83f2e3bd40.zip
- Switch to more correct way of avoiding C++11 related build errors, by specifying older c++ standard
Diffstat (limited to 'games')
-rw-r--r--games/allacrost/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
index d6aeee84e570..925f081a1afe 100644
--- a/games/allacrost/Makefile
+++ b/games/allacrost/Makefile
@@ -20,15 +20,15 @@ LIB_DEPENDS= libpng.so:graphics/png \
libboost_thread.so:devel/boost-libs
GNU_CONFIGURE= yes
-USES= compiler:c++11-lang gettext gmake iconv jpeg lua:51 openal:al
+USES= gettext gmake iconv jpeg localbase lua:51 openal:al
USE_SDL= sdl ttf net
USE_GL= gl glu
USE_XORG= x11
+USE_CXXSTD= c++98
CONFIGURE_ARGS= --datadir=${DATADIR} --enable-editor=no
-CPPFLAGS+= -I${LOCALBASE}/include -I${LUA_INCDIR}
-LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
-CXXFLAGS+= -Wno-c++11-narrowing
+CPPFLAGS+= -isystem${LUA_INCDIR}
+LDFLAGS+= -L${LUA_LIBDIR}
LLD_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}