aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-06-29 05:59:26 +0800
committeralepulver <alepulver@FreeBSD.org>2006-06-29 05:59:26 +0800
commit8ee43bd3ef6bc974387f219c2cb77861afee2c93 (patch)
treeca65551122ccc1d6608ee877bb9d6727b58e5319 /games
parente62bd29146c5e7219cda19cefb7b1d1b11ea20ac (diff)
downloadfreebsd-ports-gnome-8ee43bd3ef6bc974387f219c2cb77861afee2c93.tar.gz
freebsd-ports-gnome-8ee43bd3ef6bc974387f219c2cb77861afee2c93.tar.zst
freebsd-ports-gnome-8ee43bd3ef6bc974387f219c2cb77861afee2c93.zip
- Avoid corrupting PNG files with USE_DOS2UNIX.
Diffstat (limited to 'games')
-rw-r--r--games/galaxyhack/Makefile9
-rw-r--r--games/galaxyhack/files/patch-Makefile (renamed from games/galaxyhack/files/patch-src__Makefile)4
2 files changed, 6 insertions, 7 deletions
diff --git a/games/galaxyhack/Makefile b/games/galaxyhack/Makefile
index b6e02baa5a82..a9ed844b0141 100644
--- a/games/galaxyhack/Makefile
+++ b/games/galaxyhack/Makefile
@@ -23,8 +23,7 @@ USE_BZIP2= yes
USE_DOS2UNIX= yes
USE_GMAKE= yes
USE_SDL= gfx image mixer sdl
-WRKSRC= ${WRKDIR}/${PORTNAME}
-BUILD_WRKSRC= ${WRKSRC}/src
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
OPTIONS= FLEETS "Install additional fleets" off \
OPTIMIZED_CFLAGS "Enable compilation optimizations" on
@@ -53,11 +52,11 @@ MAKE_ENV+= OPTIMIZED_CFLAGS=YES
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-sh ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${PREFIX}/libexec
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/libexec
${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/settings.dat ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/../settings.dat ${DATADIR}
.for d in fleets gamedata graphics music standardpictures
- ${CP} -R ${WRKSRC}/${d} ${DATADIR}
+ ${CP} -R ${WRKSRC}/../${d} ${DATADIR}
.endfor
.if defined(WITH_FLEETS)
@${UNZIP_CMD} -o ${_DISTDIR}/${FLEETS_FILE} -d ${DATADIR}/fleets
diff --git a/games/galaxyhack/files/patch-src__Makefile b/games/galaxyhack/files/patch-Makefile
index 0443e2e90790..ae94a063a207 100644
--- a/games/galaxyhack/files/patch-src__Makefile
+++ b/games/galaxyhack/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./src/Makefile.orig Mon Apr 17 16:33:33 2006
-+++ ./src/Makefile Sat Jun 10 17:00:12 2006
+--- ./Makefile.orig Mon Apr 17 16:33:33 2006
++++ ./Makefile Sat Jun 10 17:00:12 2006
@@ -9,10 +9,13 @@
INSTALL_DIR=/usr/local/share
INSTALL_BIN_DIR=/usr/local/bin