aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-03-17 02:34:09 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2019-03-17 02:34:09 +0800
commit8f06b655c45874ef5d35589960fae5b593e1afdd (patch)
tree8749093a3a82febc003970530ff4aeba012d9084 /games
parent9f11cca79ba9bac41c2fbd1edcaa7bd7b017c4d0 (diff)
downloadfreebsd-ports-gnome-8f06b655c45874ef5d35589960fae5b593e1afdd.tar.gz
freebsd-ports-gnome-8f06b655c45874ef5d35589960fae5b593e1afdd.tar.zst
freebsd-ports-gnome-8f06b655c45874ef5d35589960fae5b593e1afdd.zip
games/legend-of-edgar: Update to 1.31
Changes: https://github.com/riksweeney/edgar/releases
Diffstat (limited to 'games')
-rw-r--r--games/legend-of-edgar/Makefile6
-rw-r--r--games/legend-of-edgar/distinfo6
-rw-r--r--games/legend-of-edgar/files/patch-makefile10
-rw-r--r--games/legend-of-edgar/files/patch-src_headers.h20
4 files changed, 21 insertions, 21 deletions
diff --git a/games/legend-of-edgar/Makefile b/games/legend-of-edgar/Makefile
index 1dbc81be6fc4..2dd9a1110bf7 100644
--- a/games/legend-of-edgar/Makefile
+++ b/games/legend-of-edgar/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= edgar
-DISTVERSION= 1.29
+DISTVERSION= 1.31
CATEGORIES= games
MASTER_SITES= https://github.com/riksweeney/edgar/releases/download/${DISTVERSION}/
PKGNAMEPREFIX= legend-of-
@@ -16,8 +16,8 @@ LICENSE_FILE= ${WRKSRC}/doc/license
LIB_DEPENDS= libpng.so:graphics/png
-USES= gmake
-USE_SDL= image mixer sdl ttf
+USES= gmake sdl
+USE_SDL= image2 mixer2 sdl2 ttf2
MAKEFILE= makefile
MAKE_ARGS= BIN_DIR=${PREFIX}/bin/ \
DATA_DIR=${DATADIR}/ \
diff --git a/games/legend-of-edgar/distinfo b/games/legend-of-edgar/distinfo
index a63e0ed2716d..60ca43f95619 100644
--- a/games/legend-of-edgar/distinfo
+++ b/games/legend-of-edgar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1534768635
-SHA256 (edgar-1.29-1.tar.gz) = c163a0c2e3459e264ba507535934ebb1ab3915b77c210409abc306f27323779a
-SIZE (edgar-1.29-1.tar.gz) = 92971537
+TIMESTAMP = 1552758736
+SHA256 (edgar-1.31-1.tar.gz) = 7184fafe49c68008b761b793967ff96911575deb0337b808c506291459288844
+SIZE (edgar-1.31-1.tar.gz) = 91857274
diff --git a/games/legend-of-edgar/files/patch-makefile b/games/legend-of-edgar/files/patch-makefile
index 92fbce24bc53..15e1c175a7ee 100644
--- a/games/legend-of-edgar/files/patch-makefile
+++ b/games/legend-of-edgar/files/patch-makefile
@@ -3,7 +3,7 @@
the stage directory and that the game can actually find its assets
at runtime
---- makefile.orig 2018-04-22 07:16:24 UTC
+--- makefile.orig 2019-03-16 12:57:53 UTC
+++ makefile
@@ -22,7 +22,7 @@ PO_PROG = po_creator
TILE_PROG = tile_creator
@@ -18,11 +18,11 @@
ifeq ($(DEV),1)
CFLAGS += -Werror -g
endif
-+CFLAGS += $(shell sdl-config --cflags)
++CFLAGS += $(shell sdl2-config --cflags)
DEFINES = -DVERSION=$(VERSION) -DRELEASE=$(RELEASE) -DDEV=$(DEV) -DINSTALL_PATH=\"$(DATA_DIR)\" -DLOCALE_DIR=\"$(LOCALE_DIR)\" -DUNIX=$(UNIX)
ifndef NO_PAK
-@@ -103,11 +104,11 @@ endif
+@@ -104,11 +105,11 @@ endif
all : $(PROG) makefile.dep $(ED_PROG) $(PAK_PROG) $(LOCALE_MO) $(PO_PROG)
makefile.dep : src/*/*.h src/*.h
@@ -36,10 +36,10 @@
%.mo: %.po
msgfmt -c -o $@ $<
-@@ -148,37 +149,37 @@ ifeq ($(DEV),1)
+@@ -148,37 +149,37 @@ install: all buildpak
+ ifeq ($(DEV),1)
echo Cannot install if DEV is set to 1!
else
- $(MAKE) buildpak
- mkdir -p $(BIN_DIR)
- mkdir -p $(DATA_DIR)
- mkdir -p $(DOC_DIR)
diff --git a/games/legend-of-edgar/files/patch-src_headers.h b/games/legend-of-edgar/files/patch-src_headers.h
index 6108dfe71e45..1d1adc0c7db1 100644
--- a/games/legend-of-edgar/files/patch-src_headers.h
+++ b/games/legend-of-edgar/files/patch-src_headers.h
@@ -4,16 +4,16 @@
#include <windows.h>
#endif
--#include "SDL/SDL.h"
--#include "SDL/SDL_endian.h"
--#include "SDL/SDL_image.h"
--#include "SDL/SDL_mixer.h"
--#include "SDL/SDL_ttf.h"
-+#include <SDL/SDL.h>
-+#include <SDL/SDL_endian.h>
-+#include <SDL/SDL_image.h>
-+#include <SDL/SDL_mixer.h>
-+#include <SDL/SDL_ttf.h>
+-#include "SDL2/SDL.h"
+-#include "SDL2/SDL_endian.h"
+-#include "SDL2/SDL_image.h"
+-#include "SDL2/SDL_mixer.h"
+-#include "SDL2/SDL_ttf.h"
++#include <SDL.h>
++#include <SDL_endian.h>
++#include <SDL_image.h>
++#include <SDL_mixer.h>
++#include <SDL_ttf.h>
#include "structs.h"
#include "i18n.h"