aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-05-15 18:01:55 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-05-15 18:01:55 +0800
commit974a96798b0635315a2f54e2eb5349bef1ace0de (patch)
treee014e8d5421ae4cf68c329b18382386c485ad990 /games
parent9fd7b8be780a2e67f5c1f25ab05c383391907c1f (diff)
downloadfreebsd-ports-gnome-974a96798b0635315a2f54e2eb5349bef1ace0de.tar.gz
freebsd-ports-gnome-974a96798b0635315a2f54e2eb5349bef1ace0de.tar.zst
freebsd-ports-gnome-974a96798b0635315a2f54e2eb5349bef1ace0de.zip
There's a black box. You can shoot in and watch, where the shot
leaves the box. In the box, crystals are reflecting the shots. You have to guess where the crystals are hidden, by watching your shots. WWW: http://www.linux-games.com/black-box/ PR: 167355 Submitted by: nemysis <nemysis@gmx.ch>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/black-box/Makefile32
-rw-r--r--games/black-box/distinfo2
-rw-r--r--games/black-box/pkg-descr6
-rw-r--r--games/black-box/pkg-plist34
5 files changed, 75 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 055f0f50fa8f..eef52f298464 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -72,6 +72,7 @@
SUBDIR += biniax2
SUBDIR += biorythm
SUBDIR += bitefusion
+ SUBDIR += black-box
SUBDIR += blackjack
SUBDIR += blackshadeselite
SUBDIR += blinken
diff --git a/games/black-box/Makefile b/games/black-box/Makefile
new file mode 100644
index 000000000000..fae282dc95e3
--- /dev/null
+++ b/games/black-box/Makefile
@@ -0,0 +1,32 @@
+# New Ports collection makefile for: black-box
+# Date created: 2012-04-27
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= black-box
+PORTVERSION= 1.4.8
+CATEGORIES= games
+MASTER_SITES= http://www.linux-games.com/black-box/
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= You can shoot in and watch, where the shot leaves the box
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+USE_SDL= sdl image mixer
+MAKE_JOBS_SAFE= yes
+
+PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/black-box/distinfo b/games/black-box/distinfo
new file mode 100644
index 000000000000..f3a55455735c
--- /dev/null
+++ b/games/black-box/distinfo
@@ -0,0 +1,2 @@
+SHA256 (black-box-1.4.8.tar.gz) = 9cf6a31a96e487c86973a4fe4603ed16709b6196de872d34f8df785c809b73bd
+SIZE (black-box-1.4.8.tar.gz) = 359256
diff --git a/games/black-box/pkg-descr b/games/black-box/pkg-descr
new file mode 100644
index 000000000000..6a0aaeeedd3b
--- /dev/null
+++ b/games/black-box/pkg-descr
@@ -0,0 +1,6 @@
+There's a black box. You can shoot in and watch, where the shot
+leaves the box. In the box, crystals are reflecting the shots.
+You have to guess where the crystals are hidden, by watching your
+shots.
+
+WWW: http://www.linux-games.com/black-box/
diff --git a/games/black-box/pkg-plist b/games/black-box/pkg-plist
new file mode 100644
index 000000000000..b85859db8b38
--- /dev/null
+++ b/games/black-box/pkg-plist
@@ -0,0 +1,34 @@
+bin/black-box
+%%DATADIR%%/gfx/box.gif
+%%DATADIR%%/gfx/demo1.gif
+%%DATADIR%%/gfx/demo2.gif
+%%DATADIR%%/gfx/demo3.gif
+%%DATADIR%%/gfx/demo4.gif
+%%DATADIR%%/gfx/demo5.gif
+%%DATADIR%%/gfx/demo6.gif
+%%DATADIR%%/gfx/demo7.gif
+%%DATADIR%%/gfx/demo8.gif
+%%DATADIR%%/gfx/edge1.gif
+%%DATADIR%%/gfx/edge1red.gif
+%%DATADIR%%/gfx/edge2.gif
+%%DATADIR%%/gfx/edge2red.gif
+%%DATADIR%%/gfx/edge3.gif
+%%DATADIR%%/gfx/edge3red.gif
+%%DATADIR%%/gfx/edge4.gif
+%%DATADIR%%/gfx/font.png
+%%DATADIR%%/gfx/giveup.gif
+%%DATADIR%%/gfx/help.gif
+%%DATADIR%%/gfx/light.gif
+%%DATADIR%%/gfx/mouse.gif
+%%DATADIR%%/gfx/new.gif
+%%DATADIR%%/gfx/next.gif
+%%DATADIR%%/gfx/ok.gif
+%%DATADIR%%/gfx/prev.gif
+%%DATADIR%%/gfx/quit.gif
+%%DATADIR%%/gfx/real.gif
+%%DATADIR%%/gfx/think.gif
+%%DATADIR%%/gfx/won.png
+%%DATADIR%%/sound/ein1.mod
+@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%