aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-06-10 21:41:53 +0800
committersobomax <sobomax@FreeBSD.org>2001-06-10 21:41:53 +0800
commit97c127c4ffa0353fabe8893e9149fa61bd5bda41 (patch)
tree5956fd4f7c7c602fe785417f5908ef4c28bce21e /games
parenteff46b9cde70b9ca1ccffc04c68d8c20ef2d9c02 (diff)
downloadfreebsd-ports-gnome-97c127c4ffa0353fabe8893e9149fa61bd5bda41.tar.gz
freebsd-ports-gnome-97c127c4ffa0353fabe8893e9149fa61bd5bda41.tar.zst
freebsd-ports-gnome-97c127c4ffa0353fabe8893e9149fa61bd5bda41.zip
Add sdlroids 1.3.4, an enhanced shoot-the-asteroids game.
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/sdlroids/Makefile27
-rw-r--r--games/sdlroids/distinfo1
-rw-r--r--games/sdlroids/pkg-comment1
-rw-r--r--games/sdlroids/pkg-descr7
-rw-r--r--games/sdlroids/pkg-plist34
6 files changed, 71 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 124a7e0bb58d..80b8dd07c74a 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -194,6 +194,7 @@
SUBDIR += rt2-demo
SUBDIR += rtb
SUBDIR += rubix
+ SUBDIR += sdlroids
SUBDIR += seabattle
SUBDIR += seahaven
SUBDIR += sex
diff --git a/games/sdlroids/Makefile b/games/sdlroids/Makefile
new file mode 100644
index 000000000000..c250072703c8
--- /dev/null
+++ b/games/sdlroids/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: sdlroids
+# Date created: 29 March 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdlroids
+PORTVERSION= 1.3.4
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+
+USE_GMAKE= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+
+MAN6= sdlroids.6
+
+.include <bsd.port.mk>
diff --git a/games/sdlroids/distinfo b/games/sdlroids/distinfo
new file mode 100644
index 000000000000..51e86f0da8eb
--- /dev/null
+++ b/games/sdlroids/distinfo
@@ -0,0 +1 @@
+MD5 (sdlroids-1.3.4.tar.bz2) = ae3c310bf2871809a0e8317f47bf0b50
diff --git a/games/sdlroids/pkg-comment b/games/sdlroids/pkg-comment
new file mode 100644
index 000000000000..013f563abb7f
--- /dev/null
+++ b/games/sdlroids/pkg-comment
@@ -0,0 +1 @@
+An enhanced shoot-the-asteroids game
diff --git a/games/sdlroids/pkg-descr b/games/sdlroids/pkg-descr
new file mode 100644
index 000000000000..887705033373
--- /dev/null
+++ b/games/sdlroids/pkg-descr
@@ -0,0 +1,7 @@
+SDLRoids is essentially an Asteroids clone, but with a few extra
+features, and some nice game physics. It is based on xhyperoid, which
+is a UNIX port of the 16-bit Windows game Hyperoid. Major changes from
+xhyperoid are that it's using SDL for sound and graphics, has a couple
+of extra powerups and that the shield behaves differently.
+
+WWW: http://david.hedbor.org/projects/sdlroids/
diff --git a/games/sdlroids/pkg-plist b/games/sdlroids/pkg-plist
new file mode 100644
index 000000000000..e34f4b03e8a1
--- /dev/null
+++ b/games/sdlroids/pkg-plist
@@ -0,0 +1,34 @@
+bin/sdlroids
+share/sdlroids/bmp/blank.bmp
+share/sdlroids/bmp/bomb.bmp
+share/sdlroids/bmp/icon.bmp
+share/sdlroids/bmp/level.bmp
+share/sdlroids/bmp/life.bmp
+share/sdlroids/bmp/num0.bmp
+share/sdlroids/bmp/num1.bmp
+share/sdlroids/bmp/num2.bmp
+share/sdlroids/bmp/num3.bmp
+share/sdlroids/bmp/num4.bmp
+share/sdlroids/bmp/num5.bmp
+share/sdlroids/bmp/num6.bmp
+share/sdlroids/bmp/num7.bmp
+share/sdlroids/bmp/num8.bmp
+share/sdlroids/bmp/num9.bmp
+share/sdlroids/bmp/plus.bmp
+share/sdlroids/bmp/score.bmp
+share/sdlroids/bmp/shield.bmp
+share/sdlroids/sounds/bonusgot.wav
+share/sdlroids/sounds/bshot.wav
+share/sdlroids/sounds/bwound.wav
+share/sdlroids/sounds/explode.wav
+share/sdlroids/sounds/explode2.wav
+share/sdlroids/sounds/newbad.wav
+share/sdlroids/sounds/newbonus.wav
+share/sdlroids/sounds/phit.wav
+share/sdlroids/sounds/pshot.wav
+share/sdlroids/sounds/swarmsplit.wav
+share/sdlroids/sounds/thrust.wav
+share/sdlroids/sounds/title.wav
+@dirrm share/sdlroids/sounds
+@dirrm share/sdlroids/bmp
+@dirrm share/sdlroids