aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-07-30 17:38:55 +0800
committertobik <tobik@FreeBSD.org>2018-07-30 17:38:55 +0800
commit97e13479ac40068815239e333ba4f2b7726ab76e (patch)
tree1997f862fecc2ff4788a3c83683f4a0b10d617fa /games
parent5bbd8e1a7d208a2ee9121610880a20b88b3576fb (diff)
downloadfreebsd-ports-gnome-97e13479ac40068815239e333ba4f2b7726ab76e.tar.gz
freebsd-ports-gnome-97e13479ac40068815239e333ba4f2b7726ab76e.tar.zst
freebsd-ports-gnome-97e13479ac40068815239e333ba4f2b7726ab76e.zip
games/xpacman: Fix build with Clang 6
./shapes.h:63:38: error: constant expression evaluates to 240 which cannot be narrowed to type 'char' [-Wc++11-narrowing] static SHAPETYPE pacman0_bits[]= {0xf0, 0x0f, 0xf0, 0x0f, 0xfc, 0x3f, 0xfc, 0x3f, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xfc, 0x3f, 0xfc, 0x3f, 0xf0, 0x0f, 0xf0, 0x0f}; ^~~~ http://beefy12.nyi.freebsd.org/data/head-amd64-default/p475478_s336801/logs/errors/xpacman-1.002.log
Diffstat (limited to 'games')
-rw-r--r--games/xpacman/Makefile6
-rw-r--r--games/xpacman/files/patch-pac.h15
2 files changed, 20 insertions, 1 deletions
diff --git a/games/xpacman/Makefile b/games/xpacman/Makefile
index d77c74441473..aa6b4af60e26 100644
--- a/games/xpacman/Makefile
+++ b/games/xpacman/Makefile
@@ -14,9 +14,13 @@ LICENSE= GPLv2
RUN_DEPENDS+= ${LOCALBASE}/share/fonts/misc/9x18.pcf.gz:x11-fonts/font-misc-misc
+USES= compiler
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-doublesize
-CPPFLAGS+= -I${LOCALBASE}/include
+# Build ignores CFLAGS, CXXFLAGS
+CPPFLAGS+= -I${LOCALBASE}/include ${CPPFLAGS_${CHOSEN_COMPILER_TYPE}}
+CPPFLAGS_clang= -Wno-c++11-narrowing
LDFLAGS+= -L${LOCALBASE}/lib
USE_XORG= x11 xext
PLIST_FILES= bin/pacman
diff --git a/games/xpacman/files/patch-pac.h b/games/xpacman/files/patch-pac.h
new file mode 100644
index 000000000000..0904693afd79
--- /dev/null
+++ b/games/xpacman/files/patch-pac.h
@@ -0,0 +1,15 @@
+./pac.h:36:30: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-Wreserved-user-defined-literal]
+#define PACTITLE "Pacman v. "VERSION" \xa9 1995,1999,2000 by Roar Thron\xe6s"
+ ^
+
+--- pac.h.orig 2018-07-30 09:36:15 UTC
++++ pac.h
+@@ -33,7 +33,7 @@ void writetext(); //just draw text
+
+ //change my name and you will be sued!!!!!!!!!!!!!!!!!!!!!!!!!!
+ #ifndef VMS
+-#define PACTITLE "Pacman v. "VERSION" \xa9 1995,1999,2000 by Roar Thron\xe6s"
++#define PACTITLE "Pacman v. " VERSION " \xa9 1995,1999,2000 by Roar Thron\xe6s"
+ #else
+ #define PACTITLE "Pacman v. 1_002 \xa9 1995,1999,2000 by Roar Thron\xe6s"
+ #endif