aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-13 05:25:19 +0800
committeredwin <edwin@FreeBSD.org>2007-09-13 05:25:19 +0800
commit98c5b788d3f0dc51fef223f8942cd0272ba3c646 (patch)
tree60db4524aba1dc71fce6a3426d44c8064e423864 /games
parentb23997e108abf48369a901c5dc3e6641bba5952f (diff)
downloadfreebsd-ports-gnome-98c5b788d3f0dc51fef223f8942cd0272ba3c646.tar.gz
freebsd-ports-gnome-98c5b788d3f0dc51fef223f8942cd0272ba3c646.tar.zst
freebsd-ports-gnome-98c5b788d3f0dc51fef223f8942cd0272ba3c646.zip
New port - games/antrix
Free Stable Dedicated-server for World of Warcraft PR: ports/116290 Submitted by: skillcoder <skillcoder@mail.ru>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/antrix/Makefile34
-rw-r--r--games/antrix/distinfo3
-rw-r--r--games/antrix/pkg-descr8
-rw-r--r--games/antrix/pkg-plist18
5 files changed, 64 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index f95d3933c37e..d481a05ab55d 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -44,6 +44,7 @@
SUBDIR += angband
SUBDIR += annelid
SUBDIR += antipolix
+ SUBDIR += antrix
SUBDIR += aop
SUBDIR += apoolGL
SUBDIR += aqbubble
diff --git a/games/antrix/Makefile b/games/antrix/Makefile
new file mode 100644
index 000000000000..6fe267466fd0
--- /dev/null
+++ b/games/antrix/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: antrix
+# Date created: 11 September 2007
+# Whom: Denisov Evgeniy <skillcoder@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= antrix
+PORTVERSION= 1477
+CATEGORIES= games
+MASTER_SITES= http://skillcoder.narod.ru/wow/antrix/ \
+ http://wtq.ru/wow/antrix/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= skillcoder@mail.ru
+COMMENT= Free stable dedicated-server for World of Warcraft
+
+BUILD_DEPENDS= svn:${PORTSDIR}/devel/subversion
+
+USE_AUTOTOOLS= aclocal:19 libtoolize autoconf:261 autoheader:261 automake:19 libtool:15
+ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
+AUTOMAKE_ARGS= -a
+USE_MYSQL= yes
+CFLAGS+= -O0
+USE_LDCONFIG= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --prefix=${PREFIX} --sysconfdir=${PREFIX}/etc --datadir=${PREFIX}/share
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+run-autotools-automake:
+ @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} ${AUTOMAKE_ARGS})
+
+.include <bsd.port.mk>
diff --git a/games/antrix/distinfo b/games/antrix/distinfo
new file mode 100644
index 000000000000..499081572747
--- /dev/null
+++ b/games/antrix/distinfo
@@ -0,0 +1,3 @@
+MD5 (antrix-1477.tar.gz) = 8d04674ad56eb7cd57aa2fbd6a660f55
+SHA256 (antrix-1477.tar.gz) = 80bc0008faccde34cb5f74338fdeff0aa4210961b887faa19d5a98462a02c238
+SIZE (antrix-1477.tar.gz) = 8230927
diff --git a/games/antrix/pkg-descr b/games/antrix/pkg-descr
new file mode 100644
index 000000000000..a3dcaf4cfd96
--- /dev/null
+++ b/games/antrix/pkg-descr
@@ -0,0 +1,8 @@
+Ascent(Antrix) Emulator is an Open Source reference
+implementation for a MMORPG server system. Please see the file COPYING for
+license details.
+
+WWW: http://www.ascentemu.com/
+
+- skillcoder
+skillcoder@mail.ru
diff --git a/games/antrix/pkg-plist b/games/antrix/pkg-plist
new file mode 100644
index 000000000000..4baf5439820c
--- /dev/null
+++ b/games/antrix/pkg-plist
@@ -0,0 +1,18 @@
+bin/ascent
+bin/logonserver
+lib/libGossipScripts.a
+lib/libGossipScripts.la
+lib/libGossipScripts.so
+lib/libGossipScripts.so.0
+lib/libInstanceScripts.a
+lib/libInstanceScripts.la
+lib/libInstanceScripts.so
+lib/libInstanceScripts.so.0
+lib/libServerStatusPlugin.a
+lib/libServerStatusPlugin.la
+lib/libServerStatusPlugin.so
+lib/libServerStatusPlugin.so.0
+lib/libSpellHandlers.a
+lib/libSpellHandlers.la
+lib/libSpellHandlers.so
+lib/libSpellHandlers.so.0