aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-01-11 06:22:30 +0800
committeralepulver <alepulver@FreeBSD.org>2007-01-11 06:22:30 +0800
commit994a3b4311634aaf9c4a30f4c204ab4fa5004f61 (patch)
tree356cf36a225467a39e90e8b1312590a1437e1433 /games
parentb5b7d4b65a76957b231edd70c2b3c92e797852cc (diff)
downloadfreebsd-ports-gnome-994a3b4311634aaf9c4a30f4c204ab4fa5004f61.tar.gz
freebsd-ports-gnome-994a3b4311634aaf9c4a30f4c204ab4fa5004f61.tar.zst
freebsd-ports-gnome-994a3b4311634aaf9c4a30f4c204ab4fa5004f61.zip
- Fix building with GCC 4.x.
Reported by: pointyhat
Diffstat (limited to 'games')
-rw-r--r--games/egl/files/patch-renderer__rf_image.c11
-rw-r--r--games/quake2-ctf/files/patch-g_items.c15
-rw-r--r--games/quake2-ctf/files/patch-p_weapon.c11
-rw-r--r--games/quake2-matrix/files/patch-MatrixFixSource__Makefile2
-rw-r--r--games/quake2-matrix/files/patch-MatrixFixSource__g_items.c15
-rw-r--r--games/quake2-psychomod/files/patch-src__Makefile2
-rw-r--r--games/quake2-psychomod/files/patch-src__g_items.c15
-rw-r--r--games/quake2-rogue/files/patch-g_items.c15
-rw-r--r--games/quake2-xatrix/files/patch-g_items.c15
-rw-r--r--games/quake2-zaero/files/patch-g_items.c15
10 files changed, 114 insertions, 2 deletions
diff --git a/games/egl/files/patch-renderer__rf_image.c b/games/egl/files/patch-renderer__rf_image.c
new file mode 100644
index 000000000000..91779a55b7ff
--- /dev/null
+++ b/games/egl/files/patch-renderer__rf_image.c
@@ -0,0 +1,11 @@
+--- renderer/rf_image.c.orig Wed Jan 10 18:55:48 2007
++++ renderer/rf_image.c Wed Jan 10 18:57:53 2007
+@@ -44,7 +44,7 @@
+ image_t *r_lmTextures[R_MAX_LIGHTMAPS];
+ static image_t r_imageList[MAX_IMAGES];
+ static image_t *r_imageHashTree[MAX_IMAGE_HASH];
+-static uint32 r_numImages;
++uint32 r_numImages;
+
+ static byte r_intensityTable[256];
+ static byte r_gammaTable[256];
diff --git a/games/quake2-ctf/files/patch-g_items.c b/games/quake2-ctf/files/patch-g_items.c
new file mode 100644
index 000000000000..7f0a7243b37e
--- /dev/null
+++ b/games/quake2-ctf/files/patch-g_items.c
@@ -0,0 +1,15 @@
+--- ./g_items.c.orig Wed Mar 4 18:51:16 1998
++++ ./g_items.c Wed Jan 10 19:04:52 2007
+@@ -21,9 +21,9 @@
+ gitem_armor_t combatarmor_info = { 50, 100, .60, .30, ARMOR_COMBAT};
+ gitem_armor_t bodyarmor_info = {100, 200, .80, .60, ARMOR_BODY};
+
+-static int jacket_armor_index;
+-static int combat_armor_index;
+-static int body_armor_index;
++int jacket_armor_index;
++int combat_armor_index;
++int body_armor_index;
+ static int power_screen_index;
+ static int power_shield_index;
+
diff --git a/games/quake2-ctf/files/patch-p_weapon.c b/games/quake2-ctf/files/patch-p_weapon.c
new file mode 100644
index 000000000000..ed0f716b4310
--- /dev/null
+++ b/games/quake2-ctf/files/patch-p_weapon.c
@@ -0,0 +1,11 @@
+--- ./p_weapon.c.orig Wed Mar 4 18:51:16 1998
++++ ./p_weapon.c Wed Jan 10 19:05:28 2007
+@@ -4,7 +4,7 @@
+ #include "m_player.h"
+
+
+-static qboolean is_quad;
++qboolean is_quad;
+ static byte is_silenced;
+
+
diff --git a/games/quake2-matrix/files/patch-MatrixFixSource__Makefile b/games/quake2-matrix/files/patch-MatrixFixSource__Makefile
index f48ecaab03ae..eb9b5895c6df 100644
--- a/games/quake2-matrix/files/patch-MatrixFixSource__Makefile
+++ b/games/quake2-matrix/files/patch-MatrixFixSource__Makefile
@@ -1,5 +1,5 @@
--- ./MatrixFixSource/Makefile.orig Fri Feb 3 05:47:07 2006
-+++ ./MatrixFixSource/Makefile Sun Dec 24 13:57:26 2006
++++ ./MatrixFixSource/Makefile Wed Jan 10 19:07:23 2007
@@ -16,22 +16,12 @@
# this nice line comes from the linux kernel makefile
ARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc/ -e s/sparc64/sparc/ -e s/arm.*/arm/ -e s/sa110/arm/ -e s/alpha/axp/)
diff --git a/games/quake2-matrix/files/patch-MatrixFixSource__g_items.c b/games/quake2-matrix/files/patch-MatrixFixSource__g_items.c
new file mode 100644
index 000000000000..44816438a103
--- /dev/null
+++ b/games/quake2-matrix/files/patch-MatrixFixSource__g_items.c
@@ -0,0 +1,15 @@
+--- ./MatrixFixSource/g_items.c.orig Fri Feb 3 05:47:07 2006
++++ ./MatrixFixSource/g_items.c Wed Jan 10 19:07:53 2007
+@@ -43,9 +43,9 @@
+ gitem_armor_t combatarmor_info = { 50, 100, .60, .30, ARMOR_COMBAT};
+ gitem_armor_t bodyarmor_info = {100, 200, .80, .60, ARMOR_BODY};
+
+-static int jacket_armor_index;
+-static int combat_armor_index;
+-static int body_armor_index;
++int jacket_armor_index;
++int combat_armor_index;
++int body_armor_index;
+ static int power_screen_index;
+ static int power_shield_index;
+
diff --git a/games/quake2-psychomod/files/patch-src__Makefile b/games/quake2-psychomod/files/patch-src__Makefile
index 3c8b681b5196..db762dd27e91 100644
--- a/games/quake2-psychomod/files/patch-src__Makefile
+++ b/games/quake2-psychomod/files/patch-src__Makefile
@@ -1,5 +1,5 @@
--- ./src/Makefile.orig Wed Feb 1 20:46:55 2006
-+++ ./src/Makefile Sun Dec 24 16:23:24 2006
++++ ./src/Makefile Wed Jan 10 19:11:16 2007
@@ -16,20 +16,10 @@
# this nice line comes from the linux kernel makefile
ARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc/ -e s/sparc64/sparc/ -e s/arm.*/arm/ -e s/sa110/arm/ -e s/alpha/axp/)
diff --git a/games/quake2-psychomod/files/patch-src__g_items.c b/games/quake2-psychomod/files/patch-src__g_items.c
new file mode 100644
index 000000000000..db547b75a80c
--- /dev/null
+++ b/games/quake2-psychomod/files/patch-src__g_items.c
@@ -0,0 +1,15 @@
+--- ./src/g_items.c.orig Wed Oct 10 12:53:12 2001
++++ ./src/g_items.c Wed Jan 10 19:11:41 2007
+@@ -21,9 +21,9 @@
+ gitem_armor_t combatarmor_info = { 50, 100, .60, .30, ARMOR_COMBAT};
+ gitem_armor_t bodyarmor_info = {100, 200, .80, .60, ARMOR_BODY};
+
+-static int jacket_armor_index;
+-static int combat_armor_index;
+-static int body_armor_index;
++int jacket_armor_index;
++int combat_armor_index;
++int body_armor_index;
+ static int power_screen_index;
+ static int power_shield_index;
+
diff --git a/games/quake2-rogue/files/patch-g_items.c b/games/quake2-rogue/files/patch-g_items.c
new file mode 100644
index 000000000000..c254445db789
--- /dev/null
+++ b/games/quake2-rogue/files/patch-g_items.c
@@ -0,0 +1,15 @@
+--- g_items.c.orig Mon Nov 30 17:53:36 1998
++++ g_items.c Wed Jan 10 19:14:55 2007
+@@ -34,9 +34,9 @@
+ gitem_armor_t combatarmor_info = { 50, 100, .60, .30, ARMOR_COMBAT};
+ gitem_armor_t bodyarmor_info = {100, 200, .80, .60, ARMOR_BODY};
+
+-static int jacket_armor_index;
+-static int combat_armor_index;
+-static int body_armor_index;
++int jacket_armor_index;
++int combat_armor_index;
++int body_armor_index;
+ static int power_screen_index;
+ static int power_shield_index;
+
diff --git a/games/quake2-xatrix/files/patch-g_items.c b/games/quake2-xatrix/files/patch-g_items.c
new file mode 100644
index 000000000000..bea176834daf
--- /dev/null
+++ b/games/quake2-xatrix/files/patch-g_items.c
@@ -0,0 +1,15 @@
+--- ./g_items.c.orig Mon Nov 30 17:55:28 1998
++++ ./g_items.c Wed Jan 10 19:17:48 2007
+@@ -26,9 +26,9 @@
+ gitem_armor_t combatarmor_info = { 50, 100, .60, .30, ARMOR_COMBAT};
+ gitem_armor_t bodyarmor_info = {100, 200, .80, .60, ARMOR_BODY};
+
+-static int jacket_armor_index;
+-static int combat_armor_index;
+-static int body_armor_index;
++int jacket_armor_index;
++int combat_armor_index;
++int body_armor_index;
+ static int power_screen_index;
+ static int power_shield_index;
+
diff --git a/games/quake2-zaero/files/patch-g_items.c b/games/quake2-zaero/files/patch-g_items.c
new file mode 100644
index 000000000000..336ca3225cc5
--- /dev/null
+++ b/games/quake2-zaero/files/patch-g_items.c
@@ -0,0 +1,15 @@
+--- ./g_items.c.orig Wed Jan 10 19:20:43 2007
++++ ./g_items.c Wed Jan 10 19:20:56 2007
+@@ -21,9 +21,9 @@
+ gitem_armor_t combatarmor_info = { 50, 100, .60, .30, ARMOR_COMBAT};
+ gitem_armor_t bodyarmor_info = {100, 200, .80, .60, ARMOR_BODY};
+
+-static int jacket_armor_index;
+-static int combat_armor_index;
+-static int body_armor_index;
++int jacket_armor_index;
++int combat_armor_index;
++int body_armor_index;
+ static int power_screen_index;
+ static int power_shield_index;
+