aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-04-22 06:03:34 +0800
committernemysis <nemysis@FreeBSD.org>2014-04-22 06:03:34 +0800
commit99d7fcbd114cc45dc30cb6a640e820ab27ba04e9 (patch)
tree1b20540adcb518a76dbc0fe54ef291f111c49fae /games
parentaa3aaa658f153640f7fdb857cc7455f12d7807a9 (diff)
downloadfreebsd-ports-gnome-99d7fcbd114cc45dc30cb6a640e820ab27ba04e9.tar.gz
freebsd-ports-gnome-99d7fcbd114cc45dc30cb6a640e820ab27ba04e9.tar.zst
freebsd-ports-gnome-99d7fcbd114cc45dc30cb6a640e820ab27ba04e9.zip
- Bump PORTREVISION, for LICENSE adding
- Add license (GPLv3) - Change Desktop entry file - Use PLIST_FILES and PLIST_DIRS instead of pkg-plist - Add DOCS and Option - Mute MKDIR - Install icon in ${PREFIX}/share/pixmaps for Desktop entry file - Add patch, fix build with Clang compiler [1] - Change pkg-descr, use whitespace instead of tabulator PR: ports/188286 Submitted by: pawel@ [1]
Diffstat (limited to 'games')
-rw-r--r--games/openpref/Makefile30
-rw-r--r--games/openpref/files/patch-src__util__debug.cpp10
-rw-r--r--games/openpref/pkg-descr2
-rw-r--r--games/openpref/pkg-plist5
4 files changed, 33 insertions, 14 deletions
diff --git a/games/openpref/Makefile b/games/openpref/Makefile
index a12f183460b3..78122fdf34da 100644
--- a/games/openpref/Makefile
+++ b/games/openpref/Makefile
@@ -3,24 +3,38 @@
PORTNAME= openpref
PORTVERSION= 0.1.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/OpenPref-Qt4/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/OpenPref-Qt4/${PORTNAME}-${PORTVERSION}/
MAINTAINER= annulen@yandex.ru
COMMENT= Preferans game
+LICENSE= GPLv3
+
USES= qmake
USE_QT4= corelib gui moc_build rcc_build uic_build
MAKE_JOBS_UNSAFE= yes
-DESKTOP_ENTRIES="OpenPref" "${COMMENT}" "${DATADIR}/openpref.png" \
- "openpref" "Game;CardGame;" true
+PLIST_FILES= bin/${PORTNAME} \
+ %%DATADIR%%/i18n/${PORTNAME}_ru.qm \
+ share/pixmaps/${PORTNAME}.png
+PLIST_DIRS= %%DATADIR%%/i18n %%DATADIR%%
+
+PORTDOCS= AUTHORS BUGS NEWS README THANKS
+OPTIONS_DEFINE= DOCS
+
+DESKTOP_ENTRIES="OpenPref" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;CardGame;" ""
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/openpref ${STAGEDIR}${PREFIX}/bin
- ${MKDIR} ${STAGEDIR}${DATADIR}/i18n
- ${INSTALL_DATA} ${WRKSRC}/openpref_ru.qm ${STAGEDIR}${DATADIR}/i18n
- ${INSTALL_DATA} ${WRKSRC}/pics/openpref.png ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ @${MKDIR} ${STAGEDIR}${DATADIR}/i18n
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}_ru.qm ${STAGEDIR}${DATADIR}/i18n/
+ ${INSTALL_DATA} ${WRKSRC}/pics/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/openpref/files/patch-src__util__debug.cpp b/games/openpref/files/patch-src__util__debug.cpp
new file mode 100644
index 000000000000..a91bc3978ecc
--- /dev/null
+++ b/games/openpref/files/patch-src__util__debug.cpp
@@ -0,0 +1,10 @@
+--- ./src/util/debug.cpp.orig 2014-04-05 15:33:31.000000000 +0200
++++ ./src/util/debug.cpp 2014-04-05 15:34:06.000000000 +0200
+@@ -20,6 +20,7 @@
+ * http://www.gnu.org/licenses
+ */
+
++#include <time.h>
+ #include <QFile>
+
+ #include "debug.h"
diff --git a/games/openpref/pkg-descr b/games/openpref/pkg-descr
index c7b2799d2382..bafe31a90725 100644
--- a/games/openpref/pkg-descr
+++ b/games/openpref/pkg-descr
@@ -3,4 +3,4 @@ Preferans (also known as Preference). It is written using cross-platform
Qt4 framework and is portable between many operating systems including
Windows and major Unix flavours.
-WWW: http://openpref.sourceforge.net
+WWW: http://openpref.sourceforge.net
diff --git a/games/openpref/pkg-plist b/games/openpref/pkg-plist
deleted file mode 100644
index 59f6143a9711..000000000000
--- a/games/openpref/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/openpref
-%%DATADIR%%/openpref.png
-%%DATADIR%%/i18n/openpref_ru.qm
-@dirrm %%DATADIR%%/i18n
-@dirrm %%DATADIR%%