aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-21 05:18:54 +0800
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-21 05:18:54 +0800
commit9a7cbd9494fb1f9b93a6ba11f377c094371c828e (patch)
treeb6ac982beb2d3e92896fb78e5a17950afebc2113 /games
parent1ed4f1d402236d5b0b60d0e0567e7a1b129bd29d (diff)
downloadfreebsd-ports-gnome-9a7cbd9494fb1f9b93a6ba11f377c094371c828e.tar.gz
freebsd-ports-gnome-9a7cbd9494fb1f9b93a6ba11f377c094371c828e.tar.zst
freebsd-ports-gnome-9a7cbd9494fb1f9b93a6ba11f377c094371c828e.zip
[BUG]: games/linux-nwnclient dependency problem
The linux-nwnclient port checks to see if WITH_NVIDIA_GL is defined to determine whether or not it should depend on the nvidia-driver instead of linux_dri. However, both dependencies are needed as linux_dri provides 'libGLU.so.1', which does not come with the nvidia-driver. This is needed in order to run linux-nwnclient. I use the nvidia-driver port and had to install linux_dri by hand after installing nwn. It seems to be working fine in conjunction with the driver. My suggestion is to either drop the nvidia-driver dependency entirely, or at least depend on linux_dri whether WITH_NVIDIA_GL is defined or not.
Diffstat (limited to 'games')
-rw-r--r--games/linux-nwnclient/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/games/linux-nwnclient/Makefile b/games/linux-nwnclient/Makefile
index 1a40576a9cb4..9392f69d2b68 100644
--- a/games/linux-nwnclient/Makefile
+++ b/games/linux-nwnclient/Makefile
@@ -18,12 +18,11 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Neverwinter Nights Linux (x86) Client
RUN_DEPENDS= ${LOCALBASE}/share/nwndata/NWNv129.txt:${PORTSDIR}/games/nwndata \
- ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
+ ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
.ifdef(WITH_NVIDIA_GL)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
-.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
.endif
NO_BUILD= yes