aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-26 23:25:17 +0800
committerpav <pav@FreeBSD.org>2005-01-26 23:25:17 +0800
commit9af9ce5b158db4abfae74f93960b01bd8862c911 (patch)
tree331f1f10ed8ded3127e4aae8b16c47ee4552c204 /games
parent9abdcbb8f73b305ebc6479b087940e6a639f21d4 (diff)
downloadfreebsd-ports-gnome-9af9ce5b158db4abfae74f93960b01bd8862c911.tar.gz
freebsd-ports-gnome-9af9ce5b158db4abfae74f93960b01bd8862c911.tar.zst
freebsd-ports-gnome-9af9ce5b158db4abfae74f93960b01bd8862c911.zip
- Unbreak: remove two conflicting functions, which are never used anyway.
PR: ports/76635 Submitted by: Johan van Selst <johans@stack.nl> (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/KnightCap/Makefile8
-rw-r--r--games/KnightCap/files/patch-knightcap.h19
2 files changed, 20 insertions, 7 deletions
diff --git a/games/KnightCap/Makefile b/games/KnightCap/Makefile
index 33b735facb14..edfe375fb86f 100644
--- a/games/KnightCap/Makefile
+++ b/games/KnightCap/Makefile
@@ -26,12 +26,6 @@ DOCSDIR= ${PREFIX}/share/doc/KnightCap
PORTDOCS= README
PLIST_FILES= bin/KnightCap
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/KnightCap ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@@ -39,4 +33,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/KnightCap/files/patch-knightcap.h b/games/KnightCap/files/patch-knightcap.h
new file mode 100644
index 000000000000..86e49fbe7591
--- /dev/null
+++ b/games/KnightCap/files/patch-knightcap.h
@@ -0,0 +1,19 @@
+--- knightcap.h Mon Jan 24 22:20:22 2005
++++ knightcap.h Mon Jan 24 22:17:19 2005
+@@ -632,16 +632,6 @@
+ return i1 > i2? i1 : i2;
+ }
+
+-static inline float fmin(float i1, float i2)
+-{
+- return i1 > i2? i2 : i1;
+-}
+-
+-static inline float fmax(float i1, float i2)
+-{
+- return i1 > i2? i1 : i2;
+-}
+-
+ static inline etype emin(etype i1, etype i2)
+ {
+ return i1 > i2? i2 : i1;