aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-14 16:33:43 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-14 16:33:43 +0800
commit9bbfe0ccac3f503fa274f868efd27149e35ced01 (patch)
tree77f69d0cf20c8f37a2effeb4ca2e5ab1b05c88e6 /games
parent19f19f08ff09e61bdc8c5e44ca5a0f3c3364f3bf (diff)
downloadfreebsd-ports-gnome-9bbfe0ccac3f503fa274f868efd27149e35ced01.tar.gz
freebsd-ports-gnome-9bbfe0ccac3f503fa274f868efd27149e35ced01.tar.zst
freebsd-ports-gnome-9bbfe0ccac3f503fa274f868efd27149e35ced01.zip
- Support staging
- Define DOCS option
Diffstat (limited to 'games')
-rw-r--r--games/plonx/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/plonx/Makefile b/games/plonx/Makefile
index 0316e775f17f..1936703af6b0 100644
--- a/games/plonx/Makefile
+++ b/games/plonx/Makefile
@@ -14,16 +14,15 @@ PORTDOCS= README
LDFLAGS+= -lncurses
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-build:
${CC} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/${PORTNAME} \
${WRKSRC}/${PORTNAME}.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>