aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-05-17 02:20:04 +0800
committerkwm <kwm@FreeBSD.org>2011-05-17 02:20:04 +0800
commit9e43b839c61e0888f8922ce6fa72074be12cd380 (patch)
tree13a5271d3d2e355df63b233ce12e65596e2ad1be /games
parentf26ac25b0a0f88cf383edd72ca97d01e558ceba8 (diff)
downloadfreebsd-ports-gnome-9e43b839c61e0888f8922ce6fa72074be12cd380.tar.gz
freebsd-ports-gnome-9e43b839c61e0888f8922ce6fa72074be12cd380.tar.zst
freebsd-ports-gnome-9e43b839c61e0888f8922ce6fa72074be12cd380.zip
Update to 1.1.0.
Update mirrors. Use USE_XZ liblzma check, only works with the pkgconfig file. Add workaround for systems where liblzma is in base. PR: ports/156114 Submitted by: myself Approved by: maintainer timeout (45 days)
Diffstat (limited to 'games')
-rw-r--r--games/openttd/Makefile33
-rw-r--r--games/openttd/distinfo4
-rw-r--r--games/openttd/files/liblzma.pc19
-rw-r--r--games/openttd/pkg-plist4
4 files changed, 44 insertions, 16 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 9888731a861f..7b50d6ee3832 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -6,11 +6,14 @@
#
PORTNAME= openttd
-PORTVERSION= 1.0.5
+PORTVERSION= 1.1.0
CATEGORIES= games
MASTER_SITES= http://gb.binaries.openttd.org/binaries/releases/${PORTVERSION}/ \
http://ftp.snt.utwente.nl/pub/games/openttd/binaries/releases/${PORTVERSION}/ \
- #SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+ http://cz.binaries.openttd.org/openttd/binaries/releases/${PORTVERSION}/ \
+ http://de.binaries.openttd.org/binaries/releases/${PORTVERSION}/ \
+ http://us.binaries.openttd.org/binaries/releases/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-source
MAINTAINER= danfe@FreeBSD.org
COMMENT= An open source clone of Microprose Transport Tycoon Deluxe
@@ -22,7 +25,7 @@ LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix-dir="${PREFIX}" --data-dir="${DATADIR_REL}"
-USE_BZIP2= yes
+USE_XZ= yes
USE_GMAKE= yes
INSTALLS_ICONS= yes
MAKE_JOBS_SAFE= yes
@@ -53,11 +56,13 @@ MAN6= ${PORTNAME}.6
DESKTOP_ENTRIES="OpenTTD" "${COMMENT}" "${PORTNAME}" "${PORTNAME}" \
"Game;Simulation;StrategyGame;" ${FALSE}
-PORTDOCS= 32bpp.txt HOWTO_compile_lang_files.txt elrail.svg \
- elrail_tile.png elrail_track.png landscape.html \
+PORTDOCS= 32bpp.txt HOWTO_compile_lang_files.txt admin_network.txt \
+ elrail.svg elrail_tile.png elrail_track.png landscape.html \
landscape_externals.html landscape_grid.html multiplayer.txt \
obg_format.txt obm_format.txt obs_format.txt \
- ottd-colour-palette.gif ottd-colourtext-palette.png tileh.png
+ ottd-colourtext-palette.png tileh.png
+
+.include <bsd.port.pre.mk>
pre-everything::
.if !defined(WITH_MIDI_PLAYER)
@@ -73,12 +78,16 @@ pre-everything::
post-patch:
# Remove extra (vendor-provided) CFLAGS and LDFLAGS and make the port more
# LOCALBASE safe
- @${REINPLACE_CMD} -e '1250,1252d ; s,/usr/local,${LOCALBASE},' \
+ @${REINPLACE_CMD} -e '1355,1355d ; s,/usr/local,${LOCALBASE},' \
+ ${WRKSRC}/config.lib
+# Use custom libzma.pc for when we use libzma from base.
+.if ${OSVERSION} >= 900012 || (${OSVERSION} >= 800505 && ${OSVERSION} < 900000)
+ @${REINPLACE_CMD} \
+ -e 's|pkg-config liblzma|pkg-config ${FILESDIR}/liblzma.pc|g' \
${WRKSRC}/config.lib
-# FreeBSD has strndup(3) since 701101
- @${REINPLACE_CMD} -e '/__NetBSD_Version__/s,$$, || (defined(__FreeBSD_version) \&\& __FreeBSD_version > 701100),' \
- -e 's,def __NetBSD__, defined(__NetBSD__) || defined(__FreeBSD__),' \
- ${WRKSRC}/src/string_func.h
+.else
+LIB_DEPEND+= lzma.5:${PORTSDIR}/archivers/xz
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
@@ -106,4 +115,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/openttd/distinfo b/games/openttd/distinfo
index 92511b0c5114..e016e7ff14c3 100644
--- a/games/openttd/distinfo
+++ b/games/openttd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openttd-1.0.5-source.tar.bz2) = c353626b16b4b781db3c3c61f0ad651f5701e50f87439c4005b4456b63db09f8
-SIZE (openttd-1.0.5-source.tar.bz2) = 5684796
+SHA256 (openttd-1.1.0-source.tar.xz) = 290b482efa4229a0ef35660178787bc458fdf6bd982c95aee252cde77e500447
+SIZE (openttd-1.1.0-source.tar.xz) = 4901356
diff --git a/games/openttd/files/liblzma.pc b/games/openttd/files/liblzma.pc
new file mode 100644
index 000000000000..b479beb6e6cb
--- /dev/null
+++ b/games/openttd/files/liblzma.pc
@@ -0,0 +1,19 @@
+#
+# Author: Lasse Collin
+#
+# This file has been put into the public domain.
+# You can do whatever you want with this file.
+#
+
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: liblzma
+Description: General purpose data compression library
+URL: http://tukaani.org/xz/
+Version: 5.0.0
+Cflags: -I${includedir}
+Libs: -L${libdir} -llzma
+Libs.private: -D_THREAD_SAFE -pthread
diff --git a/games/openttd/pkg-plist b/games/openttd/pkg-plist
index b38c4a59bfa1..f06bb891e8b1 100644
--- a/games/openttd/pkg-plist
+++ b/games/openttd/pkg-plist
@@ -2,12 +2,12 @@ bin/openttd
share/pixmaps/openttd.32.xpm
%%DATADIR%%/ai/compat_0.7.nut
%%DATADIR%%/ai/compat_1.0.nut
+%%DATADIR%%/ai/compat_1.1.nut
@dirrm %%DATADIR%%/ai
%%DATADIR%%/gm/no_music.obm
%%DATADIR%%/gm/orig_win.obm
@dirrm %%DATADIR%%/gm
-%%DATADIR%%/data/openttdd.grf
-%%DATADIR%%/data/openttdw.grf
+%%DATADIR%%/data/openttd.grf
%%DATADIR%%/data/opntitle.dat
%%DATADIR%%/data/orig_dos.obg
%%DATADIR%%/data/orig_dos.obs