aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2000-08-17 14:34:50 +0800
committerkris <kris@FreeBSD.org>2000-08-17 14:34:50 +0800
commit9fa515b893148d1f341f903f89c00b54ca32e457 (patch)
treefe34fbff31bcc959b81e6e7b39a6c2a267a829d1 /games
parent93eba540fbe2ceeb1348c559f1cdad4a1b23dfd1 (diff)
downloadfreebsd-ports-gnome-9fa515b893148d1f341f903f89c00b54ca32e457.tar.gz
freebsd-ports-gnome-9fa515b893148d1f341f903f89c00b54ca32e457.tar.zst
freebsd-ports-gnome-9fa515b893148d1f341f903f89c00b54ca32e457.zip
Make this setgid games to avoid world-writable files
Diffstat (limited to 'games')
-rw-r--r--games/mirrormagic/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/games/mirrormagic/Makefile b/games/mirrormagic/Makefile
index 31203a5ff59a..7f8f7c99b66c 100644
--- a/games/mirrormagic/Makefile
+++ b/games/mirrormagic/Makefile
@@ -23,7 +23,7 @@ post-extract:
@(cd ${WRKDIR}; ${CP} ${FILESDIR}/RAY.* .; uudecode *.uu; ${RM} *.uu)
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/mirrormagic ${PREFIX}/bin
+ ${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/mirrormagic ${PREFIX}/bin
@${MKDIR} ${PREFIX}/share/mirrormagic/graphics
${INSTALL_DATA} ${WRKSRC}/graphics/* ${PREFIX}/share/mirrormagic/graphics
@${MKDIR} ${PREFIX}/share/mirrormagic/sounds
@@ -35,7 +35,8 @@ do-install:
.for file in CHANGES COPYRIGHT DISCLAIMER README
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/mirrormagic
.endfor
-# @${CHMOD} a=rwx ${PREFIX}/share/mirrormagic/data
- @${CHMOD} a=rw ${PREFIX}/share/mirrormagic/data/RAY.*
+# @${CHMOD} 664 ${PREFIX}/share/mirrormagic/data
+ @${CHOWN} root:games ${PREFIX}/share/mirrormagic/data/RAY.*
+ @${CHMOD} 664 ${PREFIX}/share/mirrormagic/data/RAY.*
.include <bsd.port.mk>