aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-03-27 05:56:25 +0800
committernemysis <nemysis@FreeBSD.org>2014-03-27 05:56:25 +0800
commita4799624861e3f670ecd8eee6992e35002124a40 (patch)
treef9435091a93547ca3039438f39ba09fa53ccc535 /games
parent0dbbdcb5c3fc70ffe95fb43299aae6526614d139 (diff)
downloadfreebsd-ports-gnome-a4799624861e3f670ecd8eee6992e35002124a40.tar.gz
freebsd-ports-gnome-a4799624861e3f670ecd8eee6992e35002124a40.tar.zst
freebsd-ports-gnome-a4799624861e3f670ecd8eee6992e35002124a40.zip
- Change Makefile header, use my name and @FreeBSD.org email
- Change master site - Remove TODO from DOCS - Change REINPLACE, cosmetical changes
Diffstat (limited to 'games')
-rw-r--r--games/blockrage/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/games/blockrage/Makefile b/games/blockrage/Makefile
index b659e00a014d..e412b5758cfe 100644
--- a/games/blockrage/Makefile
+++ b/games/blockrage/Makefile
@@ -1,4 +1,4 @@
-# Created by: nemysis <nemysis@gmx.ch>
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
# $FreeBSD$
PORTNAME= blockrage
@@ -6,7 +6,7 @@ PORTVERSION= 0.2.3
PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}_icons${EXTRACT_SUFX}:icons
@@ -19,7 +19,8 @@ USE_SDL= sdl image mixer
GNU_CONFIGURE= yes
ALL_TARGET= ${PORTNAME}
-PORTDOCS= ChangeLog KNOWN_BUGS README TODO
+PORTDOCS= ChangeLog KNOWN_BUGS README
+OPTIONS_DEFINE= DOCS
INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
@@ -29,14 +30,12 @@ SUB_FILES= ${PORTNAME}
DESKTOP_ENTRIES="Block Rage" "" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" ""
-OPTIONS_DEFINE= DOCS
-
post-patch:
- @${REINPLACE_CMD} \
- -e 's|prefix=/usr/local|prefix=${PREFIX}| ; \
- s|MYCC=gcc|MYCC?=${CC}| ; \
- s|-s -O2 -Wall|| ; \
- s|sdl-config|$(SDL_CONFIG)| ; \
+ @${REINPLACE_CMD} -e \
+ 's|prefix=/usr/local|prefix=${PREFIX}|; \
+ s|MYCC=gcc|MYCC?=${CC}|; \
+ s|-s -O2 -Wall||; \
+ s|sdl-config|$(SDL_CONFIG)|; \
s|MAKE=make|MAKE=${MAKE}|' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|gcc -s|${CC}|' \