aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2018-08-01 02:41:30 +0800
committerzeising <zeising@FreeBSD.org>2018-08-01 02:41:30 +0800
commita53df5e7ca6da97d66d740eac2dafb2f671ba021 (patch)
tree71f4780cd34e184b043831e0db99b92f22e0da0d /games
parent31723f2783ac216daf5099cb46ec62951738bf9d (diff)
downloadfreebsd-ports-gnome-a53df5e7ca6da97d66d740eac2dafb2f671ba021.tar.gz
freebsd-ports-gnome-a53df5e7ca6da97d66d740eac2dafb2f671ba021.tar.zst
freebsd-ports-gnome-a53df5e7ca6da97d66d740eac2dafb2f671ba021.zip
Switch to xorgproto instead of individual packages
Upstream used to distribute protocol headers as separate packages, but has decided to merge those to a common package, named xorgproto. This update tracks that change. * Add a new port, x11/xorgproto, with are protocol headers for xorg. * Hook the new protocol port to the build and to infrastructure in bsd.xorg.mk. * Update all ports with a dependency on any of the old *proto packages to instead depend on xorgproto. Bump portrevision. * Delete the old *proto packages, update MOVED. PR: 230023 Submitted by: zeising Approved by: portmgr (antoine) exp-run by: antoine
Diffstat (limited to 'games')
-rw-r--r--games/doom/Makefile4
-rw-r--r--games/fkiss/Makefile4
-rw-r--r--games/xjig/Makefile4
-rw-r--r--games/xpilot-ng-client/Makefile5
-rw-r--r--games/xtrojka/Makefile4
5 files changed, 12 insertions, 9 deletions
diff --git a/games/doom/Makefile b/games/doom/Makefile
index 6dccf7eec358..2f13f52c7c92 100644
--- a/games/doom/Makefile
+++ b/games/doom/Makefile
@@ -3,7 +3,7 @@
PORTNAME= doom
PORTVERSION= 1.10
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= IDSOFTWARE/source
DISTNAME= doomsrc
@@ -21,7 +21,7 @@ NO_CDROM= Redistribution is limited, see license; Requested by id Software
ONLY_FOR_ARCHS= i386
USES= gmake zip
-USE_XORG= x11 sm xextproto xext
+USE_XORG= x11 sm xorgproto xext
NO_WRKSUBDIR= yes
DATADIR= ${DMDIR}
diff --git a/games/fkiss/Makefile b/games/fkiss/Makefile
index c4ca7c46030b..a9c6217ee622 100644
--- a/games/fkiss/Makefile
+++ b/games/fkiss/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fkiss
PORTVERSION= 0.33a
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= http://www2s.biglobe.ne.jp/~yav/soft/fkiss/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/a//}
@@ -25,7 +25,7 @@ BROKEN_armv7= fails to compile: passing char * to parameter of incompatible typ
EXTRA_PATCHES= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.diff
USES= gmake
-USE_XORG= x11 xproto
+USE_XORG= x11 xorgproto
GNU_CONFIGURE= yes
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
AUTOMAKE="${TRUE}"
diff --git a/games/xjig/Makefile b/games/xjig/Makefile
index 1376f56aa327..2631a863728e 100644
--- a/games/xjig/Makefile
+++ b/games/xjig/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xjig
PORTVERSION= 2.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= XCONTRIB/games
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Jigsaw puzzle game for X11
USES= compiler tar:tgz
-USE_XORG= x11 xproto xext
+USE_XORG= x11 xorgproto xext
MAKEFILE= Makefile.Linux
PLIST_FILES= bin/xjig man/man1/xjig.1.gz
diff --git a/games/xpilot-ng-client/Makefile b/games/xpilot-ng-client/Makefile
index 0ae633f52b4e..135277676343 100644
--- a/games/xpilot-ng-client/Makefile
+++ b/games/xpilot-ng-client/Makefile
@@ -1,11 +1,14 @@
# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-PORTREVISION= 4
+PORTREVISION= 5
PKGNAMESUFFIX= -client
COMMENT= Enhanced version of XPilot (client program)
MASTERDIR= ${.CURDIR}/../xpilot-ng-server
+USE_XORG= x11 xext xxf86misc
+USE_GL= gl
+
.include "${MASTERDIR}/Makefile"
diff --git a/games/xtrojka/Makefile b/games/xtrojka/Makefile
index c3535fdc4254..5058e2c91310 100644
--- a/games/xtrojka/Makefile
+++ b/games/xtrojka/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xtrojka
PORTVERSION= 1.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SUNSITE/games/arcade/tetris
DISTNAME= ${PORTNAME}${PORTVERSION:C/\.//g}
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}${PORTVERSION:C/\.//g}
MAINTAINER= ports@edwinm.ik.nu
COMMENT= Game of skill similar to T*tris
-USE_XORG= x11 xt xproto xaw xmu xext
+USE_XORG= x11 xt xorgproto xaw xmu xext
MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
INSTALL_TARGET= install PREFIX=${STAGEDIR}${PREFIX}