aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-27 00:39:14 +0800
committerbapt <bapt@FreeBSD.org>2013-04-27 00:39:14 +0800
commita9e406d4f73b8159743603b7499b85c6e084503f (patch)
treed124c4d6f965d5152806ebfbf40e1b5a25860ddb /games
parent8057e31698ebdc787d8715981347b119d4799a21 (diff)
downloadfreebsd-ports-gnome-a9e406d4f73b8159743603b7499b85c6e084503f.tar.gz
freebsd-ports-gnome-a9e406d4f73b8159743603b7499b85c6e084503f.tar.zst
freebsd-ports-gnome-a9e406d4f73b8159743603b7499b85c6e084503f.zip
Convert from USE_GETTEXT to USES= gettext
While here: - Trim some headers - Convert to new options framework
Diffstat (limited to 'games')
-rw-r--r--games/ceferino/Makefile24
-rw-r--r--games/ltris/Makefile12
-rw-r--r--games/ninix-aya/Makefile20
-rw-r--r--games/vdrift/Makefile15
-rw-r--r--games/xmoto/Makefile10
5 files changed, 34 insertions, 47 deletions
diff --git a/games/ceferino/Makefile b/games/ceferino/Makefile
index 64d100cdd3e2..e4489604792c 100644
--- a/games/ceferino/Makefile
+++ b/games/ceferino/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ceferino
-# Date created: 2006-01-11
-# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-#
+# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
# $FreeBSD$
-#
PORTNAME= ceferino
PORTVERSION= 0.97.8
@@ -22,17 +18,17 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD}
CEFEDIRS= ima music levels sounds
-OPTIONS= NLS "Native Language Support" on
+OPTIONS_DEFINE= NLS DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
PLIST_SUB+= NLS=""
FLAG_NLS= true
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-extract:
@@ -55,10 +51,10 @@ do-install:
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC} && \
${INSTALL_DATA} AUTHORS ChangeLog README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/ltris/Makefile b/games/ltris/Makefile
index 9765bf3634c4..f0a591d35ba1 100644
--- a/games/ltris/Makefile
+++ b/games/ltris/Makefile
@@ -17,14 +17,14 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --localstatedir=${DATADIR}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
.endif
post-patch:
@@ -38,4 +38,4 @@ post-install:
@${CHMOD} 0664 ${DATADIR}/${PORTNAME}.hscr
@${CHOWN} root:games ${DATADIR}/${PORTNAME}.hscr
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/ninix-aya/Makefile b/games/ninix-aya/Makefile
index e250a97a7944..24154b400cd7 100644
--- a/games/ninix-aya/Makefile
+++ b/games/ninix-aya/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ninix-aya
-# Date created: 6 Dec 2003
-# Whom: UMENO Takashi
-#
+# Created by: UMENO Takashi
# $FreeBSD$
-#
PORTNAME= ninix-aya
PORTVERSION= 4.3.9
@@ -29,14 +25,14 @@ USE_PYTHON= yes
USE_GNOME= pygtk2
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
DOCSDIR= ${PREFIX}/share/doc/ninix
.endif
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
@@ -48,13 +44,13 @@ post-patch:
-e 's,lib/ninix,libexec/ninix,' \
-e 's,/doc,/share/doc/ninix,' \
${WRKSRC}/Makefile
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e '/docdir)$$/d' \
${WRKSRC}/Makefile
.endif
-.if defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e '/localedir/d' \
${WRKSRC}/Makefile
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/vdrift/Makefile b/games/vdrift/Makefile
index 40f9a00ebdb9..5e3a36bc9cf7 100644
--- a/games/vdrift/Makefile
+++ b/games/vdrift/Makefile
@@ -33,19 +33,18 @@ DATE_VERSION= 2010-06-30
SUB_FILES= pkg-message
-OPTIONS= DEBUG "Additional debug information" off \
- NLS "Internationalization support " on
+OPTIONS_DEFINE= DEBUG NLS DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
SCONS_ARGS+= release=0
.else
SCONS_ARGS+= release=1
.endif
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
PLIST_SUB+= NLS=""
FLAG_NLS= true
.else
@@ -74,7 +73,7 @@ do-install:
${FIND} * -type f -name "*.po" -exec ${INSTALL_DATA} "{}" "${DATADIR}/po/{}" \;
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for FILE in docs/AUTHORS docs/README
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
@@ -84,4 +83,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 047830bbe580..22cecf766b83 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -47,11 +47,7 @@ DESKTOP_ENTRIES="XMoto" \
"Game;SportsGame;ArcadeGame;" \
false
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800067
-BROKEN= does not compile due to missing getline()
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MASIAN_TTF}
RUN_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/TrueType/bkai00mp.ttf:${PORTSDIR}/chinese/arphicttf
@@ -61,7 +57,7 @@ CONFIGURE_ARGS+=--without-asian-ttf-file
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
CONFIGURE_ENV+= LIBS="-lintl"
.else
@@ -77,4 +73,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>