aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-03-11 10:07:28 +0800
committernemysis <nemysis@FreeBSD.org>2014-03-11 10:07:28 +0800
commitaacd1db9587d4ba968dd94fd704a8c4e1ed5ba2e (patch)
tree70182069e9539b64b9c3c7c0b29bce154d34d2eb /games
parent78a2a8d2b371074edf8e632899bf0d5132555394 (diff)
downloadfreebsd-ports-gnome-aacd1db9587d4ba968dd94fd704a8c4e1ed5ba2e.tar.gz
freebsd-ports-gnome-aacd1db9587d4ba968dd94fd704a8c4e1ed5ba2e.tar.zst
freebsd-ports-gnome-aacd1db9587d4ba968dd94fd704a8c4e1ed5ba2e.zip
- Remove TODO from DOCS
- Change REINPLACE, cosmetical changes - Strip executable - Add pkg-message PR: ports/187432 Submitted by: Jonas Hofmann <freebsd-pr@jhofmann.se> Reviewed by: Horia Racoviceanu <horia@racoviceanu.com>
Diffstat (limited to 'games')
-rw-r--r--games/icebreaker/Makefile33
-rw-r--r--games/icebreaker/files/pkg-message.in13
2 files changed, 31 insertions, 15 deletions
diff --git a/games/icebreaker/Makefile b/games/icebreaker/Makefile
index 07b63cafbadd..e3d66b082c92 100644
--- a/games/icebreaker/Makefile
+++ b/games/icebreaker/Makefile
@@ -21,28 +21,31 @@ USES= gmake
USE_SDL= mixer sdl
PORTDOCS= ChangeLog README README.SDL README.ifyoumakechanges \
- README.themes TODO
+ README.themes
OPTIONS_DEFINE= DOCS
+SUB_FILES= pkg-message
+
post-patch:
- @${REINPLACE_CMD} \
- -e 's|CC=gcc|CC?=gcc| ; \
- s|sdl-config|$(SDL_CONFIG)| ; \
- s|prefix=/usr/local|prefix=${STAGEDIR}${PREFIX}| ; \
- s|datadir=$$(prefix)/share|datadir=${STAGEDIR}${PREFIX}/share| ; \
- s|mandir=$$(prefix)/share/man|mandir=${STAGEDIR}${PREFIX}/man| ; \
- s|highscoredir=/var/local/lib/games|highscoredir=/var/games| ; \
- s|CFLAGS=|CFLAGS+=| ; \
- s|OPTIMIZE=-O3|OPTIMIZE=| ; \
- s|$$(CC) $$(CFLAGS)|$$(CC) $$(LDFLAGS) $$(CFLAGS)| ; \
- s|install -s -g games|install -g games| ; \
- s|install -s -m 755|install -m 755| ; \
- s|chown -f games:games|chown -f root:games| ; \
- s|$$(SRC:.c=.d)|$$(SRC:.c)|' \
+ @${REINPLACE_CMD} -e \
+ 's|CC=gcc|CC?=gcc|; \
+ s|sdl-config|$(SDL_CONFIG)|; \
+ s|prefix=/usr/local|prefix=${STAGEDIR}${PREFIX}|; \
+ s|datadir=$$(prefix)/share|datadir=${STAGEDIR}${PREFIX}/share|; \
+ s|mandir=$$(prefix)/share/man|mandir=${STAGEDIR}${PREFIX}/man|; \
+ s|highscoredir=/var/local/lib/games|highscoredir=/var/games|; \
+ s|CFLAGS=|CFLAGS+=|; \
+ s|OPTIMIZE=-O3|OPTIMIZE=|; \
+ s|$$(CC) $$(CFLAGS)|$$(CC) $$(LDFLAGS) $$(CFLAGS)|; \
+ s|install -s -g games|install -g games|; \
+ s|install -s -m 755|install -m 755|; \
+ s|chown -f games:games|chown -f root:games|; \
+ s|$$(SRC:.c=.d)|$$(SRC:.c)|' \
${WRKSRC}/Makefile
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
diff --git a/games/icebreaker/files/pkg-message.in b/games/icebreaker/files/pkg-message.in
new file mode 100644
index 000000000000..219d2e629116
--- /dev/null
+++ b/games/icebreaker/files/pkg-message.in
@@ -0,0 +1,13 @@
+===============================================================================
+
+IceBreaker has been installed.
+
+
+When you have problems with usage please reinstall
+
+cd /usr/ports/games/icebreaker ; make deinstall ; make clean ; make reinstall
+
+
+Have fun!
+
+===============================================================================