aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2018-07-02 01:00:10 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2018-07-02 01:00:10 +0800
commitad29f56250fda323cfacdc7e3689a05453647dbe (patch)
treedfc737110a8896f5432ec528ec751c5e29b632ee /games
parentc14ddaebddeb6a10ec43fc20e02bf692fe67bdfd (diff)
downloadfreebsd-ports-gnome-ad29f56250fda323cfacdc7e3689a05453647dbe.tar.gz
freebsd-ports-gnome-ad29f56250fda323cfacdc7e3689a05453647dbe.tar.zst
freebsd-ports-gnome-ad29f56250fda323cfacdc7e3689a05453647dbe.zip
FreeOrion is a free, open source, turn-based space empire and
galactic conquest (4X) computer game being designed and built by the FreeOrion project. FreeOrion is inspired by the tradition of the Master of Orion games, but is not a clone or remake of that series or any other game. WWW: http://www.freeorion.org/
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/freeorion/Makefile48
-rw-r--r--games/freeorion/distinfo3
-rw-r--r--games/freeorion/files/patch-boost16729
-rw-r--r--games/freeorion/files/patch-cmake_make__versioncpp.py23
-rw-r--r--games/freeorion/pkg-descr7
-rw-r--r--games/freeorion/pkg-plist14
7 files changed, 125 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index d2d3ee4756f3..edf26224bf93 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -310,6 +310,7 @@
SUBDIR += freedroidrpg
SUBDIR += freeminer
SUBDIR += freeminer-default
+ SUBDIR += freeorion
SUBDIR += freera
SUBDIR += freesweep
SUBDIR += freesynd
diff --git a/games/freeorion/Makefile b/games/freeorion/Makefile
new file mode 100644
index 000000000000..dd9468565949
--- /dev/null
+++ b/games/freeorion/Makefile
@@ -0,0 +1,48 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= freeorion
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.4.8-rc1
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Turn-based space empire and galactic conquest game
+
+LICENSE= GPLv2 CC-BY-SA-3.0
+LICENSE_COMB= multi
+
+LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
+ libboost_python27.so:devel/boost-python-libs@${PY_FLAVOR}
+
+USE_GITHUB= yes
+
+USES= cmake compiler:c++14-lang python:2.7
+
+PORTDOCS= ChangeLog.md README.md
+PORTDATA= *
+
+OPTIONS_DEFINE= DOCS TEST HEADLESS
+OPTIONS_SUB= yes
+
+TEST_CMAKE_BOOL= BUILD_TESTING
+TEST_TEST_TARGET= unittest
+TEST_USES= localbase
+
+HEADLESS_DESC= Build only headless components: server and AI
+HEADLESS_CMAKE_BOOL= BUILD_HEADLESS
+HEADLESS_USES_OFF= openal
+HEADLESS_USE_OFF= SDL=sdl2 GL=gl,glu,glew
+HEADLESS_LIB_DEPENDS_OFF= \
+ libfreetype.so:print/freetype2 \
+ libogg.so:audio/libogg \
+ libvorbis.so:audio/libvorbis \
+ libpng.so:graphics/png
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/freeorion/distinfo b/games/freeorion/distinfo
new file mode 100644
index 000000000000..d0976f8aaca2
--- /dev/null
+++ b/games/freeorion/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530197828
+SHA256 (freeorion-freeorion-v0.4.8-rc1_GH0.tar.gz) = 0963ec3573b8ab71278687a9ad143fda083171b651adab6b3cf6705fe93741c9
+SIZE (freeorion-freeorion-v0.4.8-rc1_GH0.tar.gz) = 106224914
diff --git a/games/freeorion/files/patch-boost167 b/games/freeorion/files/patch-boost167
new file mode 100644
index 000000000000..88d6983e655b
--- /dev/null
+++ b/games/freeorion/files/patch-boost167
@@ -0,0 +1,29 @@
+commit 618568705a0ca37ffd9e88d08cda3d3601d01d98
+Author: Dmitry Marakasov <amdmi3@amdmi3.ru>
+Date: Fri Jun 29 19:42:52 2018 +0300
+
+ Fix compatibility with boost 1.67.0
+
+diff --git CMakeLists.txt CMakeLists.txt
+index 5b2fe63a7..4d26e06a2 100644
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -204,11 +204,17 @@ find_package(Boost ${MINIMUM_BOOST_VERSION}
+ log_setup
+ regex
+ serialization
+- python
+ signals
+ system
+ thread
+ REQUIRED)
++if(${Boost_VERSION} GREATER 106699) # boost >= 1.67
++ find_package(Boost COMPONENTS python27 REQUIRED)
++ set(Boost_PYTHON_LIBRARY ${Boost_PYTHON27_LIBRARY})
++else()
++ find_package(Boost COMPONENTS python REQUIRED)
++endif()
++
+ find_package(ZLIB REQUIRED)
+ if(NOT BUILD_HEADLESS)
+ find_package(Freetype REQUIRED)
diff --git a/games/freeorion/files/patch-cmake_make__versioncpp.py b/games/freeorion/files/patch-cmake_make__versioncpp.py
new file mode 100644
index 000000000000..121cd96f30b7
--- /dev/null
+++ b/games/freeorion/files/patch-cmake_make__versioncpp.py
@@ -0,0 +1,23 @@
+--- cmake/make_versioncpp.py.orig 2017-09-03 13:21:52 UTC
++++ cmake/make_versioncpp.py
+@@ -115,19 +115,7 @@ if system() == 'Darwin':
+
+ version = "0.4.7.1"
+ branch = ""
+-build_no = INVALID_BUILD_NO
+-
+-try:
+- branch = check_output(['git', 'rev-parse', '--abbrev-ref', 'HEAD']).strip()
+- if (branch == "master") or (branch[:7] == "release"):
+- branch = ""
+- else:
+- branch += " "
+- commit = check_output(["git", "show", "-s", "--format=%h", "--abbrev=7", "HEAD"]).strip()
+- timestamp = float(check_output(["git", "show", "-s", "--format=%ct", "HEAD"]).strip())
+- build_no = ".".join([datetime.utcfromtimestamp(timestamp).strftime("%Y-%m-%d"), commit])
+-except:
+- print "WARNING: git not installed or not setup correctly"
++build_no = "portbld"
+
+ for generator in generators:
+ generator.execute(version, branch, build_no, build_sys)
diff --git a/games/freeorion/pkg-descr b/games/freeorion/pkg-descr
new file mode 100644
index 000000000000..3a9b8b5b34f2
--- /dev/null
+++ b/games/freeorion/pkg-descr
@@ -0,0 +1,7 @@
+FreeOrion is a free, open source, turn-based space empire and
+galactic conquest (4X) computer game being designed and built by
+the FreeOrion project. FreeOrion is inspired by the tradition of
+the Master of Orion games, but is not a clone or remake of that
+series or any other game.
+
+WWW: http://www.freeorion.org/
diff --git a/games/freeorion/pkg-plist b/games/freeorion/pkg-plist
new file mode 100644
index 000000000000..4f8a92012b92
--- /dev/null
+++ b/games/freeorion/pkg-plist
@@ -0,0 +1,14 @@
+%%NO_HEADLESS%%bin/freeorion
+bin/freeorionca
+bin/freeoriond
+%%NO_HEADLESS%%lib/freeorion/libGiGi.so
+%%NO_HEADLESS%%lib/freeorion/libGiGiSDL.so
+lib/freeorion/libfreeorioncommon.so
+lib/freeorion/libfreeorionparse.so
+%%NO_HEADLESS%%share/applications/freeorion.desktop
+share/icons/hicolor/128x128/apps/freeorion.png
+share/icons/hicolor/16x16/apps/freeorion.png
+share/icons/hicolor/24x24/apps/freeorion.png
+share/icons/hicolor/256x256/apps/freeorion.png
+share/icons/hicolor/32x32/apps/freeorion.png
+share/icons/hicolor/64x64/apps/freeorion.png