aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-07-02 23:37:41 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-07-02 23:37:41 +0800
commitae9c0af0e212c499a237af74c63a8e43b2febd58 (patch)
tree82509208793936148c79e35c6976a3d25159190e /games
parentb06fd40db5412937f0e6a9f5df1a1bf421a2e285 (diff)
downloadfreebsd-ports-gnome-ae9c0af0e212c499a237af74c63a8e43b2febd58.tar.gz
freebsd-ports-gnome-ae9c0af0e212c499a237af74c63a8e43b2febd58.tar.zst
freebsd-ports-gnome-ae9c0af0e212c499a237af74c63a8e43b2febd58.zip
- Update to 1.5.8
Diffstat (limited to 'games')
-rw-r--r--games/redeclipse/Makefile10
-rw-r--r--games/redeclipse/distinfo5
-rw-r--r--games/redeclipse/files/patch-src_Makefile12
3 files changed, 15 insertions, 12 deletions
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
index 16dba637941d..855222c38833 100644
--- a/games/redeclipse/Makefile
+++ b/games/redeclipse/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= redeclipse
-PORTVERSION= 1.5.3
-PORTREVISION= 1
+PORTVERSION= 1.5.8
DISTVERSIONPREFIX= v
CATEGORIES= games
@@ -13,7 +12,7 @@ COMMENT= Single-player and multi-player first-person ego-shooter
LICENSE= MIT ZLIB
LICENSE_COMB= multi
-RUN_DEPENDS= redeclipse-data>=1.5.3:games/redeclipse-data
+RUN_DEPENDS= redeclipse-data>=${PORTVERSION}:games/redeclipse-data
BROKEN_sparc64= does not build on sparc64
@@ -35,7 +34,7 @@ OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED
OPTIONS_DEFAULT= CLIENT DEDICATED OPTIMIZED_CFLAGS
CLIENT_DESC= Build client
-CLIENT_USE= GL=gl SDL=image,mixer,sdl XORG=x11
+CLIENT_USE= GL=gl SDL=image2,mixer2,sdl2 XORG=x11
CLIENT_ALL_TARGET= client
CLIENT_PLIST_FILES= bin/${PORTNAME} libexec/${PORTNAME} \
share/pixmaps/${PORTNAME}.ico
@@ -53,6 +52,9 @@ DEDICATED_PLIST_FILES= bin/${PORTNAME}_server libexec/${PORTNAME}_server
OPTIMIZED_CFLAGS_CFLAGS= -O3 -fomit-frame-pointer -ffast-math
OPTIMIZED_CFLAGS_CXXFLAGS= -O3 -fomit-frame-pointer -ffast-math
+post-extract:
+ @${RM} -rf ${WRKSRC}/src/include ${WRKSRC}/src/lib
+
post-patch:
@${REINPLACE_CMD} -e 's|CLIENT_PCH=.*|CLIENT_PCH=|' ${WRKSRC}/src/Makefile
diff --git a/games/redeclipse/distinfo b/games/redeclipse/distinfo
index 99e17dc8d896..42969ed0163e 100644
--- a/games/redeclipse/distinfo
+++ b/games/redeclipse/distinfo
@@ -1,2 +1,3 @@
-SHA256 (red-eclipse-base-v1.5.3_GH0.tar.gz) = 94b0475c7c161d4fdb59a9ebe0d740ec07b1934abf348d78d4f127f369d912f8
-SIZE (red-eclipse-base-v1.5.3_GH0.tar.gz) = 10276808
+TIMESTAMP = 1493412473
+SHA256 (red-eclipse-base-v1.5.8_GH0.tar.gz) = 6c8ddfa140c7c0669d8b1e47043de7b1b9dd9b586edf531f74202ac6bb1209aa
+SIZE (red-eclipse-base-v1.5.8_GH0.tar.gz) = 13842382
diff --git a/games/redeclipse/files/patch-src_Makefile b/games/redeclipse/files/patch-src_Makefile
index 9be9a614207c..95c5dfa2c78b 100644
--- a/games/redeclipse/files/patch-src_Makefile
+++ b/games/redeclipse/files/patch-src_Makefile
@@ -1,13 +1,13 @@
---- src/Makefile.orig 2015-07-18 02:54:17 UTC
+--- src/Makefile.orig 2016-06-30 04:34:23 UTC
+++ src/Makefile
-@@ -80,8 +80,8 @@ else
+@@ -82,8 +82,8 @@ else
BIN_SUFFIX=_native
endif
endif
--CLIENT_INCLUDES= $(INCLUDES) -I/usr/X11R6/include `sdl-config --cflags`
--CLIENT_LIBS= -Lenet -lenet -L/usr/X11R6/lib -lX11 `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL
-+CLIENT_INCLUDES= $(INCLUDES) -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`
-+CLIENT_LIBS= -Lenet -lenet -L${LOCALBASE}/lib -lX11 `${SDL_CONFIG} --libs` -lSDL_image -lSDL_mixer -lz -lGL
+-CLIENT_INCLUDES= $(INCLUDES) -I/usr/X11R6/include `sdl2-config --cflags`
+-CLIENT_LIBS= -Lenet -lenet -L/usr/X11R6/lib -lX11 `sdl2-config --libs` -lSDL2_image -lSDL2_mixer -lz -lGL
++CLIENT_INCLUDES= $(INCLUDES) -I${LOCALBASE}/include `sdl2-config --cflags`
++CLIENT_LIBS= -Lenet -lenet -L${LOCALBASE}/lib -lX11 `sdl2-config --libs` -lSDL2_image -lSDL2_mixer -lz -lGL
endif
ifneq (,$(findstring linux,$(PLATFORM)))
CLIENT_LIBS+= -lrt