aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-11-28 11:23:46 +0800
committerswills <swills@FreeBSD.org>2012-11-28 11:23:46 +0800
commitaf1a7246ec31646aca16d17aae457089c69dbed5 (patch)
treedcccc969a8b055362e1acb6edd88bf3613846513 /games
parentb557d1d57c8f118ccb64b4b9f4c781f4e3f5e391 (diff)
downloadfreebsd-ports-gnome-af1a7246ec31646aca16d17aae457089c69dbed5.tar.gz
freebsd-ports-gnome-af1a7246ec31646aca16d17aae457089c69dbed5.tar.zst
freebsd-ports-gnome-af1a7246ec31646aca16d17aae457089c69dbed5.zip
An EVE Online skill monitoring standalone application.
WWW: http://gtkevemon.battleclinic.com PR: ports/173909 Feature safe: yes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/gtkevemon/Makefile35
-rw-r--r--games/gtkevemon/distinfo2
-rw-r--r--games/gtkevemon/pkg-descr3
-rw-r--r--games/gtkevemon/pkg-plist4
5 files changed, 45 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index ca447676282e..41b991499fed 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -361,6 +361,7 @@
SUBDIR += gti
SUBDIR += gtkatlantic
SUBDIR += gtkballs
+ SUBDIR += gtkevemon
SUBDIR += gtklife
SUBDIR += gtkpool
SUBDIR += gtkradiant
diff --git a/games/gtkevemon/Makefile b/games/gtkevemon/Makefile
new file mode 100644
index 000000000000..43b488129caf
--- /dev/null
+++ b/games/gtkevemon/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= gtkevemon
+DISTVERSION= 1.8-135
+CATEGORIES= games
+MASTER_SITES= https://bitbucket.org/BattleClinic/${PORTNAME}/get/
+DISTNAME= Version%20${DISTVERSION}
+
+MAINTAINER= feld@feld.me
+COMMENT= A skill monitoring standalone application for EVE Online
+
+LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24
+
+FETCH_ARGS= -pRr
+CHANGESET= 8fa5c0b5f16b
+WRKSRC= ${WRKDIR}/BattleClinic-${PORTNAME}-${CHANGESET}/${PORTNAME}
+
+USE_GNOME= gtk20 libxml2
+USE_GMAKE= yes
+USE_PKGCONFIG= both
+USE_OPENSSL= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(shell pkg-config --libs openssl)|-L${OPENSSLLIB} -lssl -lcrypto|' ${WRKSRC}/src/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/gtkevemon ${PREFIX}/bin/gtkevemon
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/icon/gtkevemon.desktop ${PREFIX}/share/applications/gtkevemon.desktop
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/icon/gtkevemon.png ${PREFIX}/share/pixmaps/gtkevemon.png
+
+.include <bsd.port.post.mk>
diff --git a/games/gtkevemon/distinfo b/games/gtkevemon/distinfo
new file mode 100644
index 000000000000..8d5e4885c386
--- /dev/null
+++ b/games/gtkevemon/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Version%201.8-135.tar.gz) = b2608c37a8b2c3d9f696db74dfdde809c72010c3aecde9162eb1d68215096e84
+SIZE (Version%201.8-135.tar.gz) = 306699
diff --git a/games/gtkevemon/pkg-descr b/games/gtkevemon/pkg-descr
new file mode 100644
index 000000000000..5c9fdb77fba8
--- /dev/null
+++ b/games/gtkevemon/pkg-descr
@@ -0,0 +1,3 @@
+An EVE Online skill monitoring standalone application.
+
+WWW: http://gtkevemon.battleclinic.com
diff --git a/games/gtkevemon/pkg-plist b/games/gtkevemon/pkg-plist
new file mode 100644
index 000000000000..473d2cfe25bc
--- /dev/null
+++ b/games/gtkevemon/pkg-plist
@@ -0,0 +1,4 @@
+share/applications/gtkevemon.desktop
+share/pixmaps/gtkevemon.png
+bin/gtkevemon
+@dirrmtry share/applications