aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-10-30 05:25:51 +0800
committerantoine <antoine@FreeBSD.org>2014-10-30 05:25:51 +0800
commitaf35fae537b43d55de237f6ab18e30a9e285f062 (patch)
treef0b8cd2d86ea97ad3f4fe0e6bf647101e7991a07 /games
parentd874abd54e0b67b33b03a903e63fdc07e70e5d0c (diff)
downloadfreebsd-ports-gnome-af35fae537b43d55de237f6ab18e30a9e285f062.tar.gz
freebsd-ports-gnome-af35fae537b43d55de237f6ab18e30a9e285f062.tar.zst
freebsd-ports-gnome-af35fae537b43d55de237f6ab18e30a9e285f062.zip
Mark BROKEN and deprecate again: fails to link
c++ -Wl,-O1 -pthread -Wl,-rpath,/usr/local/lib/qt4 -o build/Hall tmp/obj/main.o tmp/obj/DJContact.o tmp/obj/DJChat.o tmp/obj/DJContactItem.o tmp/obj/DJSocket.o tmp/obj/DJHallController.o tmp/obj/DJDownloadManager.o tmp/obj/DJProgressDialog.o tmp/obj/DJStyle.o tmp/obj/DJTabWidget.o tmp/obj/DJMainWindow.o tmp/obj/HallUtility.o tmp/obj/UILogin.o tmp/obj/UIHallSetup.o tmp/obj/UISelectDownloadServer.o tmp/obj/UIAboutHall.o tmp/obj/DJApplication.o tmp/obj/moc_DJContact.o tmp/obj/moc_DJChat.o tmp/obj/moc_DJSocket.o tmp/obj/moc_DJHallController.o tmp/obj/moc_DJDownloadManager.o tmp/obj/moc_DJProgressDialog.o tmp/obj/moc_DJStyle.o tmp/obj/moc_DJTabWidget.o tmp/obj/moc_DJMainWindow.o tmp/obj/moc_UILogin.o tmp/obj/moc_UIHallSetup.o tmp/obj/moc_UISelectDownloadServer.o tmp/obj/moc_UIAboutHall.o tmp/obj/moc_DJApplication.o tmp/obj/qrc_Hall.o tmp/obj/qrc_HallMutable.o -L/usr/local/lib/qt4 -L/usr/local/lib ../Base/build/libBaseStatic.a -lQtSvg -L/usr/local/lib/qt4 -L/usr/local/lib -lQtXml -lQtGui -lQtNetwork -lQtCore /usr/bin/ld: //usr/local/lib/libX11.so.6: invalid DSO for symbol `XGrabKey' definition //usr/local/lib/libX11.so.6: could not read symbols: Bad value c++: error: linker command failed with exit code 1 (use -v to see invocation) *** [build/Hall] Error code 1 Reported by: pkg-fallout
Diffstat (limited to 'games')
-rw-r--r--games/djgame2/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/games/djgame2/Makefile b/games/djgame2/Makefile
index 6dd852f2ee85..faa7b39fb88d 100644
--- a/games/djgame2/Makefile
+++ b/games/djgame2/Makefile
@@ -14,6 +14,10 @@ COMMENT= bluedj contains many popular online games
LICENSE= GPLv2 # or later
LICENSE_FILE= ${WRKSRC}/LICENSE.GPL
+BROKEN= Fails to link
+DEPRECATED= Resurrected but not fixed
+EXPIRATION_DATE= 2014-11-29
+
USE_QT4= gui qt3support qmake_build uic_build rcc_build moc_build svg
USES= dos2unix zip
DOS2UNIX_FILES= Base/src/DJGraphicsChessTimerItem.cpp